Probléme Division par zéro – Image invisible

  • WordPress :4.9.9
  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #2229220
    Xman34
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : ?
    • Thème utilisé : Teddy (payant)

    Problème(s) rencontré(s) :

    Bonjour.

    J’ai un gros probléme avec Mon wordpress.

    J’avais un WordPress + woocommerce + Théme Teddy en local, tout fonctionnait bien.

    J’ai passé le wordpress sur un serveur et activé un certificat SSL.

    Mon problème est montré sur le fichier joint : « Division by zero ». En fait mon image de produit ne s’affiche pas (ca marche partout ailleurs, juste ici sur la fiche produit, ça bug).

    Le code qui bug est le suivant :

    $visible_thumbs           = $vertical ? intval( $image_size['height'] / $thumb_size['height'] ) : 
            intval( $image_size['width'] / $thumb_size['width'] ); 

    Concrétement le $thum_size[‘width’] semble etre zéro.

    Donc je regarde plus haut dans le code :

    $thumb_size               = get_option( 'shop_thumbnail_image_size' );

    Donc faut croire que get_option renvoi un tableau avec zéro comme taille d’image alors que ça ne devrait pas.

    D »ou ça peut venir? Ca me fait ce warning et mon image ne veut pas s’afficher du coup….

     

    Je précise que ce théme est payant et je n’arrive pas à contacter celui qu’il l’a fait.

    C’est impossible sur le site ou j’ai acheté le théme Woocommerce Teddy. Merci

    • Ce sujet a été modifié le il y a 2 weeks et 2 days par  Xman34.
    • Ce sujet a été modifié le il y a 2 weeks et 2 days par  Xman34.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.