[Résolu] Problème d’installation WordPress

  • WordPress :5.2
  • Statut : résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #2267418
    polyteradmin
    Participant
    Initié WordPress
    16 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : MySQL v.5.6
    • Thème utilisé : Installation de WP, donc thème de base
    • Extensions en place : pas de plugins pour le moment
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.aikido-club-peageois.fr

    Problème(s) rencontré(s) :

    Après avoir installé un Worpress tout neuf, au moment où j’ai tapé http://www.aikido-club-peageois.fr/wp-admin/install.php pour finaliser l’installation, j’ai reçu le message d’erreur suivant :
    <b>Parse error</b>: syntax error, unexpected T_ARRAY, expecting ‘)’ in <b>/home/aikidoclp/www/wp-includes/load.php</b> on line <b>711</b>

    Je précise que je n’ai rien changé dans les fichiers d’installation

    Voici la copie de la ligne de code 711 : function wp_skip_paused_plugins( array $plugins ) {

    Le problème existe aussi bien avec une installation avec le module 1-Click d’OVH et en installation directe via Filezilla.

     

    Voici tout ce que j’ai fait :

    • J’ai décidé de refaire une installation complète du site pour upgrader la base de données MySQL v.5.5 vers la version 5.6
    • Pour ce faire, j’ai sauvegardé la BDD via PHPMyadmin (export), puis je l’ai supprimée à la fois dans PHPMyadmin et dans mon interface OVH
    • Sauvegardé le site existant en local, puis supprimé tous les fichiers de la racine www via Filezilla
    • Demandé la création d’une nouvelle BDD à OVH (MySQL v.5.6) => OK
    • Injecté la sauvegarde de l’ancienne BDD à partir de l’interface d’OVH => OK
    • Installé le module WordPress par la solution 1-click d’OVH en mode avancé pour le lier à la nouvelle BDD => OK
    • Ensuite, message d’erreur.
    • J’ai appelé OVH qui a constaté le problème en direct et qui m’a dit qu’ils reviendraient vers moi après avoir interrogé leurs services techniques
    • Ensuite, je me suis dit que si le problème venait de l’installation 1-click, je pouvais essayer une installation manuelle
    • J’ai donc désinstallé le module 1-click, téléchargé WordPress 5.2.2 que j’ai installé via Filezilla et ai entré la commande http://www.aikido-club-peageois.fr/wp-admin/install.php comme indiqué par WP.
    • Résultat : message d’erreur identique à la première fois : <b>Parse error</b>: syntax error, unexpected T_ARRAY, expecting ‘)’ in <b>/home/aikidoclp/www/wp-includes/load.php</b> on line <b>711</b>

    Voilà, j’espère avoir été assez précis pour vous permettre de m’aider à trouver l’origine du problème et surtout, trouver une solution.

    En dernier ressort, je tenterai de remettre le sauvegarde de l’ancien site qui est en version 3.9, mais si j’ai décidé de faire les mises à jour, c’est que beaucoup de plugins ne fonctionnent plus avec cette ancienne version.

    Merci d’avance pour votre aide

    Christophe

    #2267419
    PhiLyon
    Modérateur
    Maître WordPress
    23339 contributions

    Bonjour.

    Ton PHP est en 4.4.9, ça ne marchera jamais, chez OVH passes en 7.3 https://docs.ovh.com/fr/hosting/mutualise-configurer-la-version-de-php-depuis-votre-espace-client/

    🙂

    #2267428
    polyteradmin
    Participant
    Initié WordPress
    16 contributions

    Merci PhiLyon,

    J’ai plusieurs questions alors :

    1. Comment sais-tu que le PHP est en 4.4.9 ? Je vais dans <code class=”action”>Hébergements/Informations généralesmais ne vois pas la version de PHP dans mon interface OVH.
    2. N’ayant pas cette information, je n’ai pas non plus le bouton avec ‘…’ qui me donnerais la possibilité de modifier la configuration. Aurais-tu une idée du pourquoi ?

    Je suis en train d’appeler OVH pour vérifier ce point et voir comment passer en version 7.3

    #2267429
    PhiLyon
    Modérateur
    Maître WordPress
    23339 contributions

    Tu dois être resté sur l’installation en 1 click.

    Comment sais-tu que le PHP est en 4.4.9 ?

    C’est écrit-là https://sitecheck.sucuri.net/results/www.aikido-club-peageois.fr

    🙂

    #2267440
    polyteradmin
    Participant
    Initié WordPress
    16 contributions

    Merci beaucoup

    C’était effectivement ça le problème.

    Sur les conseils d’OVH, je viens de créer le fichier .ovhconfig et l’ai placé à la racine puis réinstallé le module 1-click, avec ma base de données MySQL 5.5. J’ai donc maintenant accès à l’administration du site.

    Par contre, je ne retrouve pas les articles de mon ancien site.

    Pourrais-tu me donner un coup de main pour les récupérer ?

     

    #2267459
    PhiLyon
    Modérateur
    Maître WordPress
    23339 contributions

    Tu as importé la base de données que tu avais sauvegardé ?

    🙂

    #2267483
    polyteradmin
    Participant
    Initié WordPress
    16 contributions

    Oui, via l’interface OVH.

    Je viens de faire un essai en désinstallant le module 1-clik et en réinjectant la sauvegarde initiale du site.

    Ça marche. Sauf que je n’arrive plus à me reconnecter à l’interface de gestion de wordpress. Mes identifiants ne marchent plus.

    J’ai donc fait une demande pour modifier mon mot de passe, mais ça ne marche pas : je tourne en boucle.

    Y aurait-il un moyen de voir le mot de passe enregistré via Filezilla ?

    #2267492
    polyteradmin
    Participant
    Initié WordPress
    16 contributions

    J’ai trouvé cette astuce, mais cela ne marche pas :

    1. Aller sur ton <b>Espace Client </b>puis dans <b>Administration de MySQL</b>
    2. Chercher la ligne correspondant à ta base de donnée (si tu en as plusieurs) et cliquer sur le bouton <b>Administration</b>, ce qui ouvrira PHPMyAdmin 😉
    3. Dans la liste des tables à gauche, trouver la ligne « <b>wp_users</b> » et cliquer sur l’icone à gauche du nom.
    4. Dans la partie de droite, trouver la ligne correspondant à ton compte (c’est la ligne qui a pour le champ user_nicename la valeur « admin » normalement) ; cliquer sur l’icone en forme de crayon pour éditer cette ligne.
    5. Effacer le contenu du champ de formulaire de la troisième ligne (user_pass), taper ce que tu veux comme mot de passe puis sélectionner <b>MD5</b> dans la liste déroulante à gauche, sur la même ligne puis cliquer sur le bouton <b>Exécuter</b> en bas de la page

    #2267501
    Li-An
    Modérateur
    Maître WordPress
    22240 contributions

    Bonjour, il y a une épidémie de problème de connexion sur les sites WP 5.2.2 chez OVH qui nécessite de passer en https (cf de nombreux sujets sur le forum).

    #2267512
    Flobogo
    Modérateur
    Maître WordPress
    15664 contributions

    Bonjour,

    J’attendais d’avoir tout lu pour répondre, mais dès le questionnaire, j’ai vu que le site était en HTTP. Donc, juste pour compléter la réponse de Li-An :

    #2268280
    polyteradmin
    Participant
    Initié WordPress
    16 contributions

    Merci pour votre aide à tous.

    J’ai finalement opté pour un site tout neuf.
    Cependant, j’ai été obligé d’utiliser le tuto pour passer tout le site en HTTPS, car même si le SSL était activé, le site en module 1-click s’installait en HTTP. Ça a marché impec.

    Par contre, j’ai tenté la transformation en HTTPS pour un autre de mes blogs, et là, gros problème. Heureusement que j’avais fais une sauvegarde de la BDD avant de passer l’outil “Search-Replace-DB”.

    Merci encore

     

    #2268484
    Flobogo
    Modérateur
    Maître WordPress
    15664 contributions

    Bonjour,

    Tant mieux si le problème est résolu pour ce site.

    mais vous dites que vous avez toujours un problème de HTTP sur un autre site :

    j’ai tenté la transformation en HTTPS pour un autre de mes blogs, et là, gros problème.

    Tôt ou tard, vous allez rencontrer des problèmes de fonctionnement. Il faut passer au HTTPS. N’hésitez pas à ouvrir un nouveau sujet en détaillant la configuration de ce site là, et on essaiera de vous aider en détail

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.