[Résolu] Problème d’import d’une BDD – erreur #1273

  • WordPress :4.6.1
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #1568364
    chti56
    Participant
    Chevalier WordPress
    347 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : v5.5 chez OVH
    • Thème utilisé :
    • Extensions en place : Akeeba
    • Nom de l’hébergeur :  Import chez OVH
    • Adresse du site : local

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai installé en local (WP 4.6.1) un nouveau site et maintenant je souhaite l’installer sur un hébergement OVH existant dans une nouvelle BDD.
    J’ai fait un Export de ma BDD locale et lorsque je tente un Import de cette BDD chez OVH j’obtiens cette erreur:

    #1273 – Unknown collation: ‘utf8mb4_unicode_520_ci’ ovh

    Quelqu’un aurait-il déjà rencontré ce problème ?
    La base de données chez OVH est la version MySQL 5.5

    Je précise qu’en local j’utilise XAMPP . Je n’ai pas utilisé AKEEBA qui me donnait aussi une erreur.

    Merci pour votre aide.

    JP

    #1568368
    simo.freelance@gmail.com
    Participant
    Initié WordPress
    41 contributions

    La version de ton MySQL sur OVH est ancienne,

    Edit ton fichier sql (que tu as exporté en local) en remplaçant les utf8mb64 par utf8, enregistre le, puis importe le dans ovh, ça devrait marcher.

    #1568377
    chti56
    Participant
    Chevalier WordPress
    347 contributions

    Bonjour,

    Merci pour cette réponse rapide.

    J’avais déjà faite cette manip, que je viens de re-tenter…, et j’ai maintenant cette erreur:

    #1273 – Unknown collation: ‘utf8_unicode_520_ci

    JP

    #1568411
    chti56
    Participant
    Chevalier WordPress
    347 contributions

    Je crains que le problème vienne du fait que chez OVH j’ai une base MySQL 5.5 alors qu’avec la version Xampp que j’utilise j’ai une version 5.6

    Quelle pourrait être la solution… à part re-créer le site directement sur l’hébergement ?? Ce que je souhaitais éviter…

     

    JP

    #1568418
    sebastienserre
    Gestionnaire du forum
    Maître WordPress
    810 contributions

    Bonjour,

    Changer d’hébergeur?

    perso j’en suis revenu d’OVH…

    #1568420
    chti56
    Participant
    Chevalier WordPress
    347 contributions

    Ça peut être une solution à long terme.. mais (hélas) pas pour le moment !!

    JP

    #1568524
    simo.freelance@gmail.com
    Participant
    Initié WordPress
    41 contributions

    Nul besoin de changer votre hébergeur.

    Remplacer les utf8_unicode_520_ci par utf8_unicode_ci, puis tester a nouveau, si vous avez encore des erreur uploder votre zip ou tar de BDD quelque part pour qu’on puisse le télécharger et voir et le tester ça nous donnera plus des idée sur le problème.

    #1568577
    chti56
    Participant
    Chevalier WordPress
    347 contributions

    Bonjour,

    J’ai maintenant cette erreur:

    MySQL a répondu: Documentation

    #1273 - Unknown collation: 'utf8mb4_unicode_520_ci'

    Merci pour votre aide.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1568579
    chti56
    Participant
    Chevalier WordPress
    347 contributions

    Je viens de faire un import concluant (!) en changeant utf8mb4_unicode_520_ci  par  utf8_unicode_ci

    JP

    #1583047
    enzo1908@live.be
    Participant
    Initié WordPress
    1 contributions

    Salut Chti.

    J’ai exactement le même problême que toi.

     

    Pourrais tu me dire quel est la démarche que tu as suivi (en détail) pour changer utf8mb4_unicode_520_ci  par  utf8_unicode_ci stp ?

    #1612681
    Jo Numerikax
    Participant
    Initié WordPress
    4 contributions

    Bonsoir

    Je n’ai pas connaissance si le problème a été résolu mais si vous souhaitez mon apport voici comment faire :

    1- Exportez la base de donnée en personnalisant

    2- Maximisez ensuite la compatibilité en choisissant MYSQL 40 dans la liste proposée

    3- Editez la base de donnée exportée en remplancant TYPE= par ENGINE=

    4- Enrégistrez votre nouvelle base de donnée et importez la sur votre site en ligne

    J’ai exécuté ce moyen et cela a très bien fonctionné pour mon site.

    #1613231
    pierrebena
    Participant
    Initié WordPress
    1 contributions

    Bonjour à tous,

    Idem problème que vous… Je fais une migration de site et problème d’importation de la base de donnée avec même erreur :
    #1273 – Unknown collation: ‘utf8mb4_unicode_520_ci  (juste un “mb4” en plus > cf. photo jointe)
    Migration : Site source (chez OVH) en MySQL 5.6 >>> Site cible (chez OVH) en MySQL 5.5

    Je pense donc avoir le même problème que vous.
    J’ai fait les manips décrites plus haut mais le problème n’est pas résolu, cela ne fonctionne pas…

    Je n’ai pas réussi à faire la manip juste au-dessus (post du 7 janvier 2017 à 0 h 53 min) car je n’ai pas l’option demandée
    (2- Maximisez ensuite la compatibilité en choisissant MYSQL 40 dans la liste proposée) à l’export depuis myphpadmin de OVH…
    Merci de faire part de vos solutions ou recherches SVP.

    Merci par avance.

    😉

    Suite : Je viens de faire la demande à OVH (via formulaire) quelle démarche devons-nous faire pour passer en 5.6 (pour info, j’ai l’offre “kimsufi”, je ne sais pas si cela va être possible !)  -> Je vous tiens informé dès que j’ai des news…

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1614009
    Jo Numerikax
    Participant
    Initié WordPress
    4 contributions

    Salut

    Pour moi, c’était du web local sur mon site ligne … Pour OVH je n’ai pas de connaissance à cet effet mais je crois que le sujet portait dans son ensemble sur le web local vers une mise en ligne

    Pour Maximiser, il suffit de personnaliser (Afficher toute les options possibles) et choisir tout en bas avant “Options de création d’objets” dans Maximiser la compatibilité avec un système de base de données ou un ancien serveur MySQL : (NONE)

    Merci

    #1616524
    Cédric
    Participant
    Initié WordPress
    2 contributions

    il faut utiliser search replace DB

    https://github.com/interconnectit/Search-Replace-DB

    Vous le téléchargez.
    Ensuite vous le mettez à la racine de votre site.
    Vous appelez le dossier via votre navigateur (exemple : https://www.monsite.fr/Search-Replace-DB-master/).
    Ensuite vous cliquez sur “convert to uf8 unicode”

    Pour finir, exportez votre base puis importez là chez ovh.

     

     

    #1841046
    orlydeguyzo
    Participant
    Initié WordPress
    14 contributions

    <div class=”bbp-reply-author”>Bonsoir fraternitevehuiah@gmail.com,
    <div class=”bbp-author-role”></div>
    </div>
    <div>Merci pour ton aide.</div>
    <div></div>
    <div>J’ai essayé les mamips que tu as détaillé et ça marché.</div>
    <div>Ma BDD est bien installé.</div>
    <div>Encore une fois merci</div>

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.