[Résolu] Problème diaporama thème mystile

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • WordPress :4.7
  • Statut : résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #1636588

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7
    • Thème utilisé : Mystile
    • Extensions en place : woocommerce
    • Nom de l’hébergeur : local
    • Adresse du site : local

    Problème(s) rencontré(s) :

    Bonjour,

    Après maj vers wordpress 4.7.4, ou bien après derniere maj de woocommerce (aujourd’hui), et bien je n’ai plus le jolie diaporama d’image sur un produit 🙁 !!

    A la place les images se mettent les une en-dessous des autres… et quand je clique sur l’image c’est le lien URL de l’image qui s’affiche !

    Avez-vous eu ce problème ? Y a t’il quelque chose à faire ?

    Merci

    #1636622

    momofr@free.fr
    Participant
    Maître WordPress
    1118 contributions

    Salut, problème de javascript à priori, tester en désactivant toutes les extensions.

    Si ça marche, tu réactives petit à petit tes extensions et tu vas trouver la fautive.

    Solution à voir avec le dev du thème ou de l’extension.

    #1636627

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    Re bonjour,

    Merci

    Apparemment il y a une nouvelle version de Mystile disponible. La 1.3.19.

    Mais il n’y a pas de mise a jour automatique… donc je pense que ca vient de là!!
    Que dois-je faire ? Supprimer mon theme Mystile et le remplacer par le nouveau ?

    • Cette réponse a été modifiée le il y a 2 mois et 1 semaine par  noixdecoco.
    #1636681

    momofr@free.fr
    Participant
    Maître WordPress
    1118 contributions

    Le plus sûr c’est d’écraser ton thème via FTP. Le supprimer va sans doute te faire perdre des données de paramétrage.

    #1637023

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    Merci !

    J’ai rentré une clé et j’ai pu mettre à jour mon thème Mystile mais j’ai toujours le même problème. J’ai donc ensuite suivi votre conseil plus haut et j’ai désactivé toutes les extensions mais sans résultat.

    Une solution ?

    #1637106

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    C’était le theme enfant qui posait problème. Tout va bien maintenant mais je n’ai plus de theme enfant…

    Problème réglé en partie. Par contre, je ne sais pas bien ce qu’il faut mettre dans les réglages de woocommerce ?

    Dans woocommerce -> réglages -> comptes ?

    Il y a un champs avec écrit Page Mon compte » ?

    J’ai créé une page que j’ai appelé Mon compte et que j’ai associé à ce champs mais je vois pas à quoi cela sert ? Une idée ? Merci

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1637115

    Joss47
    Participant
    Maître WordPress
    1789 contributions

    Si tu as seulement crée la page sans ajouter le shortcode WooCommerce compte, cela ne fera rien.

    La page sert à afficher les informations du compte utilisateur WooCommerce.

    Le shortcode à insérer dans cette page est :

    [woocommerce_my_account]

    #1637120

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    Merci ! J’ ai donc ajouté le code en mode « texte » j’imagine.
    Ce qui est curieux c’est que où suis-je sensé trouver ce code ? Il s’affichait au survol du point interrogation mais sans possibilité de le copier.

    Merci beaucoup en tout cas 😉

    • Cette réponse a été modifiée le il y a 2 mois et 1 semaine par  noixdecoco.
    #1637133

    Joss47
    Participant
    Maître WordPress
    1789 contributions

    Quand tu installes WooCommerce il ajoute automatiquement les pages dont il a besoin pour fonctionner, donc cette page en fait partie.

    Sinon simplement sur la documentation de WooCommerce toutes ces informations sont notées 🙂

    #1637137

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    Donc j’ai encore une question… si possible 🙂 !

    L’url de ma page quand je clique sur mon compte c’est : /?page_id=615

    Si je ne suis pas connecté j’ai une erreur 404 !

    Si je suis connecté en tant qu’admin alors j’ai la même url /?page_id=615 et pas d’erreur 404..;

    Si je clique sur un des élément de la liste déroulante comme « commandes » par exemple, alors je suis redirigé vers la page ou j’ai mis le shortcode donné plus haut (la page mon compte) ?

    Est ce que c’est normal ? Ne devrais-je pas mettre le short code dans la page à l’ID=615 ? Mais je ne trouve pas cette page ?

    Et ce n’est pas normal qu’un client ne puisse pas se connecter en cliquant sur « mon compte » ? Que dois je faire ?

    #1637141

    noixdecoco
    Participant
    Chevalier WordPress
    270 contributions

    Bon ca a l’air de fonctionner, j’avais deux pages avec le short code. Je mets en résolu. Et j’ouvrirai une nouvellle discussion si nécessaire. Merci !

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.