Problème d’HTTPS

  • WordPress :4.9.4
  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2162013
    repasdietetique
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : ?
    • Thème utilisé : OCEANWP
    • Extensions en place :
    • Customer Chat for Facebook
    • Elementor Pro
    • Jetpack par WordPress.com
    • JustFreeThemes Assistant
    • Ocean Extra
    • PayPal for WooCommerce
    • Pixel Caffeine
    • Smush
    • Woo Checkout Field Editor Pro
    • WooCommerce
    • WooCommerce PayPal Express Checkout Gateway
    • WooCommerce Services
    • WooCommerce Stripe Gateway
    • WordPress Importer
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://repasdietetique.com/

    Problème(s) rencontré(s) : Bonjour, j’ai un soucis de HTTPS qui ne s’affiche pas sur toutes les pages de mon site, par exemple sur ma page d’accueil elle s’est bien mise (https://repasdietetique.com/), cependant, lorsque je me rend sur cette page ci ( http://repasdietetique.com/index.php/produit/21-guides-numeriques/ ), elle n’est pas en HTTPS. Savez-vous à quoi est-ce dû ? Merci à vous.

    #2162281
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    Bonjour,

    Vos deux URL dans les réglages de WP sont en HTTPS ?

    vous allez comment sur cette URL qui ne se met pas en HTTPS ? Car si je la tape en HTTPS ça fonctionne.

    Aussi vos permaliens ne sont pas bons, vous avez un index.php dans l’URL ce n’est guère bien, choisissez le permalien « Nom de l’article »

    #2162283
    PhiLyon
    Modérateur
    Maître WordPress
    19993 contributions

    Bonjour.

    Certaines images ne sont pas en https, vérifies.

    🙂

    #2162286
    PhiLyon
    Modérateur
    Maître WordPress
    19993 contributions

    Celles-là par exemple

    http://repasdietetique.com/wp-content/uploads/2018/06/Banni%C3%A8res_Verticales_JPG.jpg
    http://repasdietetique.com/wp-content/uploads/2018/05/Snow.png
    http://repasdietetique.com/wp-content/uploads/2018/06/Scooter.jpg
    http://repasdietetique.com/wp-content/uploads/2018/06/diet-1869131.jpg
    http://repasdietetique.com/wp-content/uploads/2018/05/8d2k7a3wmkq-bench-accounting.png
    http://repasdietetique.com/wp-content/uploads/2018/06/contact-rest_1.jpg

    🙂

    • Cette réponse a été modifiée le il y a 2 months par  PhiLyon.
    #2162395
    repasdietetique
    Participant
    Initié WordPress
    8 contributions

    Merci pour vos réponses, je viens de passer en « nom de l’article ». Et les réglages sont en HTTPS :

     

    A propos des images, apparement elles sont bien en HTTPS, je ne comprend pas pourquoi elles s’affichent en HTTP chez vous, comment puis-je modifier celà ? Merci. 

     

    Finalement, pour atterir sur la page qui n’est pas en HTTPS, il faut se rendre sur ce lien https://repasdietetique.com/ et par la suite cliquer sur l’un des boutons rose « Oui je profite de l’offre ».

     

    Bien à vous,

     

     

     

    • Cette réponse a été modifiée le il y a 2 months par  repasdietetique.
    #2162415
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    oui car tu n’as pas rentré l’URL sur tes boutons en HTTPS très certainement.
    Car si j’ajoute le produit au panier, une fois dans le panier si je clique sur le produit je suis bien redirigé sur une page en https

    #2162456
    repasdietetique
    Participant
    Initié WordPress
    8 contributions

    Super merci, problème résolu pour les pages de redirection ! Plus que un problème qui persiste, celui de l’affichage du cadenas vert à la place du « i » que voici : 

     

    Auriez-vous des solutions ? Est-ce que celà est dû aux images ? Merci à vous pour votre précieuse aide !

     

    #2162811
    repasdietetique
    Participant
    Initié WordPress
    8 contributions

    J’ai demandé à mon hébergeur OVH, apparemment le problème ne vient pas d’eux, je suis assez confus quant à l’origine du problème.

    #2165082
    repasdietetique
    Participant
    Initié WordPress
    8 contributions

    Toujours aucune solutions trouvée, c’est plutôt compliqué à résoudre comme problème.. 🙁

     

    #2165158
    Noaneo
    Participant
    Maître WordPress
    28293 contributions

    Bonjour,
    Avez-vous utilisé le script Search&Replace pour remplacer tous les urls de http à https ?
    Code de redirection ?  Etc..
    Avez-vous suivi ce tutoriel ? Il donne des sites pour tester HTTPS
    https://wpmarmite.com/wordpress-https/
    Merci

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.