Problème de sous-menu dans l’administration

  • WordPress :5.2
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #2282072
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : je ne sais pas où trouver cette info
    • Thème utilisé : Deli
    • Extensions en place : Askimet anti-spam / All-in-one-migration / child theme configurator custom sidebars / dowload manager / duplicator / Elementor / essential addons for elementor / tarteaucitron.js / woocommerce / Yoast SEO
    • Nom de l’hébergeur : OVH
    • Adresse du site : avistop.fr

    Problème(s) rencontré(s) :

    Bonjour.

    Il s’agit d’un site que j’ai mis en ligne cet été et qui est encore peu utilisé.
    La semaine dernière après avoir fait une mise à jour de mes plugin, j’ai constaté que je n’avais plus accès au sous-menu de extension, donc impossible d’en ajouter de nouvelles. Ores je souhaitais installé Google analytics et surtout mettre en place le certificat SSL pour passer en https (chose que je n’avais pas fait 🙁 )

    J’ai donc faire une restauration de sauvegarde, mais sans succès. Je n’avais même plus la possibilité de mettre à jour les plugin.
    Aujourd’hui j’ai pu mettre à jour tous mes plugin ainsi que wordpress grâce au ftp.
    J’ai également réussi le passage en https, même si a priori ce n’est pas une réussite à 100% (pas de cadenas pour la page d’accueil)

    Mais maintenant je n’ai toujours pas accès au sous menu d’extension ni à celui du tableau de bord et pire quand je veux aller sur le sous menu de réglages Général je suis automatiquement déconnecté du site.

    Je ne suis pas très calé niveau technique et je sèche dans mes recherches.
    Par avance merci pour vos pistes

    • Ce sujet a été modifié le il y a 3 weeks et 5 jours par  Ambroisie.
    #2282500
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

     

    Personne n’a une piste à me donner ? J’ai retourné le problème dans tous les sens et c’est l’impasse à chaque fois…

    Merci

    #2282501
    ferman
    Participant
    Maître WordPress
    1372 contributions

    Bonjour,

    Avez-vous aussi restauré la base de données? Autrement regardez cette possibilité.

    #2282506
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Bonjour ferman,

     

    j’ai fait une restauration de base de données comme suggéré, mais aucun différence.

    j’ai regardé aussi l’autre possiblité avec  :

    1. Désactiver les plugins
    2. Aller dans phpmyadmin, sauvegarder votre base de données, puis l’ouvrir  et aller dans la table wp_users. Là vous devez être listée. Vous relevez votre ID et allez dans user_meta vous regardez les lignes correspondant à cette ID et à la ligne wp capabilities vérifiez que vous avez bien a:1:{s:13:”administrator”;b:1;}.  Sinon il faudra mettre la bonne définition.Voir ce post pour cette possibilité.

    mais aucune différence…

    j’ai été voir dans table wp_options et chercher la ligne wp_user_roles (la 3e ou 4e page). Double cliquez sur la case option_value (cliquez droit dans cette case, sélectionnez tout, puis copiez) ressortez et collez le texte dans bloc notes. Comparez-le à  ce que vous voyez ici .

    Là la différence est de taille, ce que j’ai, est totalement différent, mais je suis incapable d’analyser les différences. Par contre dans cette 4ème page de discussion ils parlent de Yoast comme source de problème, hors j’ai Yoast . serait -ce une piste ?

    pour le problème de déconnexion quand je vais dans réglages – Général : Je me demande également si le passage en https n’y serait pas pour quelque chose. j’ai peut être loupé quelque chose

    #2282507
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    D’ailleurs, pardon, c’est toi qui parlait de Yoast comme source de soucis.

    Tu évoques un plugin pour le désinstaller, quel est-il ?

    Sachant que techniquement je ne peux plus installer de plugin directement via wordpress (au secours !)

    #2282517
    ferman
    Participant
    Maître WordPress
    1372 contributions

    Pouvez-vous copier/coller dans bloc notes ce que vous avez dans votre base de données pour la case option value et le mettre en pièce jointe dans votre réponse (il n’y a rien de confidentiel).

    Pour Yoast, je ne disais pas de le supprimer mais simplement que si on voulait le faire ce n’était pas évident. On a remarqué que plusieurs fois, avec Yoast, les droits (la case option/value) étaient chamboulés et que les droits admin avaient disparu.  Je voudrais vérifier si c’est le cas cette fois encore.

    #2282521
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Voici en PJ ce que j’ai dans option_value

    Merci !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2282536
    ferman
    Participant
    Maître WordPress
    1372 contributions

    Non, dans votre cas il n’y a pas de problème de droits. Vous avez php 7.0 et wordpress 5.2.4 (https://sitecheck.sucuri.net/results/avistop.fr). Votre version de store front (2.5.0) date un peu mais je ne crois pas que ce soit le problème. Pour le  cadenas avec avertissement  ce n’est pas  grave et pourra être arrangé quand vous aurez accès au tableau de bord.

     

    #2282538
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Bon c’est déjà ça…

    En effet je n’ai fait aucune mise à jour de mon thème (vu que je n’ai aucune alerte sur les mises à jours à faire)…

    je vais voir si je peux faire ça… néanmoins ayant un thème enfant, je ne suis pas sûre de la procédure en pssant par le ftp…

     

    et l’enquête continue pour mon soucis…

     

    merci !

    #2282566
    ferman
    Participant
    Maître WordPress
    1372 contributions

    1.Il est possible de se “logger” par l’adresse en https et l’adresse sans https.  Avez vous le même phénomène dans l’un et l’autre cas?

    2.Essayez de désactiver votre thème actuel et de le remplacer par un thème par défaut. Pour cela, allez encore une fois dans votre base de données->wp_options (page 2) regardez la pièce jointe et également ici . Vous pouvez d’abord vérifier si le problème vient du thème enfant (c’est possible selon ce que vous avez mis dans votre thème enfant) en remplaçant dans stylesheet par le nom du dossier du parent. Pour remplacer par un thème par défaut, mettez le nom du dossier (par ex: twentysixteen) dans les cases template et stylesheet.

    Copiez d’abord dans bloc note ce qui est dans les deux cases template et stylesheet pour ee pas faire d’erreur en le remettant.

    3.A la suite de ça, s’il n’y a pas d’amélioration, dans wp-config, vous pouvez passer define(‘WP_DEBUG’, false); en define(‘WP_DEBUG’, true); et voir si un message d’erreur s’affiche sur le site.  Vous le notez et repassez sur “false”.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2282570
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Alors j’étais persuadé avoir testé de me logger sans le https  mais a priori non puisque là je constate  que dans ce cas de figure j’ai accès à Réglage – Général !!!

    Donc que j’ai fait de travers ?  Car j’administre plusieurs sites et le premier pour lequel j’ai fait le passage en https, tout s’est bien passé et je peux me logger à l’admin en https et avoir accès à tout sans soucis.

     

    Par contre mon problème pour le sous-menu extension persiste et j’avoue que je ne sais pas dire depuis quand ce problème existe…

    Merci

     

    #2282573
    ferman
    Participant
    Maître WordPress
    1372 contributions

    Donc, les essais proposés plus haut doivent être faits en http, non https. Il faudra voir plus tard pour https. Essayez encore une fois de désactiver les extensions. Puis le thème, comme indiqué et de mettre debug: true. S’il y a un message il s’affichera sur le site et je pourrai (comm tout le monde) le voir.

    Le https est let’s encrypt ou autre chose?

    #2282574
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    Le https est let’s encrypt a priori

     

    Dans les étapes je bloque au point 3. :

    3.A la suite de ça, s’il n’y a pas d’amélioration, dans wp-config, vous pouvez passer define(‘WP_DEBUG’, false); en define(‘WP_DEBUG’, true); et voir si un message d’erreur s’affiche sur le site.  Vous le notez et repassez sur “false”.

    Le wp-config je ne le trouve pas dans la base de données, mais en passant par le ftp ?

     

    #2282575
    Ambroisie
    Participant
    Initié WordPress
    15 contributions

    donc j’ai trouvé et fait la manip : passer define(‘WP_DEBUG’, false); en define(‘WP_DEBUG’, true)

    et je n’ai aucun message d’erreur.

    que dois je faire maintenant ?

     

     

    #2282576
    ferman
    Participant
    Maître WordPress
    1372 contributions

    WP-config n’est pas dans  la base de données mais dans les fichiers wordpress (ftp) . Copiez-le  par filezilla , éditez-le avec notepad.++ , gardez une copie avant changement, puis faites le changement et renvoyez-le chez l’hébergeur.

15 sujets de 1 à 15 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.