problème de slug (pages inaccessibles) (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2349936
    yuna416
    Participant
    Initié WordPress
    9 contributions

    Ma configuration WP actuelle :

    – Version de WordPress : 5.4.2
    – Version de PHP/MySQL : 5.6.40 / 5.6.48
    – Thème utilisé : Divi Community Child Theme
    – Extensions en place : Akismet Anti-Spam (4.1.6), Autoptimize (2.7.5), EWWW Image Optimizer (5.6.0), Feed Them Social – for Twitter feed, Youtube, Pinterest and more (2.8.6), Forum_wordpress_fr (4.2), Imsanity (2.6.0), Rank Math SEO (1.0.45), Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder (2.2.8), UpdraftPlus – Backup/Restore (1.16.26)
    – Adresse du site : https://wp.sophrologie-cote-azur.fr
    – Nom de l’hébergeur : Apache / OVH

    Bonjour à tous,

    Si c’était le cas au départ, je ne peux plus accéder depuis plusieurs jours aux pages qui sont liées à la page parente “www.monsite/formation/…” lorsqu’elles sont publiées. Je ne peux y accéder que lorsqu’elles sont à l’état de brouillon. La page parente non plus n’est plus accessible.

    Si je modifie le slug et que je rajoute un “s” à formation, là ça fonctionne ! Mais je souhaite garde la version au singulier et aussi comprendre ce qui ne va pas.

    Comment expliquez-vous cela ? Que faire?

    Merci infiniment.

    #2349938
    PhiLyon
    Modérateur
    Maître WordPress
    26071 contributions

    Bonjour.

    Dans Outils lance l’état de santé du site, il te dira s’il y a un problème et notamment un conflit avec une extension.

    Je pense à Rank Math SEO.

    🙂

    #2349952
    yuna416
    Participant
    Initié WordPress
    9 contributions

    Bonjour et merci pour ta réponse !

    J’ai regardé et il n’y a rien hormis ma version PHP qui est trop vieille et que je compte mettre à jour au moment de la mise en ligne de la nouvelle version.

    Je viens de désactiver Rank Math SEO et le problème persiste 🙁

    #2349954
    ferman
    Participant
    Maître WordPress
    2696 contributions

    Bonjour,

    Vous avez des redirections anormales (voir pj). La plus importante est la deuxième (renvoi de https vers http). L’autre en découle sûrement. On ne sait pas comment vous avez créé vos redirections (ht access, l’hébergeur)? mais en tout cas il faut déjà corriger ça.

    • Cette réponse a été modifiée le il y a 6 jours et 15 heures par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2350033
    yuna416
    Participant
    Initié WordPress
    9 contributions

    Bonjour ferman,

    Merci ! En effet, mais elles se sont faites automatiquement.

    J’ai pu corriger la première, due à des doublons de pages pour des tests afin de comprendre l’origine de la deuxième.
    C’est surtout la deuxième que je cherche à comprendre et à annuler.

    La version http sans “s” c’est le site actuel, créé il y a longtemps avec un logiciel qui a apparemment disparu et qui n’est plus modifiable… J’ai tout passé en sécurisé via OVH pour la création du nouveau site, pour l’instant en sous domaine.

    Je viens de jeter un coup d’oeil au fichier .htaccess et rien 🙁
    J’ai également installé le plugin Redirection mais il ne me donne pas plus d’information et ne me propose pas de supprimer une redirection, seulement d’en créer.

     

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.