problème de référencement BING mais pas sur GOOGLE à cause du root (Créer un compte)

  • WordPress :6.0.1
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2415684
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Bonjour à tous,

    Je rencontre un problème avec le référencement de Bing. Mais tout fonctionne avec Google.

    Je vais tâcher d’être court et précis :

    Wordpress : 6.0.1

    De nombreuses extensions dont celles qui pourraient être la cause ? : Wordfence ; ithemes security ; bing webmaster ; AAM ; Akismet Anti-Spam ; Paid memberships ; Yoast SEO…

     

    Sur Bing wemaster tools, il est dit que le site ne peut-être indexé car :

    Non indexée en raison d’une directive NOINDEX

    L’URL ne peut pas s’afficher sur Bing

     

    Mais je ne sais pas où. J’ai cherché partout, enfin je pense, et même dans le head de la page principal il y a :

    <meta name=’robots’ content=’index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1′ />

     

    Aucun NOINDEX dans robots.txt ni dans htaccess.

     

    J’ai regardé dans URL avec balise noindex, sur Bing wemaster tools, et là !!!!

    Il affiche :

    / (root)

    Avec la dernière recherche le 15 juillet 2021 alors que je n’arrête pas de relancer l’indexation. Le fichier semble faire 35Ko mais je ne trouve aucun fichier de cette taille sur le serveur dans le répertoire de WordPress.

    A quoi correspond ce ROOT pour BING ? Où dois-je chercher ?

    Seo m’informe qu’il n’y a pas de balises NOINDEX… J’ai bien des pages réservées aux abonnés mais l’ensemble du site est accessible à tous…

    Et dans « réglages » ; « lecture » ; la case est bien décochée pour : « Demander aux moteurs de recherche de ne pas indexer ce site ».

    Si vous avez une idée de recherche je suis preneur.

    MERCI  😉

    Jérôme

    • Ce sujet a été modifié le il y a 1 mois par jerome.ammouial.
    • Ce sujet a été modifié il y a 4 semaines et 1 jour par Flobogo. Raison : déplacé en rubrique "discussion générale"
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2415691
    mathieu42
    Participant
    Maître WordPress
    1509 contributions

    « root » veut dire racine en anglais donc il s’agit de la page d’accueil.

    par contre dans le cœur de wordpress, il y a juste la case à cocher que vous avez déjà trouvée dans « lecture ». donc si quelque chose fait un blocage, cela vient d’une extension ou peut-être du thème. avez-vous testé un thème de base de wordpress pour voir si cela change quelque chose ?

    #2415696
    Lumiere de Lune
    Participant
    Maître WordPress
    20482 contributions

    Et l’url du site ? Ou bien on joue aux devinettes ?

    #2415705
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Merci à vous deux pour vos réponses.

    Alors non, je n’ai pas essayé de changer le thème. Et si je désactive une à une les extensions en redemandant « l’indexisation », ça se dit ?, Ça pourrait marcher ?

    Ensuite, pour l’adresse c’est :

    https://www.ammouial.xyz

    Merci encore pour votre soutien.

    Je testerai pour les extensions demain ou mardi… 👍🏻

    Merci encore.

    #2415718
    Lumiere de Lune
    Participant
    Maître WordPress
    20482 contributions

    L’url de la page d’accueil est bien en 200 https://www.webrankinfo.com/outils/header.php?url=https%3A%2F%2Fwww.ammouial.xyz%2F&ua=bingbot

    Par contre Bing annonce que « certains résultats ont été supprimés » https://www.bing.com/search?search=&q=site%3Aammouial.xyz&form=QBLH

    Tu as fait ton robots.txt manuellement et il n’est pas en UTF-8

    User-agent: *
    
    # On empêche l'indexation des dossiers sensibles
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wpcontent/cache
    Disallow: /trackback
    Disallow: /*.php$
    Disallow: /*.inc$
    Disallow: /*.gz$
    
    # On désindexe la page de connexion (contenu inutile)
    Disallow: /wp-login.php
    
    C'est peut être ça qui pose problème. Essaye de le supprimer pour l'instant
    #2415736
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Salut,

    J’ai supprimé le robots.txt et refait le test, toujours la même réponse de Bing. Pour le contenu supprimé… Je ne sais pas.

    Je me lance dans les désactivations successives d’extensions. Mais je n’ai droit qu’à 10 essais d’indexation par 24 heures… Donc cela se fera sur plusieurs jours.

    Je repasse aussi le robots.txt en UTF-8 ! Merci, je n’avais pas fait gaffe à ça du tout !!!!

    A bientôt si j’ai du neuf.

    #2415738
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    De retour,

    J’ai vérifié sur mon PC le robots.txt semble en UTF-8 d »après le bloc-note.

    J’ai désactivé l’un après l’autre :

    Advanced Access Manager : pareil,

    Akismet AntiSpam : pareil,

    3dflipbook : pareil,

    Contact Form7 : pareil,

    Duplicator : pareil,

    Gestionnaire de fichiers WP : pareil,

    Import Users from CSV : pareil,

    iThemes Security : pareil,

    iThemes Security : pareil,

    LoginPress – Customizing the WordPress Login Screen. : pareil,

    Newsletter : pareil,

    Bah ça fait plus de 10, je continue, j’ai pas dû comprendre ce truc non plus 🙂

    Newsletter – Addons Manager : pareil,

    Newsletter – Import : pareil,

    Newsletter – WP Users Integration : pareil,

    Paid Memberships Pro : pareil,

    Re-add text underline and justify : pareil,

    Remplisseur de formulaire PDF pour CF7 : pareil,

    Rise Blocks – A Complete Gutenberg Page builder : pareil,

    TablePress : pareil,

    User Switching : pareil,

    Wordfence Security : pareil, c’est celui sur lequel je doutais le plus…

    WP Mail SMTP : pareil,

    WP Maintenance Mode & Coming Soon : pareil,

    WP Rollback: pareil,

    WP-Optimize – Nettoyer, compresser, mettre en cache. : pareil,

    WPCode – Insert Headers, Footers, and Code Snippets : pareil,

    Yoast SEO : pareil,

    Yoast Test Helper : pareil,

    Bing Webmaster Url Submission : pareil,

    IndexNow : pareil,

    Ca y est, tout a été désactivé successivement mais pareil :

    <div class= »urlInspectionContainerContent »>
    <div class= »urlInspectionSectionTitle »>Non indexée en raison d’une directive NOINDEX</div>
    <div class= »urlInspectionSectionDescription »>L’URL ne peut pas s’afficher sur Bing</div>

    En relisant vos réponses je vois la question du thème. Je teste… : pareil…

    J’ai suivi vos conseils mais rien n’a abouti.  Merci quand même car psychologiquement je me sens moins seul 🙂

    Cela dit Bing qui ne référence pas mon site ce n’est pas vital, mais quand même j’aurais bien aimé comprendre ce qui ne va pas dans mon site 🙂

    Bonne journée

    #2415785
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Yo,

    Je pense qu’il y a bien un problème avec le robots.txt (qui rejoindrait ce que disait <span class= »bbp-author-name »>Lumiere de Lune</span>).

    Je l’ai supprimé mais quand je le demande avec https://www.ammouial.xyz/robots.txt il apparaît encore !!! Je l’ai modifié vite fait puis remis via ftp. Il apparaît toujours sous la même forme :

    ——————————-

    User-agent: *
    
    # On empêche l'indexation des dossiers sensibles
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wpcontent/cache
    Disallow: /trackback
    Disallow: /*.php$
    Disallow: /*.inc$
    Disallow: /*.gz$
    
    # On désindexe la page de connexion (contenu inutile)
    Disallow: /wp-login.php

    <hr />

    Alors que le fichier statique redéposé pour test est :

    <hr />

    User-agent: *
    Allow: /
    # On empêche l’indexation des dossiers sensibles
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wpcontent/cache
    Disallow: /trackback
    Disallow: /*.php$
    Disallow: /*.inc$
    Disallow: /*.gz$
    Disallow: /wp-login.php

    <hr />

    Donc il y a bien un souci.

    Je l’ai retiré de nouveau, il n’y a plus de robots.txt statique sur le serveur… Et il apparaît toujours…

    Pour l’historique j’avais Yoast, puis j’ai testé AIOSEO (qui lui le gère en dynamique), puis je suis repassé à Yoast. Le problème vient-il de là ?

    Je n’ai pas trouvé dans la base de données ce robots.txt dynamique mais je suis une bille en base de données 🙂 🙂

    Si vous avez des idées, quelles qu’elles soient !!!

    Merci.

     

    • Cette réponse a été modifiée le il y a 4 semaines et 1 jour par jerome.ammouial.
    #2415813
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Re,

    J’ai utilisé yoast seo test helper, j’ai supprimé grâce à lui toutes les données de yoast seo.

    J’ai recommencé les paramétrages.

    Il m’a proposé de créer un nouveau fichier robots.txt ! Cooool !

    Je l’ai créé.

    Mais toujours l’ancien qui apparaît quand on le cherche sur mon site…

    Retour case départ…

    #2415845
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    J’y pense, peut-être une histoire de cache. Pas celui du navigateur, que j’ai vidé, peut-être celui du serveur ?

    #2415889
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Re,

    C’était le VARNISH CACHE de l’hébergeur !

    Je l’ai purgé et le nouveau robots.txt est apparu.

    J’ai installé aussi Better Robots.txt (Index & Rank Booster by Pagup) Plugin, qui fera peut-être avancer le référencement sur BING.

    Si cela peu aider quelqu’un…

    #2416383
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Merci de votre partage d’infos

    #2416400
    jerome.ammouial
    Participant
    Initié WordPress
    11 contributions

    Pas de quoi… Mais Bing me snobe toujours pour un NOINDEX invisible…

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.