Problème de personnalisation du thème WP

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • WordPress :4.7
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #1630811

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : phpMyAdmin 4.4.15.7/MySQL 5.5
    • Thème utilisé : Twenty Seventeen
    • Extensions en place : Akismet et Hello Dolly (non activées)
    • Nom de l’hébergeur : ovh.net
    • Adresse du site : http://www.hypno-coach.fr/hypnocoach/

    Problème(s) rencontré(s) :

    Voilà je viens d’installer WordPress fraichement téléchargé, dans un sous répertoire créé spécialement (hypnocoach) afin de conserver le site originel tant que celui de WordPress n’est pas finalisé.

    Ce nouveau répertoire est configuré en « Lire » « Écrire » et « Exécuter » pour les permissions du propriétaire ; et en « Lire » et « Exécuter » pour les permissions publiques, avec la valeur numérique 705.

    Tout ce passe bien, créations de page, de menu, d’articles, de commentaires, d’installation de thèmes, sauf que pour chaque thème activé, je n’ai pas accès à :

    • Personnaliser
    • En-tête
    • Et « Background » quand le thème le propose

    Pour « Thème », « Menu », « Widgets » et « Éditeur », pas de problème. Les seuls qui n’ouvrent pas une fenêtre de prévisualisation.

    Donc pour ces 3 options, en cliquant dessus, j’obtiens le lancement de la page de personnalisation/prévisualisation avec seulement le bouton « Enregistrer et publier » et la croix pour fermer le tout, et tout le reste est vide.

    J’ai fait plein de recherches avant de venir ici m’inscrire.

    Auparavant j’ai installé d’autres sites avec WordPress sans aucun problème où je ne puisse trouver de solution et ce sur des hébergeurs différents. C’est la première fois chez OVH qui propose d’ailleurs dans l’espace client, un module d’installation directe de WP mais sans le choix du répertoire qui par défaut est celui de la racine du site.

    J’ai regardé un peu dans les fichiers .htacces mais sans y voir la source du problème (je ne connais pas les arcanes de ce fichier).

    J’ai essayé de vider le cache, supprimer les cookies, changer de navigateur. De session : Linux pour Windows. Rien n’y fait.

    Merci pour vos suggestions 🙂

    • Ce sujet a été modifié le il y a 2 semaines et 3 jours par  cloholdo.
    • Ce sujet a été modifié le il y a 2 semaines et 3 jours par  cloholdo. Raison: Ajout d'éléments de réflexion
    #1630871

    WP Traduction
    Modérateur
    Maître WordPress
    938 contributions

    Bonjour,

    Quelle est votre version de Php ? (pas phpMyAdmin ni MySQL)

    #1630921

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    J’ai trouvé : Version PHP globale 4.4
    On peut modifier l’environnement apparemment. L’environnement actuel est Legacy. Je peux choisir Jessie.i386, ou Stable, ou Testing. Pour PHP, je peux passer à : 5.4 – 5.5 – 5.6 – 7.0 ou 7.1
    Toucherions-nous le nœud du problème ?!!
    Je risque de foutre en l’air le fonctionnement de l’ancien site, fait main par je ne sais qui…

    Bon je viens de trouver ceci ici : https://wordpress.org/about/requirements/
    <h3>To run WordPress we recommend your host supports:</h3>
    PHP version 7 or greater
    MySQL version 5.6 or greater OR MariaDB version 10.0 or greater
    HTTPS support

    Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.2.4+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

    Bon, et bien, je vais changer la version PHP et on verra 🙂 Hop !

    • Cette réponse a été modifiée le il y a 2 semaines et 2 jours par  cloholdo. Raison: Apparition de code inutile du à un copié-collé
    • Cette réponse a été modifiée le il y a 2 semaines et 2 jours par  cloholdo.
    #1630928

    WP Traduction
    Modérateur
    Maître WordPress
    938 contributions

    Si vous avez installé la dernière vesion de WordPress (branche 4.7), alors je vous conseille Php 7.0.

    Par contre, ça m’étonnerait que vous ayez actuellement la version 4.4, alors pour être sur d’avoir les bonnes informations, installez l’extension indiquée dans ce tutoriel et revenez nous donnez les informations du formulaire de demande d’aide.

    #1630929

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Voilà, je suis passé à PHP 7.0 en restant dans l’environnement Legacy, mais cela ne change pas le problème dans l’édition/prévisualisation du thème pour « personnaliser » et « en-tête ». Toujours vide.
    J’avais vu sur je ne sais quel site, une astuce pour augmenter la mémoire cache de WP en rajoutant quelques lignes de code dans le fichier wp-config.php
    Je cherche ça…
    Apparemment je ne peux changer la version MySQL qui est en dessous de la recommandation…

    #1630931

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Voila c’est fait :

    [b]Ma configuration WP actuelle :[/b] [b]- Version de WordPress :[/b] 4.7.3 [b]- Version de PHP/MySQL :[/b] 7.0.15 / 5.5.54 [b]- Thème utilisé :[/b] Twenty Seventeen [b]- Thème URI :[/b] https://wordpress.org/themes/twentyseventeen/ [b]- Extensions en place :[/b] Forum_wordpress_fr (4.1) [b]- Adresse du site :[/b] http://www.hypno-coach.fr/hypnocoach [b]- Nom de l’hébergeur :[/b] Apache

    #1630939

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Bon je suis toujours coincé. J’ai aussi essayé comme dit plus haut, l’ajout de quelques lignes de code dans le fichier wp-config.php comme suit :

    /* define('WP_DEBUG', false);  */
    define('WP_DEBUG', true);
    define('WP_MEMORY_LIMIT', '96M');
    define('WP_MAX_MEMORY_LIMIT', '256M');
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    ça n’arrange rien non plus. J’ai donc remis la première ligne normale, et les 6 autres lignes en commentaire…

    Le .htaccess à la racine du site, a des lignes de code qui peut être gênent le fonctionnement de WP…

    • Cette réponse a été modifiée le il y a 2 semaines et 2 jours par  cloholdo.
    #1630948

    WP Traduction
    Modérateur
    Maître WordPress
    938 contributions

    J’ai aussi essayé comme dit plus haut, l’ajout de quelques lignes de code dans le fichier wp-config.php

    Je ne vois aucun message ici vous disant de faire cela … et je crois donc que vous ne nous dites pas tout.

    #1630953

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Effectivement, cela n’a pas été dit ici, mais sur un autre site Web. Je cherche et expose mes recherches, des fois que cela déclenche une idée, une piste, parce que je sèche.

    Voici un site similaire qui dit à peu près la même chose que ce que j’avais trouvé je ne sais plus où :
    https://wpchannel.com/optimiser-wordpress-augmenter-taille-limite-memoire-wordpress/
    J’ai installé comme dit, l’extension WP-Memory-Usage, et voici les résultats :

    • PHP Version : 7.0.15 / 32Bit OS
    • Memory limit : 512 MB
    • Memory usage : 17.81 MB soit 3%

    J’ai donc de la marge, je vais ré-essayer car dans ce lien il est mentionné :

    A la racine de votre espace, modifiez le fichier wp-config.php et rajouter la ligne de code suivante :

    define('WP_MEMORY_LIMIT', '96M');

    Attention à l’emplacement de cette dernière ! Positionnez-là après la ligne 56 pour la rendre effective.

    En tout cas, merci pour l’aide et le soutien !

    #1630954

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    J’ai fait des recherches (sur ce forum et d’autres) sur ce sujet de la fenêtre de personnalisation vide, et je n’ai rien trouvé qui soit résolu.

    Donc en augmentant la mémoire cache de WordPress, en ayant vidé le cache du navigateur et en réessayant, toujours le même problème. Comme je soupçonne le fichier .htaccess mis à la racine du site, donc celui encore mis en avant, car celui-ci renferme des lignes de code que je n’avais jamais auparavant. Les voici :

    SetEnv PHP_VER 5_TEST
    SetEnv REGISTER_GLOBALS 0

    SetEnv HTTP_MY_BASE « www.hypno-coach.fr »
    #RewriteBase /hypno/

    RewriteEngine On
    RewriteRule ^edit$  edit.php [L]
    RewriteRule ^(.*).htm$  index.php?page=$1 [L]
    RewriteRule ^images/titre_hypno.jpg$  images/titre_hypno.jpg [L]
    RewriteRule ^images/titre_(.*).jpg$  images/titre_hypnose.jpg [L]

    Pour moi c’est un peu du chinois, mais j’y vois qu’une base de données y est définie : /hypno/ que je n’ai pas trouvé dans PHPMyAdmin. Quand j’ai repris ce site, il n’y avait pas de base configurée chez OVH, j’ai activé la seule disponible. Par FTP, je ne trouve pas non plus de répertoire /hypno/
    Pourtant il y a une connexion vers une interface d’administration ici : http://www.hypno-coach.fr/edit.php
    Ma cliente ne se souvient pas des identifiant et mot de passe…
    Bref, je vais essayer en supprimant ce fichier .htaccess pour voir…

    #1630955

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    C’est fait, mais aucune amélioration du problème de la page prévisualisation/personnalisation du thème… 🙁

    Je vais me coucher…

    #1631442

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Personne n’a de piste pour régler ce problème ? Je téléphone à OVH…

     

    #1631617

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Toujours bloqué sur la fenêtre de personnalisation/prévisualisation de mon WP sur OVH 🙁

    J’ai d’ailleurs fait une demande dans le forum d’entraide OVH ici :

    https://community.ovh.com/t/probleme-daffichage-du-panneau-de-personnalisation-wordpress/2599/13

     

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1632695

    cloholdo
    Participant
    Initié WordPress
    12 contributions

    Bon, j’ai réglé le problème sans trop comprendre ce qui n’allait pas dans mes installations manuelles de WP chez OVH.

    J’ai d’abord effacé l’ancien site qui utilise aussi PHP et qui pouvait faire interférence avec WP dans son sous répertoire. Puis j’ai réinstallé de propre WP à la racine de l’espace OVH. Là encore j’avais toujours le même problème.
    Il me restait une solution, l’installation de WordPress via l’interface Client de chez OVH. Je n’avais pas osé l’utiliser en premier lieu car il fallait conserver l’ancien site tant que celui avec WP ne serait pas finalisé, donc choisir un sous répertoire pour WP. Le module d’installation WP dans l’espace Client ne mentionne pas qu’il peut installer WP dans un sous répertoire, du moins pas à la première étape. Hors c’est possible en seconde étape. Et là tout marche !
    Et ne me demandez pas pourquoi, je n’ai pas cherché vu que j’ai déjà perdu 5 jours à essayer de faire marcher WP manuellement.
    Mon conseil : chez OVH passer par l’interface Client dans le gestionnaire de site, cliquez sur ajouter un module et vous trouverez l’intallation automatique de WordPress 🙂

    #1632697

    WP Traduction
    Modérateur
    Maître WordPress
    938 contributions

    Au contraire, je déconseille vivement l’utilisation du module d’installation en 1 clic d’OVH, car les mises à jour peuvent poser problème au bout d’un certain temps.

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.