[Résolu] Problème de permaliens après transition de mon site (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2291632
    gregb
    Participant
    Initié WordPress
    23 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0.33-0 / 5.7
    • Thème utilisé : Jkreativ
    • Extensions en place : bcp
    • Nom de l’hébergeur : ikoula ( server dédié )
    • Adresse du site : http://www.gregb.fr

    Problème(s) rencontré(s) :

    bonjour voici mon soucis, j’étais chez ovh et j’ai voulu héberger moi meme plusieurs de mes sites pour non seulement avoir un dédié mais aussi me remettre dans tout ça ( hébergement, etc)

    j’ai actuellement un soucis au niveau des permaliens.

    Chez Ovh j’avais mis sur  » titre de la publication » soit %postname%/ dans la structure personnalisée

    mais depuis que je suis sur mon server je suis obligé de mettre directement en structure personnalisée avec comme argument « /index.php/%postname%/ »

     

    si je remet la première config, cela ne fonctionne pas, mais en mettant la seconde tout refonctionne correctement.

    seul hic à tout cela mes adresse sont de l’ordre http://www.gregb.fr/index.php/contact/ alors qu’avant j’avais des adresse du genre http://www.gregb.fr/contact/

    quelqu’un à une idée pour remédier à ce soucis ?

    a savoir que j’ai actuellement 2 sites et que les deux sont dans ce cas la, que le mod_rewrite du server est activé.

     

    merci d’avance en tout cas

    #2291635
    mathieu42
    Participant
    Maître WordPress
    2012 contributions

    est ce que vous avez autorisé l’utilisation de la réécriture d’URL (RewriteEngine …) dans la configuration d’Apache ?

    http://httpd.apache.org/docs/2.4/mod/core.html#allowoverride

    #2291639
    sam76
    Participant
    Initié WordPress
    3 contributions

    Bonsoir,

    Je compatis, j’ai le même problème avec la 5.3.2, tous les plugins sont désactivé, thème par défaut. Désolé de m’incruster dans ton thread mais je pense qu’on a le même problème et je ne trouve pas la solution.

    • Version de PHP/MySQL : 7.3.11-0ubuntu0.19.10.1 / 8.0.18-0ubuntu0.19.10.1
    • Thème utilisé : Twenty Nineteen 1.4
    • Extensions en place : aucune active
    • Nom de l’hébergeur : OVH dédié ubuntu 19.10
    • Adresse du site : https://www.bubblemind.net

    Mod rewrite on :

    ubuntu@bubblemind:/var/www/html$ sudo a2enmod rewrite
    Module rewrite already enabled

    Je suis obligé de mettre Permaliens personnalisé « /index.php/%postname%/ » ou permalien « Simple » sinon j’ai erreur 404 sur toutes les pages

    • Cette réponse a été modifiée le il y a 4 années et 4 mois par sam76.
    • Cette réponse a été modifiée le il y a 4 années et 4 mois par sam76.
    #2291665
    sam76
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    J’ai résolu mon problème en modifiant ma config apache.

    Dans le fichier apache2.conf j’ai remplacé

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
    </Directory>

    par :

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    J’espère que ca t’aidera gregb.

    #2291670
    gregb
    Participant
    Initié WordPress
    23 contributions

    SOLUTION TROUVEE:

     

    merci à sam76

    il suffit simplement de faire ça :

    Dans le fichier apache2.conf j’ai remplacé

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
    </Directory>

    par :

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    je quote Sam76, car ça solutionne le soucis.. Grand Merci à lui !!

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.