Problème de liens dynamiques. (Créer un compte)

  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #456721
    PJ
    Membre
    Initié WordPress
    2 contributions

    Bonjour à tous,

    Je viens de réaliser un site de Photoblog (http://www.pierrejeansuau.com) et je rencontre un petit problème pour afficher un lien dynamique vers les posts précédents ou suivants.

    J’ai placé dans la page de mon theme ‘Single.php’ ce code :

    Quand on clique sur ‘comment’ les liens dynamiques s’affichent donc correctement pour naviguer de post en post mais ce n’est pas très clair puisqu’il faut d’abord cliquer sur ‘comment’ pour qu’ils s’affichent.

    J’ai donc essayer d’insérer ce code dans la page ‘home.php’ pour que les liens soient visibles mais la page s’affiche en laissant un espace à l’endroit où devrait se trouver les liens mais n’affiche pas les liens du tout.

    Je suis donc obligé d’intégrer une balise HTML dans chacun de mes posts pour le post précédent ce qui n’est ni jolis ni pratique.

    Une suggestion peut-être ?

    Merci à tous pour vos réponses,

    Pierre-Jean

    WordPress 2.3.2
    Theme perso

    PS: Si vous voyez d’autre problème n’hésitez pas à me faire part de vos suggestions ! 🙂

    #619566
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Réglage correct dans console admin ? Onglet Options/lecture/pages du blog/montrer au plus x articles (si x = 0, patatras !)

    #619567
    PJ
    Membre
    Initié WordPress
    2 contributions

    Bonjour YannC,

    Oui le réglage est correct, il est réglé sur 10 articles pour que les ‘tags’ affichent 10 articles sur le même sujet.

    Par contre j’ai ajouté cette ligne dans ‘home.php’ :
    pour n’afficher que le dernier post lors de l’accueil du site (pour plus de clarté)

    Je me demande si le problème ne vient pas là…

    Merci de votre réponse en tout cas!

    Pierre-Jean

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.