problème de langue (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2346353
    oliviae-c
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.2.30
    • Thème utilisé : Sydney
    • Extensions en place : Polylang, Yoast, W3 cache, Monsterinsight, Heatmap, Sassy social share, Hotjar, Akismet, Header and footer script, Updraft
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://olivia-ecommunication.com/

    Problème(s) rencontré(s) : Bonjour à tous !
    Je cherche depuis une semaine une solution à mon problème dans mon site WordPress : quand je suis dans l’interface admin, tout est bien en français. Par contre, dés que je passe en mode « Aller sur le site », la barre du haut qui reprend mes options wordpress bascule en anglais, et certains de mes widgets sont désormais en anglais, alors qu’ils étaient bien en français au départ. Vous pouvez voir sur ma page d’accueil http://olivia-ecommunication.com/ que le widget « Rechercher » affiche désormais « Search », que le mois de mes archives de blog apparaissent en anglais, et que la mention WordPress dans le pied de page est également en anglais.
    Savez-vous d’où vient le problème ?
    Merci !

    #2346354
    oliviae-c
    Participant
    Initié WordPress
    2 contributions

    Ah ben, je viens de trouver !!!

    Je mets la réponse pour ceux qui sont peut-être dans le même cas que moi :

    • j’ai d’abord désactivé une par une mes extensions
    • j’ai ainsi vu que c’était l’extension Polylang qui me changeait automatiquement la langue du thème en anglais
    • je suis retournée dans les réglages des langues : là je suis tombée sur la fenêtre “Langue” avec les paramètres “Ajouter une nouvelle langue” et j’ai retrouvé sur la droite le panneau avec les 3 langue du site. J’ai sélectionné le français, puis dans l’espace “Code local”, je me suis rappelé que je l’avais modifié (et je sais pas pourquoi j’avais fait ça ….). J’ai remis dans cette cas le code “fr_FR”, et miracle ! Mon thème s’affiche bien en français.
    • j’ai fait de même pour les 2 autres langues : j’ai remodifié le code local mais là par contre, le thème reste en anglais. Je vais donc recherché le code des 2 autres langues

    Bonne journée à tous !

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.