Problème de connexion de WP à la base de donnée d’OVH ! (Créer un compte)

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #447867
    ristorante
    Membre
    Initié WordPress
    3 contributions

    Bonjour à tous,

    Complet débutant dans WP, je ne suis pas un fin technicien. Du coup, j’aurais besoin d’un peu d’aide…

    Je viens de faire l’acquisition chez OVH d’un hébergement et, si j’ai bien compris, d’un nom de domaine. J’ai créé une base MySQL.
    La procédure d’upload sur le serveur FTP est terminée, mais pas moyen d’accéder au fichier wp-admin/install.php

    A mon avis, soit je rentre la mauvaise adresse dans le navigateur, soit je me suis planté en éditant et renommant le fichier wp-config.php
    Voilà les paramètres que j’ai mis :

    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘wordpress’); // The name of the database
    define(‘DB_USER’, ‘vivianeg’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘monmotdepasse’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    L’adresse que j’ai tenté est : http://vivianegelles.net/wp-admin/install.php
    J’ai tout uploadé à la racine du site.

    Un doute encore : le mot de passe de la base de donnée que j’ai rentré est celui de l’accès à l’interface d’administration sur le site internet OVH. A ma connaissance il n’y en a pas d’autre. Aurais-je raté quelque chose ?

    Voilà. Je réalise en écrivant tout ça que j’ai pu faire plusieurs bêtises et non pas une seule : espérons que mon cas n’est pas désespéré !
    Je vous remercie par avance pour votre aide.

    #575173
    Malaiac
    Participant
    Chevalier WordPress
    148 contributions

    Le nom du serveur n’est surement pas localhost. Il t’est fourni par OVH quand tu crées ta base dans l’admin (OVH).

    Il faut créer une base dans l’admin OVH et mettre les parametres fournis dans ton install WP.

    #575174
    ristorante
    Membre
    Initié WordPress
    3 contributions

    Merci pour cette réponse.
    La base est créée. Elle s’appelle vivianeg. J’ai remplacé localhost par le nom mais ça ne donne toujours rien. :(

    #575175
    Nicow
    Membre
    Padawan WordPress
    57 contributions

    Salut,

    le nom du serveur mysql chez ovh resemble à un truc du genre : sql10. Tu dois retrouver ça dans ton contrat ou tu l’a peut être reçu par mail au moment de la création de ta base tout dépend de l’offre dont tu dispose chez eux.

    #575176
    Qwindoo
    Modérateur
    Maître WordPress
    2862 contributions
    ristorante wrote:
    La base est créée. Elle s’appelle vivianeg. J’ai remplacé localhost par le nom mais ça ne donne toujours rien.

    euh… Le nom de la base de donnée est différent de l’adresse du serveur hein 😉
    localhost = adresse du serveur SQL = par ex: sql.ovh.com != nom_de_la_base_de_données 😋

    #575177
    ristorante
    Membre
    Initié WordPress
    3 contributions

    okééééééééééééééé 🙂
    Bon je fais un nouvel essai. Merci !

    #575178
    onzeweb
    Membre
    Padawan WordPress
    73 contributions

    Pour la base, il faut utiliser un nom de serveur fournis par mail à la création (normalement). Chez OVH ils ont fait simple, au moins pour certaines formules : sql , sql2 , … (plus simple pas possible). Je pense que cela peut aider 😉

    #575179
    mangosteen
    Membre
    Initié WordPress
    1 contributions

    Je viens d’installer WordPress sur mon site a OVH et…

    Database Name: OVH utilisateur/nom de la base
    Database Username: OVH utilisateur/nom de la base
    Database Password: OVH mot de passe
    Database Host: nom de serveur MySQL (e.g. sql4)

    J’espere que ca peut vous aider.
    Lisa

    #575180
    sf
    Membre
    Initié WordPress
    6 contributions

    Bonjour

    J’eu aussi un souci !
    Pour OVH il faut créer une base MYSQL
    A réception du mail ce sont ces infos qu’on doit mettre dans le fichier config:
    utilisateur
    nom de base identique dans mon cas
    mot de passe spécifique
    serveur souvent sql, sql1….

    ça peut servir

    #575181
    charlie
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    J’ai un hébergement Start 1g chez OVH. J’ai créé mon fichier wp_config.php et ajouter l’option française dans la ligne adéquate :

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘xxx’); // The name of the database
    define(‘DB_USER’, ‘xxx’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘zzz’); // …and password
    define(‘DB_HOST’, ‘yyy’); // 99% chance you won’t need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ‘fr_FR’);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    j’ai placé tous les fichiers sur le serveur.

    A chaque fois que je me connecte, j’ai le message suivant :

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, tech@ovh.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    je l’ai installé en local, tout est ok. J’ai essayé d’autres blogs et c’est identique.

    J’ai mis tous les répertoires et fichier en 777, c’est pareil. Je craque ! j’ai placé une page test.html, elle s’affiche correctement.

    avez vous une idée ?

    merci

    Charlie

    #575182
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Nouveau problème… Nouveau sujet… je ferme

11 sujets de 1 à 11 (sur un total de 11)
  • Le sujet ‘Problème de connexion de WP à la base de donnée d’OVH !’ est fermé à de nouvelles réponses.