Problème de compatibilité jquery

  • WordPress :4.9.4
  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2143239
    Platypus26
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    J’ai créé un site WordPress avec Divi, j’ai intégré un petit script et la librairie jquery sur une page, malheureusement la librairie rend des éléments de la page inactifs : slider et accordéon.

    J’aimerais que tout fonctionne, avez-vous des idées pour résoudre ce problème ?

    Merci.

    #2143385
    hocus35
    Participant
    Initié WordPress
    26 contributions

    as tu une url a nous montrer ?

    #2143510
    Platypus26
    Participant
    Initié WordPress
    2 contributions

    Bon et bien finalement j’ai fini par trouver une alternative avec Google API et ce bout de code que j’ai trouvé ici https://codemarket.wordpress.com/2013/06/14/jquery-dans-wordpress-debutant/

    Je l’ai juste rajouté dans function.php et tout fonctionne étrangement sans problème de cette manière !

    Merci tout de même d’avoir pris le temps de me répondre hocus35.

    
    
        /** CUSTOM JAVASCRIPT **/
    
        function jquery_jquery_ui() {
         if (!is_admin()) {
          wp_deregister_script('jquery');
    
          // Google API (CDN)
          wp_register_script('jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.10.1/jquery.min.js', false, '1.10.1', true);
          wp_register_script('jquery-ui', 'http://ajax.googleapis.com/ajax/libs/jqueryui/1.10.3/jquery-ui.min.js', array('jquery'), "1.10.3", true);
    
          wp_enqueue_script('jquery');
          wp_enqueue_script('jquery-ui');
         }
        }
        add_action('init', 'jquery_jquery_ui');
    
        /** END **/

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.