Problème dans l’affichage de certains mails woocommerce

  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #559258
    ferman
    Participant
    Maître WordPress
    1023 contributions

    Bonjour,

    Ma configuration WP actuelle
    – 4.4.2 :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Woocommerce (dernière version) et quelques autres plugins classiques :
    – ovh :
    – les-collections-pop :

    Le problème concerne les e-mails envoyés automatiquement après commande woocommerce et plus particulièrement les commandes “commande terminée” et “commande remboursée”

    J’ai les textes ci-dessous dans le corps des mails:
    “Bonjour. Votre commande récente sur a été expédiée. Le récapitulatif de votre commande est affiché ci-dessous :”
    et
    “Bonjour. Votre commande sur a été partiellement remboursée.”
    La version en anglais (dans woocommerce/templates/e-mails/plain) est:
    “Hi there. Your recent order on %s has been completed. Your order details are shown below for your reference:”
    et
    “Hi there. Your order on %s has been refunded. Your order details are shown below for your reference:”
    Normalement le signe %s est automatiquement remplacé par le nom du site depuis lequel on expédie le message mais ce n’est pas le cas pour moi. Je pense qu’on devrait lire “…récente sur les-collections-pop a été expédiée…”

    Donc ma première question: est-ce un problème seulement pour moi ou bien est-ce général?
    Si c’est un problème particulier je regarderai encore plus en détail avant de solliciter le forum de nouveau
    Si c’est général je pense que cela vaut la peine d’être discuté. Le signe spécial %s aurait-il disparu dans la traduction?
    J’ajoute que je n’ai pas trouvé trace des phrases en français ci-dessus dans le fichier po, ni nulle part dans les fichiers wordpress. Où peuvent-elles bien se trouver?

    Merci pour votre avis et votre aide

    Ferman

    :

    #1042494
    ferman
    Participant
    Maître WordPress
    1023 contributions

    Bon, c’était de ma faute. J’avais complètement oublié que lors de la création du site j’avais remis à plus tard l’indication du nom du site dans les réglages wp donc bien sûr woocommerce ne pouvait pas l’inventer!

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.