Problème d’affichage d’une image dans un tableau (Créer un compte)

  • Statut : non résolu
7 sujets de 16 à 22 (sur un total de 22)
  • Auteur
    Messages
  • #1043709
    baptistebarbaud
    Participant
    Padawan WordPress
    94 contributions

    En fait le problème est que la photo s’aligne sur la première ligne du tableau plutôt que de s’aligner sur l’ensemble du tableau. J’ai essayé de jouer avec les marges et paddings mais l’alignement sur la première ligne du tableau reste prioritaire.

    #1043710
    jeanclaude57
    Participant
    Padawan WordPress
    91 contributions

    Quand j’examine ton image est que je décoche vertical-align: baseline;
    les cochons s’alignent avec l’image.
    Ce css est prioritaire sur les autres donc supprime le si il n’y a pas d’incidence sur le reste ou modifie .

    Il est placé ici dans ton fichier css

    =======================================================
    =============== END – Table of Contents ===============
    ======================================================= */
    /* Reset CSS */
    /* http://meyerweb.com/eric/tools/css/reset/
    v2.0 | 20110126
    License: none (public domain)
    */
    html,
    body,
    div,
    span,
    applet,
    object,
    iframe,
    h1,
    h2,
    h3,
    h4,
    h5,
    h6,
    p,
    blockquote,
    pre,
    a,
    abbr,
    acronym,
    address,
    big,
    cite,
    code,
    del,
    dfn,
    em,
    img,
    ins,
    kbd,
    q,
    s,
    samp,
    small,
    strike,
    strong,
    sub,
    sup,
    tt,
    var,
    b,
    u,
    i,
    center,
    dl,
    dt,
    dd,
    ol,
    ul,
    li,
    fieldset,
    form,
    label,
    legend,
    table,
    caption,
    tbody,
    tfoot,
    thead,
    tr,
    th,
    td,
    article,
    aside,
    canvas,
    details,
    embed,
    figure,
    figcaption,
    footer,
    header,
    hgroup,
    menu,
    nav,
    output,
    ruby,
    section,
    summary,
    time,
    mark,
    audio,
    video {
    margin: 0;
    padding: 0;
    border: 0;
    font-size: 100%;
    font: inherit;
    vertical-align: baseline;
    }

    #1043711
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Bonsoir.

    Sans vouloir insisté, une capture d’écran dans 2013, avec TablePress et Universal Star Rating

    Cochons.png

    🙂

    #1043712
    Flobogo
    Modérateur
    Maître WordPress
    20114 contributions

    Peut-être une question de navigateur. Moi, sous Firefox, je vois tout OK sur le site comme sur la capture de PhiLyon 🙂

    #1043713
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Bonjour.

    Sur Firefox, ce matin, j’ai toujours le tableau et l’image décalés.

    🙂

    #1043714
    baptistebarbaud
    Participant
    Padawan WordPress
    94 contributions

    Oui j’ai supprimé « vertical-align: baseline; » dans mon css comme me l’a indiqué Jeanclaude57 et ça fonctionne enfin 🙂
    Et PhiLyon, j’utilise aussi tablepress en général mais là il va y avoir 2 à 10 tableaux différents par page donc je préfère les coder.

    Merci à tous pour votre aide, problème résolu ✅

    #1043715
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Ok mais en faisant ça cela sera valable pour tous les tableaux sur ton site.

    🙂

7 sujets de 16 à 22 (sur un total de 22)
  • Vous devez être connecté pour répondre à ce sujet.