Problème d’affichage d’un sous-menu avec un carré (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2339991
    AXIOME
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : aucune idée : surement très récent car démarrage du site il y a 15 jours
    • Thème utilisé : Dabba
    • Extensions en place : Loco translate,
    • Nom de l’hébergeur : Ionos
    • Adresse du site : https://www.lrdere.fr

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai un soucis d’affichage dans mon menu, l’affichage du sous-menu s’affiche avec un carré. (Screenshot)

    Sauriez vous m’aider svp ?

    Merci beaucoup !

    Bonne journée,

    Maxime

    #2339994
    PhiLyon
    Modérateur
    Maître WordPress
    26313 contributions

    Bonjour.

    La ” police ” Fontawesome n’est pas chargée.

    Ce thème n’a été vendu que 75 fois, étrange https://themeforest.net/item/dabba-a-wordpress-theme-for-blog-shop/23213008

    🙂

    #2339996
    Flobogo
    Modérateur
    Maître WordPress
    16257 contributions

    Bonjour,

    Vous voulez parler de la petite icône juste à droite du menu “Chambres” ? Si c’est bien ça, elle est mal définie das le CSS.

    Si c’est ça, allez dans votre admin de site, onglet Apparence > Personnaliser. Puis dans le CSS additionnel, copiez-collez ce bout de code :

    .dropdown-toggle::after {
        content: "\F107";
        font-family: "Font Awesome 5 Free";
    }

    Si ce n’était pas ça, soyez plus précis dans votre demande, ou tournez-vous vers le support de votre thème (là où vous l’avez acheté)

     

     

     

    #2339997
    PhiLyon
    Modérateur
    Maître WordPress
    26313 contributions

    @Flobogo – Bonjour. le code est bien présent dans le CSS.

    🙂

    • Cette réponse a été modifiée le il y a 4 mois et 3 semaines par PhiLyon.
    #2340010
    AXIOME
    Participant
    Initié WordPress
    14 contributions

    Merci beaucoup pour vos réponses aussi rapide !

    J’ai bien ajouté ce bout de code dans le CSS additionnel mais rien ne bouge. Je parlais bien de la petite flèche après “Les Chambres” pour ouvrir les sous-menus. Mon éditeur de thème ne me répond pas malheureusement…


    @Philyon
    , avez vous la solution pour y remédier ? Je suis très débutant sur WordPress. J’ai pu créé ce style en cherchant à droite à gauche sur Google les réponses à mes questions, mais quelques éléments m’échappent encore, tout comme la traduction de la partie commentaire sur mon autre site gwadactu.fr…. sujet ouvert dans une autre discussion du forum (https://wpfr.net/support/sujet/traduction-de-lespace-commentaire-leave-a-comment-post-comment-your-name/#post-2339993) au cas ou vous auriez la réponse.

    Merci encore,

    Bonne soirée,

    Maxime

    #2340020
    PhiLyon
    Modérateur
    Maître WordPress
    26313 contributions

    Bonjour.

    Explique-nous comment est ta configuration chez ionos, tu as deux sites distincts, avec le même thème, tu es en multisite, etc ?

    🙂

    #2340364
    Flobogo
    Modérateur
    Maître WordPress
    16257 contributions

    @philyon : je l’ai vu avec un slash / dans le nom de la police, ce qui pose peut-être problème


    @axiome
    :

    J’ai pu créé ce style en cherchant à droite à gauche sur Google les réponses à mes questions

    Vous avez rajouté vous-même cette petite icône ? Alors, comme je disais ci-dessus, c’est juste une petite erreur dans votre code avec ce slash supplémentaire. (enfin, je crois)

    #2340454
    AXIOME
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Pardon, je voulais dire “j’ai créé ce site, en cherchant à droite à gauche”.

    Je n’ai rien touché d’autres que l’importation du thème et la mise en page de mes pages.

    Chez Ionos, j’ai fait une configuration classique de site : achat de nom de domaine, création d’un site wordpress relié à Ionos. Herbegement Web sur Ionos. J’ai en effet deux sites distincts avec le même thème. L’autre site : gwadactu.fr, s’affiche correctement.

    Si l’un de vous le souhaite, nous pouvons convenir d’un Skype/Zoom pour que je puisse vous montrer. Je posterai la réponse de la solution sur le forum pour les prochains lecteurs.

    Merci pour votre aide !

    Maxime

    #2353399
    AXIOME
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    C’est dommage, je n’ai toujours pas réussi à régler ce problème…

    Bonne journée à tous,

    Maxime

    #2353443
    ferman
    Participant
    Maître WordPress
    2809 contributions

    Bonjour,

    Il y a peut-être deux possibilités:

    1. Puisque ça ne marche pas avec les font awesome remplacez par une police classique.  Regardez en mettant le code ci-dessous dans vos CSS additionnelles. Ce n’est pas l’idéal mais comme vous avez dû chercher depuis des mois sans trouver de solution ça peut peut-être vous être utile.
    2. Il y a une autre solution: vous créez une image à votre goût à la dimension voulue et la mettez dans votre bibliothèque d’images. Ensuite vous reprenez le code et remplacez “^” par l’url de l’image. Voir ICI.
    .dropdown-toggle{position:relative;
    top:-8px}
    .dropdown-toggle::after {
    	content: "^"!important;
    	font-family: "";
    	font-size: 40px!important;
    	transform: rotate(-180deg);
    	position:relative;
    	top:10px;
    	color:red;
    }

    • Cette réponse a été modifiée le il y a 4 heures et 15 minutes par ferman.
    • Cette réponse a été modifiée le il y a 4 heures et 8 minutes par ferman.
    #2353450
    AXIOME
    Participant
    Initié WordPress
    14 contributions

    Super, merci beaucoup… ça fonctionne ! Ce forum est vraiment génial… merci à tous. 🙂

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.