Problème d’affichage des images produit ( erreur fatal ) (Créer un compte)

  • WordPress :6.1
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2440182
    mounir74
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.0
    • Thème utilisé : BeTHEME
    • Extensions en place : Akismet Anti-Spam, Boxtal Connect, Contact Form 7, Force Regenerate Thumbnails, Hello Dolly, Jetpack, LayerSlider, Slider Revolution,WooCommerce, WooCommerce PayPal Checkout Gateway, WooCommerce PayPal Payments,WooCommerce Shipping & Tax, WooCommerce Stripe Gateway, Yoast Duplicate Post.
    • Nom de l’hébergeur : OVH
    • Adresse du site :  https://www.soky.fr

    Problème(s) rencontré(s) :

    Bonjour,

    Fe rencontre un problème d’affichage des images produit sur mon site, qui sont présentes dans ma bibliothèque en bon format.

    Problème survenu suite a une mise à jour et d’un message d’erreur impossible d’afficher les images depuis.

    Détails de l’erreur
    ======================
    Une erreur de type E_ERROR a été causée dans la ligne 168 du fichier /home/pmmzuif/www/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/BlockTypes/ProductImage.php. Message d’erreur : Uncaught Error: Call to undefined function AutomatticWooCommerceBlocksBlockTypeswp_is_block_theme() in /home/pmmzuif/www/wp-content/plugins/woocommerce/packages/wo ocommerce-blocks/src/BlockType s/ProductImage.php:168
    Stack trace :
    #0 /home/pmmzuif/www/wp-content/p lugins/woocommerce/packages/wo ocommerce-blocks/src /BlockType s/AbstractBlock.php(100) : AutomatticWooCommerceBlocks BlockTypesProductImage->enque ue_data()
    #1 /home/pmmzuif/www/wp-includes/ class-wp-hook.php(303) : AutomatticWooCommerceBlocks BlockTypesAbstractBlock->enqu eue_editor_assets( »)
    #2 /home/pmmzuif/www/wp-includes/ class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #3 /home/pmmzuif/www/wp-includes/ plugin.php(470): WP_Hook->do_action(Array)
    #4 /home/pmmzuif/www/wp-admin/edi t-form-blocks.php(252): do_action(‘enqueue_block_e…’ )
    #5 /home/pmmzuif/www/wp-admin/pos t. php(187): require(‘/home/pmmzuif/w…’)
    #6 {main}
    lancé

    • Ce sujet a été modifié le il y a 2 semaines et 2 jours par mounir74.
    • Ce sujet a été modifié il y a 2 semaines par Flobogo. Raison : déplacé en rubrique "Woocommerce"
    • Ce sujet a été modifié le il y a 1 semaine et 6 jours par Joss47.
    #2440601
    Joss47
    Modérateur
    Maître WordPress
    4866 contributions

    Bonjour,

    « Problème survenu suite a une mise à jour »

    Quel est la mise à jour ? Suffit de revenir en arrière sur ce plugin concerné 🙂

    #2440603
    momofr@free.fr
    Modérateur
    Maître WordPress
    5495 contributions

    Salut, thème et extensions sont à jour ?

    As-tu fait la mise à jour de la base de données pour WooCommerce ?

    C’est faisable après-coup ici : WooCommerce > Statut > Outils > Mettre à jour la base de données.

    #2440664
    mounir74
    Participant
    Initié WordPress
    2 contributions

    bonjour,

    Mon problème est survenu suite a la mise a jour wordpress ,woocommerce et mon theme.

    mon hébergement me conseil  de modifier la configuration php 8.0 ou 7.4 mais les image produit ne s affiche toujours pas.

    les theme et extension sont a jour, et jai fait la mis a jour de la base de données pour woocommerce.

    pas de changement ..

     

    #2440674
    ferman
    Participant
    Maître WordPress
    5825 contributions

    C’est la même chose que dans ce sujet, mais là c’était apparemment un problème de mise à jour de wordpress

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.