[Résolu] Problème d’affichage des CGV dans le mail de confirmation de commande (Créer un compte)

  • WordPress :5.4
  • Statut : résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2349516
    Momiji
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.20
    • Thème utilisé : OceanWP (child)
    • Extensions en place :

    Async JavaScript

    Boxtal Connect

    Colissimo shipping methods for WooCommerce

    Cookie Notice

    Elementor

    Formidable Forms

    Woocommerce – Loi Hamon

    Ocean Extra

    Paybox WooCommerce Payment Gateway

    Really Simple SSL

    Redirection

    reSmush.it Image Optimizer

    Sticky Header OceanWP

    TinyMCE Advanced

    WC – APG Free Shipping

    WooCommerce PDF Invoices & Packing Slips

    WooCommerce Product Stock Alert

    WooCommerce

    Yoast SEO

    Asset CleanUp : Page Speed Booster

    WP Maintenance Mode

    WP Rocket

    WPFront Notification Bar

    WPvivid Backup Plugin

    Problème(s) rencontré(s) :

    Bonjour à tous.

    Je viens de créer une boutique en ligne avec WooCommerce (que j’utilise sans soucis depuis 7 ans).

    Je ne rencontre qu’un seul problème c’est que dans le mail de confirmation de commande, au lieu des CGV à la suite du récapitulatif de commande, mes clients se retrouvent avec la feuille de style et toute la page d’accueil du site. Le mail fait des kilomètres.

    Dans les réglages de WooCommerce, le modèle d’e-mail est ok, j’ai bien les CGV mais le mail envoyé est tout autre (voir PJ).

    Est-ce que quelqu’un pourrait me dire si j’ai oublié un paramétrage ou comment je peux régler ça?

    Merci d’avance et bon dimanche!

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2349520
    Li-An
    Modérateur
    Maître WordPress
    24087 contributions

    Bonjour, désactivez les autres extensions, mettez un thème par défaut et testez pour voir. Vous pouvez laisser une extension de maintenance pour ne pas effrayer vos visiteurs et utiliser https://www.echodesplugins.li-an.fr/plugins/widget-importer-exporter/ pour sauvegarder le réglage de vos widgets. Vous pouvez aussi regarder dans Outils>Santé du site s’il n’y a pas un problème important.

    #2349523
    Momiji
    Participant
    Initié WordPress
    9 contributions

    Bonjour.

    Merci pour la réponse, je vais essayer ça. Ca serait une incompatibilité avec un plugin?

    Dans l’écran de santé tout est ok sauf la redirection 301 par .htaccess que je n’ai pas validé (je ne sais pas si je dois) et la version PHP qui n’est pas la plus récente…

    #2349525
    Li-An
    Modérateur
    Maître WordPress
    24087 contributions

    Je ne sais pas ce que c’est. Je vous propose les tests basiques recommandés en cas de problème.

    #2349527
    Momiji
    Participant
    Initié WordPress
    9 contributions

    Je suis en train de penser qu’il y a eu une màj de WC il y a quelques jours. Peut-être un souci dans la nouvelle version?

    Je continue de chercher… Bonne journée!

    #2349544
    Li-An
    Modérateur
    Maître WordPress
    24087 contributions

    Je n’avais pas fait attention mais le code affiché est relatif à Elementor. Il y a donc un problème entre les deux – et normalement j’arrête de vous aider car j’ai décidé de ne pas faire de support relatif à Elementor.

    #2349546
    Momiji
    Participant
    Initié WordPress
    9 contributions

    Je n’avais pas fait attention non plus!

    Pour ceux qui me liraient avec le même problème, dans les outils d’Elementor j’ai régénéré les fichiers ce qui a résolu le bug.

    Merci pour votre temps Li-An!

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.