Problème connexion sur la page d’accueil

  • WordPress :5.2
  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2265136
    Erick31
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : SoSimple
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://naturosanté.fr

    Problème(s) rencontré(s) :

    Bonjour,

    Après une restauration système, j’ai supprimé ma page d’accueil puis décidé d’affecter une de mes pages créées en statique comme page d’accueil. Depuis impossible d’avoir accès à ma page d’accueil en ligne à l’adresse: https://naturosanté.fr

    En revanche, je peux accéder aux autres pages ex: https://naturosanté.fr/naturopathie ou https://naturosanté.fr/hypnose

    Mais si je décide d’affecter une de ces pages en page d’accueil, idem, impossible d’y avoir accès en ligne…étonnant, non?

    Même si je change de thème, cela ne change rien. J’ai pensé à un problème avec le fichier .htaccess. Je joins une photo du menu réglage=> lecture où tout me semble normal.

    Merci d’avance pour votre aide 🙂

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2265310
    Flobogo
    Modérateur
    Maître WordPress
    15785 contributions

    Bonjour,

    Le questionnaire totalement complété nous aiderait peut-être à vous aider.

    Donc, voici quelques tests de base :

    • Désactivez toutes vos extensions et testez : si ça résout le problème, réactivez-les une par une pour trouver l’extension responsable du bug.
    • Si ça ne résout pas le problème, désactivez votre thème (et activez-en un par défaut, de la série twenty-xx), et testez à nouveau.
    • Vérifiez aussi votre version de PHP auprès de votre hébergeur : il faut au minimum PHP 5.6, et idéalement PHP 7.1 ou 7.2 pour que WordPress fonctionne correctement
    #2265356
    Erick31
    Participant
    Initié WordPress
    3 contributions

    Bonjour Flobogo,

    J’ai désactivé les extensions mais cela n’a provoqué aucun changement.

    J’ai changé de thème en twenty, idem

    J’ai vérifié PHP, j’étais en 7.0, je suis passé en 7.2, pareil aucun changement.

    Je suis un peu déconcerté, si aucune solution ne fonctionne, je vais réinstaller WP sur une nouvelle base et recréer le site…mais j’aurai bien aimé savoir quand même ce qui se passe, par curiosité…

    Merci pour ton aide 🙂

     

    Les extensions installées et désactivées:

    Akismet Anti-Spam

    Health Check & Troubleshooting
    <table class=”wp-list-table widefat plugins”>
    <tbody id=”the-list”>
    <tr class=”inactive” data-slug=”intergeo-maps” data-plugin=”intergeo-maps/index.php”>
    <td class=”plugin-title column-primary”>Intergeo – Google Maps Plugin</td>
    </tr>
    </tbody>
    </table>
    Jetpack par WordPress.com

    Orbit Fox Companion

    Really Simple SSL

    UpdraftPlus – Sauvegarde/Restauration

    WP Fastest Cache

    WP Health (Formerly My WP Health Check)

    WPForms Lite

    Yoast SEO

    #2265619
    Flobogo
    Modérateur
    Maître WordPress
    15785 contributions

    OK pour les tests de base. Il va falloir pousser plus loin, avant de tout réinstaller (ce serait dommage)

    1ère piste : puisque vous êtes chez OVH, faites une restauration de l’espace d’hébergement. (c’est peut-être ce que vous appelez : “ Après une restauration système …” )

    2ème piste : désactivez les extensions WP Health, et Health Chaeck & Troubleshooting et WP fatest Cache, puis videz le cache (voir la documentation de cette extension pour savoir comment vider le cache), ensuite réinstallez la version 5.2.1 de WordPress manuellement –> au préalable, faites une sauvegarde de la base de données, puis passez par FTP pour supprimer wp-admin et wp-includes, ensuite renvoyez-les à partir de la dernière version téléchargée et dézippée sur votre ordi.

    3ème piste : allez dans votre PhpMyAdmin (gestionnaire de base de données), et vérifiez la table wp_users (ou autre préfixe que wp_ possible) si vous retrouvez bien votre pseudo. Si oui, allez dans la table wp_usermeta et vérifiez si vous avez la capacité administrator et le niveau (level) 10, rectifiez si besoin. Attention  : faites une sauvegarde de la BDD avant d’intervenir !

    #2267115
    Erick31
    Participant
    Initié WordPress
    3 contributions

    Bonjour Flobogo,

     

    J’ai tenté 1) et ça n’a rien donné. J’ai désactivé les extensions en 2) non plus. Je ne vais pas aller plus loin. Je te remercie pour ton aide . Je vais repartir à zéro. De toute façon, je comptais remanier intégralement le site pour le référencement. Ce sera donc plus simple. En tout cas, j’apprécie votre réactivité sur la plateforme et vos conseils avisés.

    MERCI encore 🙂

    #2267216
    Flobogo
    Modérateur
    Maître WordPress
    15785 contributions

    OK, bon courage pour la réinstallation. Surtout, utilisez bien les versions originales de WP, des thèmes, et des extensions, et pas des sauvegardes faites auparavant, si vous voulez repartir sur des bases saines.

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.