[Résolu] Problème CF7 envoie des mails

  • WordPress :4.8.2
  • Statut : résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #1960966
    SpitfireLRDM
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :  5.6
    • Thème utilisé : Rocco
    • Extensions en place : CF7
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) :

     

    Bonjour à tous,

    J’ai cherché sur le forum mais je n’ai pas trouvé de solution à mon problème.

    Il semblerait que depuis la dernière mis à jour automatique de WP, mon plugin CF7 n’envoie plus les mails.

    En effet, je ne reçois pas les mails d’inscription et ceux qui complètent le formulaire d’email de confirmation non plus.

    Pourtant celui-ci marchait correctement depuis 2 ans.

    Les données qui sont stockées via Contact Form DB et sont bien prise en compte.

    En espérant que vous arriverez à m’aider.

    #1961027
    momofr@free.fr
    Modérateur
    Maître WordPress
    2034 contributions

    Salut, « je ne reçois pas les mails d’inscription et ceux qui complètent le formulaire d’email de confirmation non plus. », si tu parles d’hier OVH était en carafe donc c’est normal que rien ne fonctionne, mais depuis se matin ça doit être OK.

    #1961030
    SpitfireLRDM
    Participant
    Initié WordPress
    4 contributions

    Bonjour Momofr,

    Merci pour ta rapidité, hélas ce n’est pas lié à OVH et sa coupure d’électricité d’hier.

    Je me suis aperçu du problème mardi matin et j’ai laissé trainer en pensant que ça s’arrangerai tout seul. (l’espoir fait vivre)

    #1961165
    momofr@free.fr
    Modérateur
    Maître WordPress
    2034 contributions

    Il te faut pister les logs d’erreur de WordPress, par exemple avec query-monitor.

    #1963988
    SpitfireLRDM
    Participant
    Initié WordPress
    4 contributions

    Bonjour Momofr,

     

    merci pour ton retours, j’ai bien téléchargé query monitor. C’est un peu du chinois pour moi du fait qu’il y ait tellement d’informations.

    il me détecte 2 erreurs PHP. As-tu une idée du problème ?
    <table cellspacing= »0″>
    <thead>
    <tr>
    <th colspan= »2″ scope= »col »>PHP Error</th>
    <th class= »qm-num » scope= »col »>Count</th>
    <th scope= »col »>Location</th>
    <th scope= »col »>Call Stack</th>
    <th scope= »col »>Component</th>
    </tr>
    </thead>
    <tbody class= »qm-group »>
    <tr class= »qm-php-error qm-php-error-strict »>
    <th rowspan= »2″ scope= »row »>Strict</th>
    <td class= »qm-ltr »>Declaration of TGM_Bulk_Installer_Skin::before() should be compatible with Bulk_Upgrader_Skin::before($title =  »)</td>
    <td class= »qm-num »>1</td>
    <td class= »qm-ltr »>wp-content/themes/rocco/functions/class-tgm-plugin-activation.php:1893</td>
    <td class= »qm-row-caller qm-row-stack qm-nowrap qm-ltr »>

    1. wp-content/themes/rocco/functions.php
      <span class= »qm-info qm-supplemental »>wp-content/themes/rocco/functions.php:83</span>

    </td>
    <td class= »qm-nowrap »>Theme</td>
    </tr>
    <tr class= »qm-php-error qm-php-error-strict »>
    <td class= »qm-ltr »>Declaration of TGM_Bulk_Installer_Skin::after() should be compatible with Bulk_Upgrader_Skin::after($title =  »)</td>
    <td class= »qm-num »>1</td>
    <td class= »qm-ltr »>wp-content/themes/rocco/functions/class-tgm-plugin-activation.php:1893</td>
    <td class= »qm-row-caller qm-row-stack qm-nowrap qm-ltr »>

    1. wp-content/themes/rocco/functions.php
      <span class= »qm-info qm-supplemental »>wp-content/themes/rocco/functions.php:83</span>

    </td>
    <td class= »qm-nowrap »>Theme</td>
    </tr>
    </tbody>
    </table>

    #2005676
    SpitfireLRDM
    Participant
    Initié WordPress
    4 contributions

    Hello,

    Petit retour d’expérience pour donner la solution :

    Après moultes recherches, j’ai enfin solutionné mon problème.

    Pour résumer mon problème :

    Du jour au lendemain, aucun de mes mails n’est reçus ou envoyé depuis mon site (depuis contact form7 ou autre)

    Le problème maintenant identifié vient de chez OVH qui a bloqué l’envoi de mails par les scripts CGI // PERL // PHP

    Il suffit de « purger les mails » via cette technique expliquée ici : https://docs.ovh.com/fr/hosting/suivi-emails-automatises/

    En espérant que cela serve aux autres !

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.