Probleme barre d’admin qui disparait et demande de relogin intenpestive.

  • WordPress :4.9.9
  • Statut : non résolu
  • This topic has 9 réponses, 3 participants, and was last updated il y a 1 week by  Li-An.
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2205396
    Pibox
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Stockholm
    • Extensions en place : contact-form7, wordfence, updraftplus, imsanity, ag-custom-admin, image-watermark, contextual-related-posts, js-composer, wp-media-library-categories
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.attrape-coeur-biarritz.com/

    Problème(s) rencontré(s) :

    Bonjour.
    Je rencontre un problème depuis plus d’un an sur un site wordpress que j’administre pour ma mère et ce problème apparait que ce soit pour l’admin (moi) ou d’autres utilisateurs pareil. Je vais essayer d’être le plus clair possible:
    Quel que soit le navigateur:
    Je me connecte au login.
    L’admin apparait correctement.
    Je vais sur le frontend (aller sur le site)
    La barre d’admin noire apparait correctement en haut, jusque là tout est normal.
    Mais: Si je tente par exemple de modifier la page (la page d’accueil donc mais pareil sur les autres) depuis cette barre: ça me renvoie au login…
    Idem si je clique sur le nom du site dans la barre pour retourner normalement au backend.
    Si j’essaie de me relogger a ce moment là , ça me fait une erreur (les cookies sont pas activés blablabla) . Bien sur les cookies sont activés sur tous mes navigateurs.
    A partir de  là, je n’ai plus qu’a revenir en arrière pour retrouver la page d’accueil mais… là la barre d’admin a disparue…
    Si je retourne encore en arrière, je retrouve le backend et je suis bien toujours connecté, je peux tout y faire normalement.
    Mais maintenant si je retourne sur le frontend, je n’ai plus la barre d’admin en haut ! Pour la retrouver (juste temporairement) il faut que je me déconnecte et que je me reconnecte)

    Donc pour résumer:
    que la barre s’affiche ou pas, je ne peux JAMAIS m’en servir et cette histoire de reconnexion quand on veut modifier une page me rend fou !
    Je suis obligé d’utiliser le retour arriere du navigateur pour chaque action ou ouvrir pleins d’ onglets, c’est pas super pratique.
    Pour editer une page ou un article on est obligés d’aller dans le backend et de chercher la page ou l’article en question pour le modifier, c’est très pénible…mais c’est surtout pour ma mère que c’est embêtant (c’est son site) car elle manipule moins bien que moi tout ça… Moi j’arrive a me débrouiller mais c’est vraiment gonflant de ne rien pouvoir faire depuis le frontend.

    Je pète un câble.
    J’ai:
    -bien sur verifié dans les profils.
    -Remplaçé TOUS LES FICHIERS wordpress et refait le wp-config.php

    -supprimé le .htaccess que le plugin wordfence m’avait créé
    -Désactivé TOUS les plugins en renommant par ftp le dossier plugin
    -Essayé d’autres themes

    -Refait de nouveaux utilisateurs, dont un admin pour tester.
    -bien sur testé sur plusieurs ordis a plusieurs endroits…

    Toujours le même problème récurant.
    ça fait un an, malgré les mises a jour de wp et de mon theme, rien n’a jamais corrigé ce problème.
    Je n’ai jamais rien modifié, a part un peu de css dans des plugins, rien de plus. Je n’ai pas les compétences pour.
    Je n’en peux plus, je suis prêt a payer pour qu’on me dépanne.
    Si quelqu’un a une idée…
    Merci.

    • Ce sujet a été modifié le il y a 2 weeks par  Pibox.
    #2205416
    Pibox
    Participant
    Initié WordPress
    6 contributions

    Je viens de migrer le site en local avec duplicator et en local je n’ai pas ce problème. tout est ok.  Je ne comprend rien.
    Help.

    • Cette réponse a été modifiée le il y a 2 weeks par  Pibox. Raison: précisions
    • Cette réponse a été modifiée le il y a 2 weeks par  Pibox.
    #2205466
    PhiLyon
    Modérateur
    Maître WordPress
    20350 contributions
    #2205821
    Pibox
    Participant
    Initié WordPress
    6 contributions

    Bonsoir, Effectivement j’étais en 5.4 et je suis passé en 7.1 mais il n’y a aucun changement…
    Il faut peut être que j’attende un peu.

    Edit: Ouiiii ça fonctionne. Merci beaucoup !
    c’était si simple lol… :p

    • Cette réponse a été modifiée le il y a 2 weeks par  Pibox.
    • Cette réponse a été modifiée le il y a 2 weeks par  Pibox. Raison: résolu!
    #2205827
    PhiLyon
    Modérateur
    Maître WordPress
    20350 contributions

    Il faut afficher « Résolu » en haut à gauche de cette page.

    🙂

    #2207229
    Pibox
    Participant
    Initié WordPress
    6 contributions

    Je déterre car mon probleme est revenu quelques jours apres sans raison…
    Je suis toujours en php 7.1 sur OVH et je n’ai rien modifié sur le site…
    toujours la barre d’admin inutilisable quand elle apparait (juste une fois au début)
    Encore une fois j’ai tenté de désactiver tous les plugins sans succes, essayé tous les navigateurs existants ect…

    Je deviens vraiment fou avec ce bug.

    • Cette réponse a été modifiée le il y a 1 week et 1 day par  Pibox.
    #2207231
    Pibox
    Participant
    Initié WordPress
    6 contributions

    Ce qui m’amene une autre question de débutant: dans quel fichier trouve-t-on le CSS personalisé qu’on peut éditer via le menu « personnaliser » en frontend?
    Vu que ce menu ne marche plus pour moi depuis longtemps et que j’ai besoin d’intervenir sur le css que j’avais écrit dedans, j’aimerai savoir où je peut trouver le fichier. Merci.

    Edit: par rapport a mon bug, la copie de mon site en local fonctionne toujours correctement, et c’est exactement les mêmes fichiers, je n’ai rien touché.
    Je pense que je vais finir par tout supprimer et tout reinstaller, mais j’ai un peu peur d’empirer la situation….

    • Cette réponse a été modifiée le il y a 1 week et 1 day par  Pibox.
    #2207256
    Li-An
    Modérateur
    Maître WordPress
    20104 contributions

    Bonjour, vous pouvez renvoyer les fichiers de WP par FTP en écrasant ceux existants – vous ne perdrez pas de données sauf si vous utilisez un des thèmes par défaut modifié par vos soins.

    #2207260
    Pibox
    Participant
    Initié WordPress
    6 contributions

    Bonsoir merci pour votre réponse, malheureusement j’avais deja fait ça l’autre jour sans succes (avant de changer la version PHP chez ovh) je retenterai demain mais j’y crois moyen…

    #2207267
    Li-An
    Modérateur
    Maître WordPress
    20104 contributions

    Mettez-nous le contenu de votre htaccess pour voir ?

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.