problème avec une erreur 403 sur le fichier admin-ajax.php (Créer un compte)

  • WordPress :4.7
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #1618138
    romk
    Participant
    Padawan WordPress
    60 contributions

    Bonjour à tous,

    Je rencontre une erreur systématique sur une mise a jour admin d’un template, je ne sais pas si c’est lié à l’hébergeur ou au theme (https://pro.photo/); qui d’ailleurs se renvoient la balle lorsque je les contacte. Le problème est visible en admin uniquement car le thème propose une vue « test-drive ».

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 7.1 / <span data-ng-bind= »element.type »>MYSQL</span> <span data-ng-if= »element.version »> v.5.5</span>
    • Thème utilisé : Prophoto Blog V6 – https://pro.photo/ (source du problème)
    • Nom de l’hébergeur : OVH – offre mutualisée Pro
    • Adresse du site : http://www.trendz.fr
    • Certificat SSL : <span data-ng-bind= »hosting.hasHostedSsl || ssl ? i18n.common_yes : i18n.common_no »>Oui</span>
    • Extensions : Akismet, Comment Reply Notification, Contact Form 7, Contact Form 7 – PayPal Add-on, Google XML Sitemaps, Scroll Back to Top, Slider PRO, WordPress Database Backup, WP Super Simple Speed, Yoast SEO
    • PHP info : http://fpm7.0-check.cluster002.ovh.net/phpinfo.php

    Problème(s) rencontré(s) : Je rencontre une erreur 403 lors de la mise à jour du template prophoto V6 (impossible à voir en ligne) sur le fichier « admin-ajax.php » uniquement (apparemment).

    Pourriez vous me dire si ce problème est plus du coté hébergeur ou si c’est un problème de développement ? Sachant que ce template est utilisé par beaucoup de personnes (photographes). Il fonctionne d’ailleurs très bien chez une collègue qui est aussi chez OVH avec la même offre que moi – à ne rien comprendre.

     

    Merci pour vos lumières ! Sinon je devrais changer d’hébergeur 🙁

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1618166
    Franck (fge)
    Modérateur
    Maître WordPress
    9573 contributions

    Une erreur HTTP 403 signifie que ce l’action n’est pas autorisée par le serveur Web. Il faut donc commencer par vérifier si tu n’as pas mis des limitations dans ta configuration Apache (une interdiction d’afficher les fichiers contenant « admin » par exemple) du côté des extensions pour des raisons de sécurité. As-tu vérifié ce point ?

    #1618176
    romk
    Participant
    Padawan WordPress
    60 contributions

    Bonjour Franck, merci pour ta réponse.

    Comment mettre des limitations dans ta configuration Apache sur un serveur mutualisé ? Cela pourrait provenir d’une configuration d’un plugin ? Comment rétablir une configuration d’origine ?

    #1618315
    Franck (fge)
    Modérateur
    Maître WordPress
    9573 contributions

    Ok, mon explication n’était pas des plus limpides.

    Comment mettre des limitations dans ta configuration Apache sur un serveur mutualisé ?

    Simplement avec un .htaccess contenant une commande du genre :

    <Files "admin">
    Order allow,deny
    Deny from all
    </Files>

    Cela pourrait provenir d’une configuration d’un plugin ?

    Je pensais plutôt à un fichier .htaccess bloquant l’accès au répertoire wp-content\plugins\. Je ne pense pas que cela puisse venir d’une des extensions que tu as citées plus haut, il n’y a pas d’extension de sécurité dans la liste.

    #1618386
    romk
    Participant
    Padawan WordPress
    60 contributions

    Merci Franck pour ta réponse.

    Voici le contenu de mon htaccess, je ne vois rien qui puisse bloquer l’accès.

    D’autant plus que tout fonctionne très bien  avec mon template actuel.

    Options +FollowSymLinks
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Htaccess

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.