Probleme avec le Slash et les catégories

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #454341
    LiloBZH
    Membre
    Initié WordPress
    26 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.3
    – Thème utilisé : Maison
    – Plugins en place : Aucun
    – Nom de l’hebergeur : DediBx
    – Adresse du site : journaldufreenaute.fr

    Problème(s) rencontré(s) :

    Bonjour,

    Depuis la mise a jour (en ce moment ^^ ) , il y a un soucis avec les catégories

    Avant, on avait ca :

    http://www.journaldufreenaute.fr/category/bretagne-normandie/

    et maintenant ca :

    http://www.journaldufreenaute.fr/category/bretagne-normandie

    le Slash de la fin a disparu et c’est pas cool ^^

    Si il y a quelques pour me dépanner, ca serait sympa

    merci 🙂

    #610845
    sinklar
    Membre
    Initié WordPress
    33 contributions

    Vérifie la strtucture des permaliens et ajoute un slash si nécessaire. 😉

    #610846
    LiloBZH
    Membre
    Initié WordPress
    26 contributions

    ji ai pensé mais si j ajoute un slash, ca va pas me plaire non plus ^^

    actuellement, il y a ca :

    /%day%/%monthnum%/%year%/%postname%.html

    si je rajoute un / a la fin, les articles vont eux aussi finir par un / … ;(

    #610847
    bertimus
    Participant
    Initié WordPress
    19 contributions

    Hello LiloBZH,

    Mini UP pour donner la solution, car mon potos Colin vient de me la donner [oui oui, je viens seulement de mettre à jour mon blog de la 2.2 à la 2.3.2 :D]

    Ca se passe dans /wp-includes/ et le responsable est canonical.php (nouveau fichier créé avec la 2.3)

    Alors, tu commentes simplement la dernière ligne pour désactiver la fonction :

    // add_action(‘template_redirect’, ‘redirect_canonical’);

    Alors la redirection est désactivée.

    PS : Si quelqu’un a une solution moins barbare, qu’il n’hésite surtout pas hein 😉

    #610848
    deleter23
    Participant
    Initié WordPress
    4 contributions

    Bonjour à tous,

    Je me permet de faire un petit up car j’ai le même problème. J’ai testé la solution donnée par bertimus mais cela ne fonctionne pas.

    Le problème ne vient pas d’une redirection qui serai faite mais dans la création de la structure d’url. Dans la création de l’url des categories n’est pas ajouté le / à la fin.

    Merci d’avance pour votre aide,
    Cyril

    #610849
    deleter23
    Participant
    Initié WordPress
    4 contributions

    Bon ba j’ai trouvé en faite (apres plusieurs heures de recherches).
    Je donne donc la solution pour certaines personnes qui pouri cherché à l’avenir:

    Ouvrir wp-includes/ puis category-template.php

    chercher:

    $catlink = get_option(‘home’) . user_trailingslashit($catlink, ‘category’);

    Et remplacer par:

    $catlink = get_option(‘home’) . user_trailingslashit($catlink, ‘category’) . ‘/’;

    Et il faut éditer canonibal.php comme expliqué par bertimus pour éviter que les url soit rediriger sans /

    Voili voilou,
    ++ Cyril

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.