probleme avec firefox (Créer un compte)

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #447275
    michele
    Membre
    Initié WordPress
    3 contributions

    bonjour
    j’ai un poblème avec mon blog et wp, enfin plein de problèmes mais je vais commencer par un: avec Internet Explorer quand je suis connectée j’ai bien accès à site admin , mais avec firefox rien j’écris mon username et mon pass, et rien dans la barre d’adresse j’ai ça –> wp-login.php?redirect_to=%2Fblog%2Fwp-admin%2F alors qu’avec IE –>/blog/wp-admin/
    J’ai wp 2.0.2, upgradé depuis quelques jours seulement, mais j’avoue que je me sers très peu de firefox aussi je ne sais pas si c’était pareil avant d’installer la version 2 de wp.
    je ne comprends pas trop et j’espère que vous saurez me dire dans quel fichier faire une modification.
    Michèle

    #571981
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Comportement anormal. Réinstalle les fichiers ?

    #571982
    michele
    Membre
    Initié WordPress
    3 contributions

    je vais recharger mes fichiers, je pense qu’il y a eu une erreur à ce moment là, merci pour votre réponse.

    #571983
    Touffe
    Membre
    Initié WordPress
    10 contributions

    Salut !
    J’ai exactement le même problème mais avec une installation nouvelle (hébergée chez Free, faite par mes soins)…
    Je n’ai testé que sous Firefox. J’ai remplacé le fichier wp-login.php, sans succès :-(

    Apparemment, c’est comme si l’authentification ne se faisait pas : donc que la variable $_REQUEST dans wp-login.php n’est pas renseignée.
    Je n’ai pas investigué plus (pas encore trouvé où se fait l’authentification).

    Si quelqu’un a une idée, je suis preneur…

    Touffe

    #571984
    minouche
    Membre
    Initié WordPress
    20 contributions

    bonjour je connais Michele et j’utilise Firefox avec WP sur hebergeur Jexiste.be et fr. et je ne comprends pas non plus ce qu’il se passe ??? pourquoi n’arrivez vous pas a avoir Firefox et ses fichiers en entiers ?? cela a t il avoir avec l’hebergeur Free ? normalement on charge F et l’installe sur son pc ? mais j’aimerai comprendre aussi ..je fais des recherches si je trouve je vous tiens au courant !!
    amities

    je ne pose pas d’autres questions :
    michele poste”j’ai un poblème avec mon blog et wp, enfin plein de problèmes mais je vais commencer par un: avec Internet Explorer quand je suis connectée j’ai bien accès à site admin , mais avec firefox rien j’écris mon username et mon pass, et rien dans la barre d’adresse j’ai ça –> wp-login.php?redirect_to=%2Fblog%2Fwp-admin%2F alors qu’avec IE –>/blog/wp-admin/
    J’ai wp 2.0.2, upgradé depuis quelques jours seulement, mais j’avoue que je me sers très peu de firefox aussi je ne sais pas si c’était pareil avant d’installer la version 2 de wp.
    je ne comprends pas trop et j’espère que vous saurez me dire dans quel fichier faire une modification.
    Michèle”
    et apres une autre personne dit la meme chose : Touf
    J’ai exactement le même problème mais avec une installation nouvelle (hébergée chez Free, faite par mes soins)…
    Je n’ai testé que sous Firefox. J’ai remplacé le fichier wp-login.php, sans succès :-(

    Apparemment, c’est comme si l’authentification ne se faisait pas : donc que la variable $_REQUEST dans wp-login.php n’est pas renseignée.
    Je n’ai pas investigué plus (pas encore trouvé où se fait l’authentification).

    Si quelqu’un a une idée, je suis preneur…
    sur quoi je reponds
    j’utilise Firefox et WP sur hebergeur jexiste et je ne trouve pas le probleme de Michel qui est mon amie et que j’essaye d’aider … excuse moi

    #571985
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Merci de créer un nouveau sujet pour toutes autres questions…
    Et veuillez vous exprimer clairement… car personnellement j’ai pa compri grand chose “minouche”

    #571986
    Touffe
    Membre
    Initié WordPress
    10 contributions

    J’ai testé avec IE…
    Il se passe la même chose qu’avec Firefox : redirection vers la page de login avec comme adresse :
    monsite.fr/wp-login.php?redirect_to=%2Ftest1%2Fwp-admin%2F

    #571987
    Touffe
    Membre
    Initié WordPress
    10 contributions

    J’ai résolu le problème !!!

    Pour cela, dans le fichier wp-settings.php, au lieu de mettre le chemin du dossier parent de WordPress et PWG, j’ai mis “/” (comme préconisé par Jillij).

    Plus de problème !!!

    #571988
    michele
    Membre
    Initié WordPress
    3 contributions

    je viens de regarder les réponses à ma demande, je vois que je n’étais pas seule, je vous explique ce que j’ai fait:
    d’abord recommencer à charger tous mes fichiers, tout bien vérifié,
    ok toujours le même problème
    j’ai appliqué la solution radicale , ne riez pas supprimer mon blog et recommencer,
    toujours pareil
    je vais sur l’ordi de mon mari juste à côté, je lui ai installe firefox …et bien sur le sien ça marche
    donc ça doit venir de mon pare feu ou une autre chose dans ce style, mais bon je cherche et ne trouve pas
    Aussi la solution proposée ci dessus : dans le
    wp-settings.php, au lieu de mettre le chemin du dossier parent de WordPress et PWG, j’ai mis “/” (comme préconisé par Jillij).
    je voudrais bien mais j’ai regardé ce fichier et c’est un peu du chinois pour moi , est ce que tu pourrais m’en dire un peu plus, s’il te plait.
    merci et bonne fête de pâques
    Michèle

    #571989
    Touffe
    Membre
    Initié WordPress
    10 contributions

    La modif que j’ai faite est demandée lors de l’installation de Photon (un plugin permettant de relier WordPress à Phpwebgallery) je ne sais pas si c’est valable si on a juste WordPress…

    Voici ce qu’il dit :

    ligne 156
    Remplacez

    if ( !defined(‘COOKIEPATH’) )
    define(‘COOKIEPATH’, preg_replace(‘|https?😕/[^/]+|i’, ”, get_settings(‘home’) . ‘/’ ) );
    if ( !defined(‘SITECOOKIEPATH’) )
    define(‘SITECOOKIEPATH’, preg_replace(‘|https?😕/[^/]+|i’, ”, get_settings(‘siteurl’) . ‘/’ ) );

    par

    if ( !defined(‘COOKIEPATH’) )
    define(‘COOKIEPATH’, “Dossier parent �phpwebgallery et wordpress” );
    if ( !defined(‘SITECOOKIEPATH’) )
    define(‘SITECOOKIEPATH’, “Dossier parent �phpwebgallery et wordpress” );

    Cette derni�e modifications permet �wordpress d’acc�er aux cookies de phpwebgallery.
    Donc “Dossier parent �phpwebgallery et wordpress” doit �re un dossier qui contient
    �la fois wordpress et phpwwebgallery. Exemple : vous avez http://www.votresite.com/dossier/phpwebgallery/
    et http://www.votresite.com/dossier/wordpress/ donc /dossier/ devrait marcher.
    Ecrivez :

    if ( !defined(‘COOKIEPATH’) )
    define(‘COOKIEPATH’, “http://www.votresite.com/dossier/” );
    if ( !defined(‘SITECOOKIEPATH’) )
    define(‘SITECOOKIEPATH’, “http://www.votresite.com/dossier/” );

    Si vous ne savez pas quoi mettre �la place de “Dossier parent �phpwebgallery et wordpress”,
    mettez simplement

    if ( !defined(‘COOKIEPATH’) )
    define(‘COOKIEPATH’, “/” );
    if ( !defined(‘SITECOOKIEPATH’) )
    define(‘SITECOOKIEPATH’, “/” );

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.