Problème au niveau rapidité de mon blog WordPress ! (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 22)
  • Auteur
    Messages
  • #527784
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Bonjour,

    Il existe un grand nombre de tutos sur Internet, différents plugins comme WP Super Cache, WP Optimize etc pour accentuer la rapidité des blogs WordPress. J’ai appliqué ces techniques, ai suivi de bons tutos pour les configurer, mon site est ainsi plus rapide de moitié, mais son temps de chargement reste élevé (de 5 à 7 secondes).

    J’aimerais aller un cran plus bas, pour que les utilisateurs ne perdent pas patience… J’ai testé mon site sur différentes plateformes se chargeant de noter les performances de mon site web, et j’en ressort avec ce but : « Remove query strings from static resources ».

    Ils m’affichent donc cela, mon site est donc considérablement ralenti par ces codes. J’aimerais ainsi savoir comment « Remove query strings from static resources », tout simplement 😉

    J’ai cherché à résoudre ce problème grâce au moteur de recherche « Google », je ne sais pas si vous connaissez. C’est plutôt pas mal : http://www.google.fr (adresse à retenir) ^^ Non, plus sérieusement, les tutos sont en Anglais, et ils n’indiquent pas où exactement placer les codes pour que cela résolve le problème.

    Je m’adresse donc à vous, comment faire en sorte que mon blog soit considérablement plus rapide ? Vous serez peut-être plus à l’aise que moi pour décrypter le problème.

    Merci de vos prochaines réponses !

    Ma configuration WP actuelle
    – Version de WordPress : 3.6
    – Version de PHP/MySQL :
    – Thème utilisé : Proxy responsive
    – Extensions en place : il y en a environ 30, mais indispensables
    – Nom de l’hebergeur : OVH hébergement perso (je sais, il n’est pas très rapide, voir pas du tout !)
    – Adresse du site : http://www.thewip.fr (site web en stade de développement, il n’y a rien à voir sauf le code pour déterminer la raison de mon problème 🙂

    Problème(s) rencontré(s) : Problème au niveau rapidité de mon blog WordPress !

    #910037
    Lumiere de Lune
    Participant
    Maître WordPress
    20344 contributions

    as tu vérifié les temps de connexion en n’étant pas admin ?

    #910038
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Oui, en navigation privée, je ne suis pas connecté, cela prend environ 7 secondes…

    #910039
    Li-An
    Modérateur
    Maître WordPress
    26443 contributions

    Tu peux essayer ça http://diywpblog.com/wordpress-optimization-remove-query-strings-from-static-resources/ – et il y a même un plugin qui le fait mais perso, ça m’a allongé le temps de chargement du site, j’ai donc laissé tomber.
    Autour de 5 secondes c’est pas si mal… surtout si le site est blindé de plugins « indispensables ». Je serai curieux de voir la liste d’ailleurs. Si vraiment vous voulez que ça aille vite, un plugin de cache et une réduction drastique de la taille des images et un bon hébergeur.

    #910040
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Oui, ça me ralenti aussi… Les 30 plugins sont en majorité des extensions de Buddypress, pour améliorer mon « réseau social ». Pour qu’il soit au top, j’en ai besoin 😉

    Mon WP Super Cache, je le disais, m’a atténué ce temps de chargement, mais j’aimerais tout de même que cela rende mieux. J’ai essayé WP Smush pour les images etc, mais il me ralentit aussi. Qu’est-ce exactement qu’une réduction drastique pour WordPress ? Quels sont les plugins qui y correspondent ?

    Ou auriez-vous d’autres solutions ? J’imagine qu’il existe pas mal de combines. Je peux tout faire, si on m’explique bien les choses :D

    Merci !

    #910041
    nomadelj
    Membre
    Chevalier WordPress
    351 contributions

    Bonjour, votre site ne semble pas lent, vitesse obtenue de la page accueil thewip :
    Page load time: 4.00s
    Total page size: 319KB
    Total number of requests: 31

    – mais il est lent car certaines images appelées répondent par une erreur 404. (non trouvé).
    Ce qui passe à 3 secondes de + le temps que le navigateur attend l’image, en vain.

    apres cest peut etre parce que le site est adresse de test et il ny a pas les images en ligne.

    – cet element « php css » met 3 secondes encore + à se charger.
    http://thewip.fr/wp-content/themes/proxy/assets/css/user-styles.php?ver=3.6

    que contient-il ?

    – aussi le script API Google Plus One semble appeler 2 fois.
    Le 2ème fois appeler ajoute +1s. pour un js de 12.9 KB.

    après, le conseil serait de diminuer le nombre de scripts chargés. et peut etre de les charger que si besoin sur la page :
    exemple. le js d’un formulaire de contact na besoin detre chargé que sur la page contact.

    #910042
    Li-An
    Modérateur
    Maître WordPress
    26443 contributions

    Buddypress n’est pas connu pour sa légèreté. Vous ne pouvez pas demander à un site – et encore là, il n’y a pas de visiteurs agissant – d’être réactif et gourmand en ressources… Ou alors il faut s’appeler Google et Facebook avec les moyens techniques qui vont avec.

    #910043
    Li-An
    Modérateur
    Maître WordPress
    26443 contributions

    Pour les images, jette un oeil là-dessus: http://www.echodesplugins.li-an.fr/plugins/ewww-image-optimizer/

    #910044
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Non, ce plugin me fait 15 secondes de chargement ! Bon, tant pis 😕

    #910045
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Bon, je vais quand même le garder, au final, je suis plus vers les 8-10 secondes, pas trop mal !

    #910046
    Li-An
    Modérateur
    Maître WordPress
    26443 contributions

    Ce plugin ne peut pas augmenter ton chargement ! Il ne fonctionne que lorsque tu uploades des images !

    #910047
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Oui, tu as raison, comme je le disais, à la longue, cela a réduit le temps de chargement (mais de 0,5 secondes, pas plus, normal, car je n’ai pas beaucoup d’images).

    Je n’avais donc pas trouvé de solutions efficace jusqu’à ce que je tente de mettre des fichiers directement mis en cache sur WP Super Cache (dans Avancé). Il faut faire attention avec cette technique, car on ne peut plus aisément modifier la page d’accueil (si on insère son URL), la barre d’administration se retire de toutes les pages que l’on a renseigné dans cette section, mais le temps de chargement est tout bonnement exceptionnel !

    Mon site met désormais 6 secondes maxi pour se charger, contre 8-10 secondes minimum avant.

    J’ai donc choisi de ne pas renseigner de pages dans cette section, que les liens utiles que je ne modifierai pas avant longtemps ou qui sont d’une réelle utilité. De toute manière, si je désactive cette fonctionnalité, je peux modifier mes pages d’accueil visiblement. Je n’aurai plus qu’à ré-activer l’option.

    Voilà, méthode un peu barbare, mais qui fonctionne largement pour moi.

    Merci de ton aide !

    #910048
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Pour nomadelj : dans mon dossier http://thewip.fr/wp-content/themes/proxy/assets/css/user-styles.php?ver=3.6, il y a ma police d’écriture :

    /* User related Theme Styles */
    
    body{
        font-family: « Droid Sans »;}

    Est-ce grave si je supprime ce fichier ?

    #910049
    lefevre
    Membre
    Chevalier WordPress
    255 contributions

    Et où trouver le script API Google Plus One ? Merci !

    #910050
    nomadelj
    Membre
    Chevalier WordPress
    351 contributions

    Bonjour, à Lefevre

    c’est les éléments que j’ai trouvé qui ralentissent le chargement et l’affichage de la page d’accueil, sur votre site.

    j’ai relevé que :
    – certaines images appelées répondent par une erreur 404. (non trouvé). 5 secondes de + à charger.
    MAJ : toujours actuellement

    – cet élément « php css » met 3 secondes encore + à se charger.
    non ne le supprimez pas.
    vous pouvez soit déplacer le code css contenant votre font, direct dans le style.css de votre theme. (à tester si cela fonctionne)
    ou vous pouvez comprendre pourquoi c’est si long.
    MAJ : vous avez changé ce fichier depuis. maintenant il est appelé mais vide.

    – le script .js nommé http://apis.google.com/js/plusone.js est chargés deux fois :
    1ere fois il est chargé en 590 ms. ce qui correct.
    une 2ème fois il est chargé en 5s. ce qui pas bon ou étrange.

    A vous de trouver pourquoi il est appelé 2 fois ? plugins ? themes ? et pourquoi c’est si long.

    maintenant, il faut tenir compte que : l’adresse indiqué de « votre site web en stade de développement,
    il n’y a rien à voir sauf le code » et donc les tests sont peut être faussés.
    mais là en l’état, le site charge :

    Page load time: 6.20s
    Total page size: 293KB
    Total number of requests: 54

    Page Speed Grade: C : 77%
    YSlow Grade: C :75%

    ce qui est pas mal. Il y a juste les trucs que j’ai relevé qui ralentissent le tout.
    après on peut aller + loin pour passer d’un grade CC à AA. mais déjà régler ces éléments en question.

15 sujets de 1 à 15 (sur un total de 22)
  • Vous devez être connecté pour répondre à ce sujet.