Problème aléatoire d’alignement vertical (depuis màj WP 4.1.1) (Créer un compte)

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #547451
    Miracle
    Participant
    Padawan WordPress
    77 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.1.1
    – Version de PHP/MySQL : 5.4
    – Thème utilisé : WP Creativix
    – Extensions en place : Google Analytics, Contact Form, Hupso Share Buttons, Tag Page,s WP Sitemap, Isotope Gallery
    – Nom de l’hebergeur : Celeonet
    – Adresse du site : http://www.opus-numerica.com/

    Problème(s) rencontré(s) :

    Depuis ce matin j’observe un problème d’autant plus incompréhensible qu’il est aléatoire (càd pas systématique !). Pb identique sur les principaux navigateurs.

    Sur la page d’accueil, dans le bandeau sur fond vert anis : les vignettes que l’on peut faire défiler avec les flèches ne sont plus alignées verticalement dans le conteneur comme elles devraient l’être.

    J’ai fait différents essais de correction, notamment en modifiant cette classe :

    ul#slide_navigation {
    float: left;
    width: 921px;
    list-style: none;
    }

    J’ai notamment essayé d’ajouter un vertical-align, en remplaçant float-left par un inline-block.
    J’ai aussi essayé de jouer sur les padding, sans succès non plus.

    Bref, je suis à court d’idées.
    La Màj WP 4.1.1 a eu lieu cette nuit. Je ne suis pas sure que cela ait un rapport. J’ai observé le problème après avoir fait quelques corrections mineures sur d’autres styles et sur le fichier de la page d’accueil, qui ne devraient pas avoir d’impact sur la zone des vignettes, mais parfois le code a ses raisons que ma raison ignore…

    Toute suggestion bienvenue ! Merci d’avance.

    #995804
    PhiLyon
    Modérateur
    Maître WordPress
    28264 contributions

    Bonsoir.

    This theme hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

    Last Updated: 2012-12-02

    C’est peut-être la raison du dysfonctionnement.

    Sinon dans style.php à partir de la ligne 448 il y a ce code où tu peux modifier le margin-top

    .slide_nav {
    float: left;
    width: 921px;
    margin-top: 20px;
    padding-left: 80px;
    }

    🙂

    #995805
    Miracle
    Participant
    Padawan WordPress
    77 contributions

    Bonsoir PhiLyon, merci de ta réponse.

    Je n’avais pas pensé à tester cette classe, pensant que cela affecterait aussi la position des flèches gauche/droite, mais apparemment ce n’est pas le cas.

    J’ai donc modifié le margin-top mais… ça fait un code pas très propre !

    Avec ceci, donc :

    .slide_nav {
    float: left;
    width: 921px;
    margin-top: 4px; /* rétablit alignement vertical des vignettes sous Firefox*/

    margin-top: 20px;

    -webkit-margin-top: 20px; /* OK pour Chrome et Android mais pas pour Safari*/
    padding-left: 80px;
    }

    J’obtiens cela :
    – alignement vertical apparemment OK dans Firefox, Chrome, IE, Android
    – un peu décentré dans Opéra, mais moins moche qu’avant quand même
    – carrément laid dans Safari (les vignettes sont collées en haut du bandeau vert).

    Tout cela n’est donc pas vraiment satisfaisant et et me laisse perplexe, d’autant plus que les préfixes ne me semblent pas prévus pour cet usage… Je ne comprends toujours pas ce qui a déclenché ce truc.

    Je reste donc ouverte aux suggestions car je doute que cette rustine tienne bien longtemps.

    (Je n’avais pas fait attention à l’ancienneté du thème, et d’ailleurs je réalise que je n’avais pas eu la bonne idée de faire un thème enfant quand j’ai créé ce site… honte, honte…)

    #995806
    Miracle
    Participant
    Padawan WordPress
    77 contributions

    Pour l’anecdote (et au cas où vous auriez des idées de remédiation) :

    Hier, l’alignement vertical était OK (enfin, selon la solution de fortune expliquée ci-dessus). Aujourd’hui, c’est de nouveau n’importe quoi (les vignettes plongent même en-dessous du bord inférieur du bandeau vert).

    Toute suggestion bienvenue, toujours…

    #995807
    didier07
    Participant
    Maître WordPress
    1964 contributions

    Si tu veux pas que ça saute, il faut déclarer ta hauteur dans l’appel du slide dans scripts/custom.js à priori.
    Ca ne viens pas du js, c’est un plugin de carousel assez ancien et redoutablement efficace

    #995808
    Miracle
    Participant
    Padawan WordPress
    77 contributions

    Bonjour,

    Je reviens sur ce problème laissé en standby car autres priorités..

    didier07 wrote:
    Si tu veux pas que ça saute, il faut déclarer ta hauteur dans l’appel du slide dans scripts/custom.js à priori.

    Quelqu’un pourrait-il préciser cela ? Quel code/syntaxe serait à utiliser pour cela ?
    Merci d’avance !

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.