Problème affichage Produits dans la boutique Woocommerce (Créer un compte)

  • WordPress :5.2
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #2301548
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • – Version de WordPress : 5.3.2
    • – Version de PHP/MySQL : 7.0.33 / 5.6.46
    • – Thème utilisé : Nantes
    • – Thème URI : http://www.demo.lollum.com/nantes
    • – Extensions en place : BackWPup (3.6.10), Better Search Replace (1.3.3), Black Studio TinyMCE Widget (2.6.9), Boxtal (2.2.2), Broken Link Checker (1.11.9), Classic Editor (1.5), Contact Form 7 (5.1.6), Easing Slider (3.0.8), Forum_wordpress_fr (4.2), Google Analytics (2.2.5), Homepage Control (2.0.3), Jetpack by WordPress.com (7.1.2), Login LockDown (v1.8.1), Lollum Framework (1.34), Lollum Page Builder Yoast Extension (1.0.1), MailPoet 3 (New) (3.39.2), Simple Lightbox (2.7.0), Simple Social Icons (3.0.1), Slider Revolution (5.2.6), TinyMCE Advanced (4.8.0), WooCommerce (3.8.0), WooCommerce E-Transactions Payment plugin (0.9.8.3), WooCommerce Paybox Payment plugin (0.9.8.5), Woocommerce Table Rate Shipping (2.0.6), WordPress Importer (0.6.4), WP-Optimize – Clean, Compress, Cache (3.0.13), Yoast SEO (9.0.3)
    • – Adresse du site : https://www.labutinerie.biz
    • – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai créé en 2016 une boutique en ligne pour mes pots de miel http://www.labutinerie.biz avec le thème Nantes.

    A partir de 2018, j’ai eu un problème avec les mises à jour de ce thème. Lors de l’installation, la disposition des produits de ma boutique est changée. Au lieu d’apparaître en grille (3 colonnes), les images produits apparaissent en grand, pleine largeur, sous forme d’une liste à puce. Pourtant dans les paramètres de la Page Boutique, il est bien demandé un affichage Grid avec 3 colonnes.

    N’ayant pas réussi à résoudre ce problème depuis 2018, je n’ai jamais installé les mises à jour du thème. Mais aujourd’hui, mon thème de 2016 a trop d’incompatibilité avec le nouveau WordPress, je ne peux plus continuer comme ça.

    Je ne suis pas informaticienne mais plutôt apicultrice….. J’ai beaucoup travaillé à la fabrication de mon site mais je ne sais pas rentrer dans le code. Je vous remercie d’avance si vous pouvez m’aider et me donner des conseils faciles.

    Merci, Laura

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2301633
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions

    Salut, le thème que tu utilises est payant, si on le possède pas impossible de t’aider. Les forums WPFR sont dédiés au thèmes et extensions gratuite.

    Je te conseille de voir avec le support du thème.

    Ceci dit si ton thème n’est plus à jour comment savoir si la version installée n’est pas boguée et que ton souci est peut-être résolu avec une version plus récente ?

    #2301690
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    Merci pour ta réponse.

    Effectivement c’est un thème payant, mais mon accès au support n’est plus valide. Aujourd’hui il faudrait que je paie plus de 50€ pour leur poser ma question… 😬

    Et c’est justement la version initiale de 2016 qui affiche normalement ma grille de produit. Mais cette version commence à avoir des bug dans le backoffice depuis la dernière maj WordPress.

    Toutes les versions sorties depuis 2017 par Nantes, dont la toute dernière, me posent ce problème d’affichage. Donc j’imagine que le problème vient plutôt de chez moi, sinon ils auraient repéré le bug…

    #2301693
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions
    Cette réponse a été marquée comme privée.
    #2301701
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    Super merci, je viens de t’envoyer un mail !

    #2301725
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions
    Cette réponse a été marquée comme privée.
    #2301765
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    Wahou génial !! Merci beaucoup !! Ca paraissait insurmontable pour moi… 😉

    Si je peux me permettre… Sur la page Accueil, je fais apparaître une sélection produit avec 4 miels. En affichage écran large, ces 4 produits s’affichent désormais en ligne, mon problème est résolu, merci c’est parfait.

    Mais sur le téléphone, l’affichage de ces 4 miels bug, ils sont en ligne, mais ya pas la place. Ils devraient s’afficher en colonne comme dans la boutique.

    Si tu veux bien m’envoyer ton adresse postale par mail, ce coup de main mérite bien un peu de miel ! 😉

    Merci !

    #2301766
    PhiLyon
    Modérateur
    Maître WordPress
    25679 contributions
    Cette réponse a été marquée comme privée.
    #2301805
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    On en apprend tous les jours ! XD

    😆

    #2301816
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    En fait je suis encore un peu embêtée… Je pensais que l’installation de la dernière version de mon thème allait résoudre mes problèmes dans le backoffice. Mais en fait, même après la mise en jour de mon thème, j’ai des problèmes depuis la mise à jour de WordPress : je ne peux plus modifier le contenu de mon site.

    Dans le backoffice, le contenu de mes pages est géré sous forme de “Page Element”. Désormais, je ne peux même plus modifier, supprimer ou déplacer le moindre de ces blocs. En installant l’extension “Classic Editor”, j’arrive à ouvrir ces blocs mais seulement en affichage Mobile. Et les modifications ne sont pas prises en compte une fois que j’ai mis à jour la page. Bref, je ne peux apporter aucune modification et mise à jour des informations de mon site.

    Mon thème n’est il plus compatible avec le dernier WordPress et il faut que je reparte à 0 avec un autre thème ? Faut-il que je paie le support de ce thème pour avoir des solutions ?

    Merci d’avance

     

    #2301850
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions

    Salut, tu dois passer ton hébergement en PHP 7.3 déjà. Pour le thème il n’est pas récent mais semble suivi donc ça devrait fonctionner même si il est peu vendu en fait (création 2014). Essaye de désactiver JetPack qui est connu pour poser des souci avec les sites ayant beaucoup d’extensions comme le tien.

    #2301854
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    Merci,

    En désactivant simplement JetPack, j’ai toujours mes problèmes pour modifier le contenu de mon site.

    Pour passer PHP 7.3 j’ai du désactiver mon extension Slider Révolution qui créait visiblement un conflit… Mais je l’ai fais, et mes problèmes sont toujours là, je ne peux pas modifier mes “Page Element” et donc mettre à jour les informations de mon site… 🙁

    #2301870
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions

    Salut, tu dois désactiver toutes tes extensions et tester une à une, je pense qu’il y a un conflit quelque part.

    #2301905
    lauraschwin
    Participant
    Initié WordPress
    13 contributions

    Bonsoir,

    J’ai désactivé toutes les extensions, même woocommerce. Le site ne ressemble plus à grand chose…

    Mais j’ai toujours les mêmes problèmes.  J’envoie des illustrations : les bloc “Page Element” s’ouvrent mal et les modifications de contenu ne sont pas prises en compte.

    Il ne reste plus qu’une seule extension active, “Lollum Framework”, sans laquelle mon site serait tout blanc et je n’aurais plus accès aux “Pages element” du back office.

    (Je laisse mon site tel quel pour la soirée, mais demain (si je ne suis pas partie pour la maternité) je réactiverai les extensions nécessaires au fonctionnement de mon site)

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2301977
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions

    Salut, j’ai testé ton thème en v1.7.5 avec un WordPress 5.3.2 sous PHP 7.3, tout est fonctionnel.

    Lorsque tu es en mode édition de page, regarde la console web de ton navigateur, il y a peut être des erreurs JS qui pourraient expliquer tes soucis. Une installation incomplète du thème par exemple, il est bien à jour (v1.7.6) ? Je vois dans le changelog que le fichier init.js à été mis à jour.

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.