Présentation des pages

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #447816
    Rico
    Membre
    Padawan WordPress
    51 contributions

    Bonjour,

    J’ai une question de débutant, mais quel code dois-je insérer dans le fichier gérant la présentation des pages (j’entends par là celles créées avec la fonction “Ecrire une page” de WordPress) afin que celles-ci s’affichent de la même façon que ma page d’accueil ?
    J’avais enfin atteint un résultat qui me plaît à peu près pour celle-ci et là je m’aperçois que les pages ne conservent que le footer ! Et comme je veux utiliser WordPress pour faire un véritable site, c’est la fonction “pages” que je vais utiliser le plus.

    #574922
    AmO
    Participant
    Maître WordPress
    4452 contributions

    En modifiant le fichier page.php ?

    #574923
    Rico
    Membre
    Padawan WordPress
    51 contributions

    Oui mais comment reprendre les éléments de la feuille de style ?

    J’ai essayé d’ajouter un comme il y a la même chose pour header et footer, mais ça m’affiche le message d’erreur suivant :
    Warning: Missing argument 1 for get_page() in functions.php on line 503

    #574924
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    get_page() est une fonction interne, à ne pas utiliser dans un template.
    De ce que je comprend, tu veux afficher header+sidebar+footer ? Ajoute get_sidebar() dans ton page.php, donc.

    #574925
    Rico
    Membre
    Padawan WordPress
    51 contributions

    Après avoir été faire un tour dans le Codex, je me dis que tout devrait fonctionner puisque le fichier page.php appelle le hearder.php qui lui contient la référence à mon fond.
    La question est donc : pourquoi s’affiche-t-il sur la page d’accueil mais plus dans les pages suivantes ?

    Pour que ça soit plus clair :
    http://www.kymeracomics.com/wordpress/
    (c’est juste une version test pour mettre au point le style)
    Si vous allez dans les Pages Runners ou Starchild, l’image de fond a disparu !

    #574926
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Y’a un truc effectivement, ton index a ces CSS imbriquée :

    #page { background: url(“images/fond_arkwright3.jpg”) repeat-y top; border: none; }

    Et sur ta page :

    #page { background: url(“images/kubrickbg3.jpg”) repeat-y top; border: none; }

    Vérifie le code de son header.php, ou ton index, un truc se passe de pas très catholique (ni très orthodoxe).

    #574927
    Rico
    Membre
    Padawan WordPress
    51 contributions

    Je sais, je suis juste parti du thème “default” et j’ai remplacé les images et retiré ce que je ne voulais pas afficher au fur et à mesure. Le #page était en double du départ, j’avais trouvé ça bizarre.
    Je viens d’essayer de virer le 2ème #page mais ça plante l’affichage avec un message d’erreur. :(

    C’est quel fichier pour l’index ? Comme kubrick3 est un carré blanc, j’ai justement voulu vérifier qu’il n’y avait pas un appel en trop quelque part mais je n’ai pas trouvé.

    #574928
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    index.php, dans le thème courant.

    #574929
    Rico
    Membre
    Padawan WordPress
    51 contributions

    Rien vu de spécial.
    Et pour les deux #page imbriqués de la feuille de style, il y a un “else” donc c’est normal non ?

    #574930
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Ca dépend else. Donne le code complet 🙂

    #574931
    Rico
    Membre
    Padawan WordPress
    51 contributions

    #page { background: url(“/images/fond_arkwright3.jpg”) repeat-y top; border: none; }
    #page { background: url(“/images/kubrickbg3.jpg”) repeat-y top; border: none; }

    #574932
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Dans le seconde else, remplace “/images/kubrickbg3.jpg” par “/images/fond_arkwright3.jpg”.

    #574933
    Rico
    Membre
    Padawan WordPress
    51 contributions

    Ah ben oui dis donc…
    C’est bête comme chou et je me suis pris la tête là-dessus… même pour un newbie comme moi c’est la honte. Je vais me cacher.
    En tout cas merci beaucoup pour ton aide. 🙂

    PS : j’ai pas trouvé non plus comment mettre le [Résolu] dans le titre, sniff…

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.