[Résolu] post qui s’incruste dans mon affichage de pages (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
  • Ce sujet contient 4 réponses, 2 participants et a été mis à jour pour la dernière fois par Sinedb, le il y a 1 mois.
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2469612
    Sinedb
    Participant
    Initié WordPress
    25 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Ibid
    • Extensions en place : Woocommerce, Dokan, Elementor, Elementor Pro, Woo COmmerce simple auction
    • Nom de l’hébergeur : hostinger
    • Adresse du site : collectibles-factory

    Problème(s) rencontré(s) : J’ai un post qui s’incruste dans mon affichage de page

    Bonjour à tous,

    Afin d’afficher un résumé des différentes pages enfant, je pensais mettre un widget post dans un container0.

    Je fais une query manuelle pour afficher les pages qui m’intéressent.

    A première vue, aucun problème.

    Sauf que lorsque je visualise en réelle, j’ai un post de blog qui s’incruste ….

    Quelqu’un saurait m’expliquer ou j’ai fait erreur ?

    (j’ai essayé avec le theme Hello Elementor au cas ou, même problème)

    #2469665
    momofr@free.fr
    Modérateur
    Maître WordPress
    6879 contributions

    Salut, peut-être un souci de slug (doublon) ?

    #2469689
    Sinedb
    Participant
    Initié WordPress
    25 contributions

    Je suis en contact avec le support Elementor qui l’a passé en niveau 2.

    j’ai essayé de désactiver tous les plugs-ins, essayé avec le theme wordpress de base.

    Quand j’enleve tous les posts, rien ne s’affiche. Des que j’en rajoute un (en sélection manuelle), le post de blog tape l’incruste. Toujours celui la.

    Je vais creuser la notion de slug, je ne connaissais pas

    #2469711
    Sinedb
    Participant
    Initié WordPress
    25 contributions

    En regardant cette histoire de slug, je m’en vais jeter un oeil à mon post.

    Et là, un tilt. J’avais coché la case Sticky ….

    Intuitivement, j’ai senti que cela venait d’ici. Je décoche et ….

    Le post disparait !

    Voilà pour cette fois,  merci pour m’avoir mis sur la piste !

    #2469723
    Sinedb
    Participant
    Initié WordPress
    25 contributions

    La réponse officielle du support Elementor qui précise que le bug est identifié et vient des sticky post qui s’incrustent dans le widget « posts » en cas de sélection manuelle des posts à afficher. Ils sont sur le dossier et cela sera corrigé dans une prochaine mise à jour.

    This is due to a bug with the Posts widget’s Manual Selection feature. It’s impossible to exclude sticky posts, and that’s why all the sticky posts appear in the widget.

    This bug has already been reported to our developers. We are glad to inform you that the issue has passed the review and estimation process and has been added to the developers’ backlog. We can expect a fix to be released in one of the future plugin updates.

    I am unable to provide you with the ETA of the resolution of this issue, but once it is fixed, we will update the status on our changelog page: Changelog of Elementor | Elementor

    As a workaround, you might consider tagging/categorizing these posts and using the Include By -> Term to query for these posts in the Posts widget.

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.