Positionnement

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #484918
    Drakone
    Participant
    Initié WordPress
    22 contributions

    Ma configuration WP actuelle
    – Version de WordPress : 3.0.1
    Version du client MySQL : 5.0.81
    – Thème utilisé : TommyDesign
    – Extensions en place : Lightbox 2
    – Nom de l’hebergeur : Toile libre
    – Adresse du site : http://capatt.toile-libre.org/

    Problème(s) rencontré(s) : Bonjour à tous 🙂, sur le site que je suis en train de “créer” je n’arrive pas à avoir une marge au dessus de “Partenaires” dans la barre latérale. Je sais qu’il y a une histoire position: absolute ou relative mais j’ai là je ne vois pas comment faire.

    #735408
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    Je vais te donner la solution batarde que j’utilise c’est pas tres orthodoxe mais ca marche : insere un widget texte vide au dessus.

    LooooL

    #735409
    Red-rabbit
    Membre
    Maître WordPress
    688 contributions

    En fermant la balise ul du dessus ça devrait resoudre ton souci de marge. Dans le source de la page sidebar.php il doit y avoir une balise mal fermée vu que le partenaire est compris dans le widget des liens …

    #735410
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    voila ca c’est une solution plus orthodoxe :D

    #735411
    Drakone
    Participant
    Initié WordPress
    22 contributions

    J’ai bien peur que ce ne soit pas ça vu que j’utilise les widgets de manière automatiser avec la page d’administration Worpress :(
    A moins que ce soit le widget en lui même qui déconne.

    En plus j’ai vérifier avec firebug apparemment la balise

      ce ferme.

      Peut être que cette partie de la feuille de style peut aider :

      #barre_lateral {
      	float: right;
      	width: 180px;
      	margin-left: 20px;
      }
      
      #barre_lateral h2 {
      	margin: 14px 0px 3px 0px;
      	font-size: 18px;
      }
      
      #barre_lateral .textwidget { font-size: 12px; }
      
      #barre_lateral li img { margin-top: 4px; }
      
      a {
      	text-decoration: none;
      	color: #52251C;
      }
      
      li img {
          border: none;
          float: left;
      }
      
      li { list-style-type: none; }
      
      p, ul {
      	margin: 0;
      	padding: 0;
      }

      PS : Merci Aphrodite mais ce n’est même pas possible si je veux afficher mes liens des deux catégories avec le même widget. Mais s’il n’y a pas de solution(s) (ce qui m’étonnerais) j’utiliserais deux widget liens : Un pour les liens normaux et l’autre pour les liens partenaires, avec un widget texte vide au milieu. Ce qui me semble une solution un peu batarde comme tu dit :D

    #735412
    Drakone
    Participant
    Initié WordPress
    22 contributions

    Personne ? Sa dois pas être difficile il dois y avoir un truc qui m’échappe ^^.

    #735413
    Drakone
    Participant
    Initié WordPress
    22 contributions

    Je re-up une dernière fois avant fermeture.

    #735414
    Drakone
    Participant
    Initié WordPress
    22 contributions

    J’ai une ou deux infos en plus : Quelque soit l’ordre des catégories le titre de la catégorie inférieur comprend les images de la catégorie du dessus (testez avec Firebug). Ce qui ne permet pas la mise en forme du titre. Ce serait donc un bug du widget lien. Je viens de tester avec Chrome il y a le même problème.

    #735415
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    et le coups avec 2 widgets liens ca donne quoi ? chacun affichant une cat particuliere ?

    j’ai eu ca aussi je me suis pas trop posée de question moi ^^^hop hop hop 2 widget et un texte vide au milieu. mais comme dit plus haut c’est batard. mais bon. ca marche quoi 😉

    #735416
    Drakone
    Participant
    Initié WordPress
    22 contributions

    Et bien non sa ne marche pas :( je pense que la différence avec toi c’est que ce ne sont que des images.

    [img]http://www.hpics.li/7f31f3a[/img]
    [img]http://www.hpics.li/8c2afe4[/img]

    #735417
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    oui possible. jamais testé. Bug donc ?

    la il faudrait lavis d’autres personnes sinon remonter ca a WP en ticket puisque c’est un plugin intégré à WP

    #735418
    Red-rabbit
    Membre
    Maître WordPress
    688 contributions

    Et moi je confirme que c est un souci de balise mal fermée, y a le code de la sidebar a revoir et le code d affichage des widgets. C’est un souci a ce niveau
    Arf oui je parle pas de CSS mais de HTML …

    #735419
    Drakone
    Participant
    Initié WordPress
    22 contributions

    Oui tu as surement raison mais ce n’est pas moi qui a coder la sidebar, j’utilise la page d’administration. Donc c’est un bug.

    #735420
    Drakone
    Participant
    Initié WordPress
    22 contributions

    Comment ont fait ?

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.