[Résolu] Plus de prévisualisation ?

  • WordPress :4.9.4
  • Statut : résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2134725
    jipaqirep
    Participant
    Chevalier WordPress
    104 contributions

    Bonjour,
    <div id= »fwf_content »>Ma configuration WP actuelle :

    • – Version de WordPress : 4.9.5
    • – Version de PHP/MySQL : 7.1.13 / 5.5.55
    • – Thème utilisé : Momentous Lite
    • – Thème URI : https://themezee.com/themes/momentous/
    • – Extensions en place : AMP (0.6.2), Contextual Related Posts (2.4.1), Disable Comments (1.7.1), FooBox Image Lightbox (2.5.1), FooGallery (1.4.25), Forum_wordpress_fr (4.1), List Pages Shortcode (1.7.4), Subscribe to Comments Reloaded (180225), W3 Total Cache (0.9.6), Wordfence Security (7.1.2), WP-Piwik (1.0.19), WP-ServerInfo (1.64), WP Smush (2.7.8), WP to diaspora* (2.1.0), Yoast SEO (7.1)
    • – Adresse du site : https://drivrsdu.fr
    • – Nom de l’hébergeur : OVH

    </div>
    Problème(s) rencontré(s) :

    La prévisualisation vient de tomber en panne ? Je n’ai rien fait de spécial autre que édition de pages, mise à jour de plugin, rien de particulier.

    Lorsque je demande une prévisualisation du nouvel article en cours d’édition, ça envoie une url type « monsite.fr/p=1234&preview=true » et quelque chose le redirige vers « monsite.fr/p=1234 », qui est une erreur 404, heureusement puisque je n’ai pas encore publié l’article.

    Qu’est-ce que c’est ? Comment cela se répare ?

    Merci pour votre aide.

     

    #2135045
    Li-An
    Modérateur
    Maître WordPress
    20102 contributions

    Bonjour, désactivez les extensions, mettez un thème par défaut et testez pour voir.

    #2135323
    jipaqirep
    Participant
    Chevalier WordPress
    104 contributions

    Bonjour,

    Merci pour votre aide.

    Si je désactive toutes les extensions et que je mets un thème par défaut (tweenty seventeen), le phénomène persiste : j’obtiens une erreur 404 lorsque je demande une prévisualisation.

     

    #2135332
    Li-An
    Modérateur
    Maître WordPress
    20102 contributions

    Alors là, c’est super bizarre. L’extension de sécurité et celle de cache peuvent avoir une influence. Vérifiez que vous avez désactivé ces extensions suivant leurs recommandations. Éventuellement renvoyez les fichiers de WP en écrasant ceux existants, optimisez/réparez votre base de données, donnez-nous le contenu de votre htaccess.

    #2135460
    jipaqirep
    Participant
    Chevalier WordPress
    104 contributions

    Bonjour,

    Voilà déjà mon .htaccess des fois que ; ce fichier n’a pas changé depuis je ne sais combien de temps. Pour les plugins je les ai fermés depuis la page des plugins.

    #SetEnv PHP_VER 5
    SetEnv REGISTER_GLOBALS 0
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    order allow,deny
    deny from 142.11.193
    deny from 178.137
    deny from 46.118.119
    deny from 94.153.64
    deny from 37.221.162
    deny from 46.119.114
    deny from 195.242.218
    deny from 176.8.88
    deny from 46.118.115
    deny from 193.106.136
    deny from 5.135.125.183
    deny from 69.162.119.3
    deny from 198.2.203.26
    deny from 188.143.232.70
    deny from 217.69.133
    allow from all

     

    #2135461
    Li-An
    Modérateur
    Maître WordPress
    20102 contributions

    Vous avez deux fois le même code. Les extensions de cache et de sécurité sont un peu plus complexes que ça à gérer. Si vous avec une option de désactivation intégrée pour Wordfence, utilisez-la. Videz le cache de l’extension et le cache de votre navigateur.

    #2135495
    jipaqirep
    Participant
    Chevalier WordPress
    104 contributions

    Bonjour,

    Depuis que j’ai remis les extensions actives, la prévisualisation est revenue !

    Tout va bien donc, comprenne qui pourra, et merci pour votre aide !

     

    #2135530
    Li-An
    Modérateur
    Maître WordPress
    20102 contributions

    Ça arrive quelque fois (une histoire d’ordre d’activation d’extensions)… Vous pouvez mettre en résolu en haut à gauche.

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.