[Résolu] Plus de mise à jour WordPress (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #2406560
    Kmloujdi
    Participant
    Padawan WordPress
    71 contributions

    Bonjour,

    Ma configuration WP actuelle

    Version de PHP/MySQL : Php 7.4

    Thème utilisé : Donation

    Extensions en place : Yoast SEO

    Nom de l’hébergeur : 1and1

    Adresse du site : http://www.kafala.fr

    Problème(s) rencontré(s) :

    J’ai un site pour une association http://www.kafala.fr.

    Depuis un petit moment je n’ai plus les mise à jour proposé par WordPress. Je suis encore en version 5.5 de WordPress et sur le backend ça me dit que je suis à jour alors que nous sommes aujourd’hui à la version 6.

    Savez-vous pourquoi je n’ai plus c’est mise à jour et comment faire ?

    Merci par avance pour votre aide 🙂

    #2406876
    momofr@free.fr
    Modérateur
    Maître WordPress
    4657 contributions

    Salut, tu as sans doute installé ton WordPress depuis le cPanel 1&1 non ?

    Si oui, regarde si dans le cPanel il n’y a pas une gestion des mises à jour des instances WP installées depuis ce dernier.

    C’est un des défauts (en autres) de ce genre d’installation avec un fil à patte ( à éviter globalement).

    #2407182
    Kmloujdi
    Participant
    Padawan WordPress
    71 contributions

    Bonjour,

    Je suis bien chez ionos mais l’installation n’a pas été réalisée depuis le cPanel 1&1.

    Pourrait-il y avoir une autre piste ?

    Merci encore pour votre aide.

     

    #2407213
    Li-An
    Modérateur
    Maître WordPress
    26394 contributions

    Bonjour,

    Il y avait un questionnaire affiché, c’est dommage de ne pas l’avoir complété entièrement, car il peut aider à vous aider.
    Alors, merci de le copier-coller et compléter du mieux possible dans votre prochain post. Vous pouvez utiliser cette extension https://fr.wordpress.org/plugins/forum-wordpress-fr/ et copier/coller les informations en remplaçant le terme Apache par le nom réel de votre hébergeur (OVH, Ionos,…).

    Si besoin, consultez cette vidéo : https://www.youtube.com/watch?v=XOFGpSbNCmY

    #2407310
    Kmloujdi
    Participant
    Padawan WordPress
    71 contributions

    Bonjour et désolé 🙁

    Voilà les informations demandées et merci pour votre aide 🙂

    Ma configuration WP actuelle :
    – Version de WordPress : 5.5
    – Version de PHP/MySQL : 7.4.29 / 5.5.62
    – Thème utilisé : Donation
    – Thème URI : https://www.sktthemes.net/shop/donation-wordpress-theme/
    – Extensions en place : Advanced Custom Fields (5.12.2), Akismet Anti-Spam (4.2.4), API KEY for Google Maps (1.2.3), bbPress (2.6.9), bbPress Messages (2.0.9.1), bbPress Notify (No-Spam) (2.17.4), Contact Form 7 (5.4.2), Contact Form CFDB7 (1.2.6.4), Download Manager (3.2.43), Email Users (4.8.8), Event Tickets (5.1.10), Export Users to CSV (1.1.1), Forum_wordpress_fr (4.2), HelloAsso (1.1.3), If Menu – Visibility control for menu items (0.16.2), Imagify (1.10), Loco Translate (2.6.2), My WordPress Login Logo (2.4.1), NinjaFirewall (WP Edition) (4.5.2), ProfilePress (3.2.14), Really Simple SSL (5.3.2), ReCaptcha v2 for Contact Form 7 (1.4.0), Shortcodes Ultimate (5.12.0), Smart Slider 3 (3.5.1.7), The Events Calendar (5.10.0), Ultimate Member (2.4.1), Ultimate Member – reCAPTCHA (2.3.1), Under Construction (3.93), UpdraftPlus – Backup/Restore (1.22.12), Wordfence Security (17.4.6 This is a developer version), WordPress Importer (0.7), WPDM – Google Drive (1.4.0), WP Downgrade | Specific Core Version (1.2.5), WP Emoji One (0.6.0), WP Rocket (13.4.4), WP YouTube Lyte (1.7.19), Yoast Duplicate Post (4.1.2), Yoast SEO Premium (23.1 This is developer Version Yoast SEO Premium)
    – Adresse du site : http://www.kafala.fr
    – Nom de l’hébergeur : Apache

    En pièce jointe la capture d’écran de mon back end

     

    • Cette réponse a été modifiée le il y a 6 jours et 11 heures par Kmloujdi.
    • Cette réponse a été modifiée le il y a 6 jours et 11 heures par Kmloujdi.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2407321
    Li-An
    Modérateur
    Maître WordPress
    26394 contributions

    Bon vous avez une extension appelée WP Downgrade | Specific Core Version qui bloque les mises à jour. Vous êtes au courant ?

    Vous avez aussi deux extensions de sécurité – j’espère qu’elles ne fonctionnent pas en même temps.

    #2407419
    Flobogo
    Modérateur
    Maître WordPress
    18411 contributions

    Je comprends qu’on puisse attendre avant de faire une mise à jour majeure (d’ailleurs, rien n’oblige à la faire, même sur les versions récentes, il « suffit » de modifier wp-config.php en conséquence) ; par contre, je ne comprends pas qu’une telle extension, qui bloque toutes MAJ et met en danger de piratage les sites qui l’utilisent, a pu être acceptée au répertoire officiel WP !

    #2407432
    Lumiere de Lune
    Participant
    Maître WordPress
    20321 contributions

    @Flobogo l’extension permet à l’utilisateur de choisir ce qu’il fait. Ce n’est pas très différent de ne pas cliquer sur le bouton de mise à jour

    #2407488
    Kmloujdi
    Participant
    Padawan WordPress
    71 contributions

    Bonjour,

    C’était bien l’extension WP Downgrade | Specific Core qui bloqué les mise à jour… 🙂 MERCI !

    Concernant les extensions de sécurité, il s’agit bien de Akismet Anti-Spam et Wordfence Security ?

    Vous me conseillez d’en désactiver une je ne savais pas que ce n’était pas terrible d’en activer deux.

    Sinon j’ai réalisé la mise à jour vers WordPress 6 ça c’est plutôt bien passé j’ai juste un petit soucis d’affichage sur la page d’accueil.

    Je peux vous en faire par ici ou je dois ouvrir un autre sujet ?

    Merci encore ! 🙂

    #2407497
    Li-An
    Modérateur
    Maître WordPress
    26394 contributions

    @flobogo : ce n’est pas problématique pour moi puisque c’est faisable avec deux lignes de code. Fondamentalement, ça n’introduit pas de faille. C’est à l’utilisateur de gérer ses choix.

    #2407499
    Li-An
    Modérateur
    Maître WordPress
    26394 contributions

    Wordfence et Ninja Firewall – je préfère le second.

    Ouvrez un autre sujet pour votre souci d’affichage.

    #2407603
    Flobogo
    Modérateur
    Maître WordPress
    18411 contributions

    @lumiere-de-lune et @li-an : bien sûr, les utilisateurs sont libres d’installer cette extension qui bloque les MAJ, tout comme ils sont libres de ne pas faire les mises à jour. Mais si on ne fait pas la mise à jour, elle apparaît toujours disponible dans le tableau de bord. Ce qui me semble problématique avec cette extension, c’est qu’elle fait disparaître les avis de mises à jour qui ne s’affichent plus. D’où le risque de rester définitivement bloqué sur une version ancienne, sans même se rappeler pourquoi et comment : la preuve ici.

    Je trouve que l’extension devrait de temps en temps afficher un message de rappel genre « attention, vos mises à jour du core de WP sont bloquées. Êtes-vous sûr de ne pas vouloir mettre à jour ? » (tous les X mois, ou à chaque nouvelle mise à jour majeure, par ex). AMHA

    #2407649
    Li-An
    Modérateur
    Maître WordPress
    26394 contributions

    @flobogo : faut surtout pas oublier qu’on l’a installée 🙂

    #2407727
    Flobogo
    Modérateur
    Maître WordPress
    18411 contributions

    Ben oui, mais parfois, avec l’âge … 😁

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.