Plus d’administration lors de mise à jour WP 2.8.6 (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 36)
  • Auteur
    Messages
  • #475916
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.8.6
    – Extensions en place : ne sais plus trop… :(
    – Nom de l’hebergeur : free
    – Adresse du site : chuut

    Problème(s) rencontré(s) :

    J’ai mis à jour WordPress de la 2.1 vers la 2.8.6 par une upgade.

    Je n’ai plus maintenant d’interface d’administration… la page d’admin reste désespérément blanche. Le site, lui, fonctionne convenablement. Je ne sais pas quoi faire…

    Merci d’avance pour votre aide !

    #699855
    thalasso
    Membre
    Chevalier WordPress
    495 contributions

    A l’avenir, merci de remplir le questionnaire de support en incluant l’adresse du site, ça fait gagner du temps à ceux qui passent du temps à répondre bénévolement aux questions de support.

    Deux pistes :

    1) Dans le fichier texte .htaccess figurant à la racine de ton blog (crée-s-en un s’il n’y en a pas), il faut activer le PHP 5 via la procédure de ton hébergeur, à savoir en ajoutant la ligne suivante :

    php 1

    2) Efface tes cookies, efface le cache de ton navigateur, désactive Google Gears et relance ton navigateur avant de te reconnecter.

    #699856
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    Bonjour et merci

    Je n’ai pas renseigné l’adresse de mon blog pour la bonne raison qu’il s’agit d’un blog familiale et que par conséquent je ne souhaite pas qu’il soit divulgué au public. Toutes mes excuses si cela gêne le dépannage.

    J’ai donc activé php5 de la manière que tu mentionnes, en ajoutant un fichier .htaccess à la racine de mon site et en y inscrivant php 1
    – pas de changements
    J’ai également effacé cookies, cache (pas de gear chez moi) puis redémarré firefox :
    – pas de changements

    J’ai testé sur Chrome au cas où, et pas de meilleurs résultats.

    Je ne vois pas comment faire….
    Est-ce possible de downgrader ma version de wordpress ? et est-ce utile ? Peut être cela me permettrait t’il de résoudre le problème avant de remettre à jour vers la v2.8.6 ?
    Comme un nigaud, je n’ai pas pris soin de désactiver mes plugins avant la mise à jour. Peut être aurait t’il été judicieux de le faire, mais maintenant, le mal est peut être déjà fait; Est-ce que je peux les désactiver manuellement ?

    Merci d’avance

    #699857
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    Bonjour,

    vous pouvez mettre l’url de votre site,le temps de trouver la solution à votre problème puis modifier le message pour enlever l’url. 😉

    vous avez envoyé les fichiers WordPress 2.8.6 par FTP ,vous avez tout écrasé SAUFle dossier wp-content et le fichier wp-config.php.
    puis vous avez été à cette adresse urldevotresite/wp-admin/upgrade.php

    On est d’accord ?

    #699858
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    tout à fait d’accord.
    lors du pointage du lien d’upgrade, j’ai eut l’info qui disait que l’opération pouvait être longue puis lorsque j’ai validé ca c’est passé rapidement. (je n’ai pas un blog énorme non plus)
    Pour information complémentaire, j’ai fait une mauvaise installation lors de ma première tentative :
    J’ai créé un nouveau dossier pour installer le nouveau wordpress sans écrasement, puis j’ai lancé l’upgrade et je n’ai pas eut ce qu’on pourrait appeler de bons résultats (blog buggé, pas d’admin)
    J’ai ensuite relus (ca faisait tellement longtemps que j’avais pas mis à jour que j’avais oublié l’essentiel) la procédure et j’ai constaté qu’il fallait écraser tout sauf wp-content… J’ai donc refait selon la bonne technique et m’en voilà rendu au point où j’en suis.
    J’ai tenté aussi de solutionner mon problème à l’aide de l’extension mémoire de php et la ligne dans le wp-config pour étendre la mémoire également, sans résultat (les 2 extensions ont été faites séparément, je ne sais pas si je dois faire le .htaccess en même temps que la ligne dans le wp-config)
    Que dire d’autre….
    Ah ! oui, j’ai voulu supprimer mes plugins , j’ai donc renommé mon dossier plugins en plugins.old et j’ai créé un dossier plugins vide. Là j’ai constaté un phénomène étrange, j’ai réussi à avoir en guise de page d’admin, une page me disant que mon compte n’avait pas les droits suffisants

    You do not have sufficient permissions to access this page.

    alors que je suis persuadé d’avoir les droits suffisants !
    C’est pour cela que je souhaiterais discriminer le rôle de mes plugins. J’ai bien pensé à les retirer un par un pour voir mais c’est une opération laborieuse que je mènerais si vous me dites que ca peut être la raison (à chaque suppression je dois attendre quelques minutes pour que le cache serveur je pense, ai pris en compte la modif)

    #699859
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    Avez vous une sauvegardé de votre site ?
    Si oui refaites une installation.

    #699860
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    En fait (j’ai honte de l’avouer mais il ne faut pas que ce soit une barrière pour m’apporter de l’aide !) j’ai sauvegardé la totalité de mon installation wordpress (fichiers) mais je n’ai pas fait le backup de la base. Vous pensez bien sinon que j’aurais fait un retour arrière et j’aurais retenté la chose.
    Pour ma défense, ce n’est qu’un simple blog familiale sans prétention et toutes mes mises à jours précédentes se sont bien passées…. J’ai donc fait confiance à WordPress ! (bon ok c’est mal ! J’admet, et je remet pas la faute à WP qu’on soit d’accord)

    J’ai lu qu’il était possible de faire un downgrade mais que rien n’est garanti (et je le concoit très volontier). Mais comme le site fonctionne très bien, mais que c’est uniquement l’interface d’administration qui est inexistante j’ai bon espoir que le problème soit finalement bénin.

    Ne serait t’il pas possible par exemple de faire une installe neuve de wordpress (dans un nouveau dossier) et d’y remettre le contenu de l’ancien (articles, pages, comptes….) ?
    Je me moque à la limite si je perds mon thème car je comptais le changer.

    Bref, je suis à l’écoute de toutes solutions, mais non, pas fait de sauvegardes, je m’auto tape sur les doigts… (et que cela me serve d’exemple)

    #699861
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    Les hackers attaquent les anciennes versions de WordPress,c’est pourquoi il faut mettre à jour votre version de Worpdress,question de sécurité.
    Sans sauvegarde de votre base de donnée,comme faire ce que vous voulez,c’est la base de donnée qui a en mémoire,vos catégories,vos posts,etc..

    #699862
    Dric
    Participant
    Maître WordPress
    757 contributions

    J’avais eu un souci similaire en oubliant bêtement de mettre à jour le fichier de langage .mo dans wp-content/languages.

    Il est aussi possible que la structure de permaliens ai été écrasée/modifiée, tu peux essayer d’effacer le .htaccess à la racine de ton blog.

    #699863
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    C’est vrai qu’il a mis à jour à partir de la version WP 2.1.

    Chez Free il faut mieux éviter les permaliens.

    #699864
    alexsolex
    Participant
    Initié WordPress
    23 contributions
    Lupi wrote:
    Les hackers attaquent les anciennes versions de WordPress,c’est pourquoi il faut mettre à jour votre version de Worpdress,question de sécurité.
    Sans sauvegarde de votre base de donnée,comme faire ce que vous voulez,c’est la base de donnée qui a en mémoire,vos catégories,vos posts,etc..

    Je sais tout cela pertinament. Encore une fois mon blog est familiale et non référencé. Et même si je sais que je ne suis jamais à l’abri, je ne pense pas être la cible de prédilection de hacker. Et si toutefois je l’étais, l’intérêt pour eux serait très maigre.

    Bref, pour en revenir à la tentative de dépannage,

    Dric wrote:
    J’avais eu un souci similaire en oubliant bêtement de mettre à jour le fichier de langage .mo dans wp-content/languages.

    Je vais regarder, mais j’ai choppé ma version sur wordpress-fr.net, version francisée. Je pense que si c’était lié à ca, d’autres utilisateurs auraient fait un retour comme le mien.

    Dric wrote:
    Il est aussi possible que la structure de permaliens ai été écrasée/modifiée, tu peux essayer d’effacer le .htaccess à la racine de ton blog.

    Je le referais ca ne coûte rien, mais je pense l’avoir déjà fait (à moins de problèmes multiples…. je réessayerais)

    Lupi wrote:
    C’est vrai qu’il a mis à jour à partir de la version WP 2.1.

    Chez Free il faut mieux éviter les permaliens.

    Effectivement j’avais eut des soucis de permaliens à une époque chez Free… Maintenant que tu en parles ca me revient. Je ne me souviens plus par contre comment je l’avais résolu…. Je crois bien que c’était un problème de chmod qui n’était plus une commande supportée par Free, et de mémoire il fallait utiliser les htaccess pour donner les droits… Peut être en serait ce la cause ? Car là mon htaccess est vide sauf « php 1 » pour passer en php 5…
    Qu’en pensez vous ?

    #699865
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    Les chmods ne fonctionnent pas chez Free comme vous le dîtes,si vous voulez passez sous php5 alors mettre seulement dans le fichier .htaccess la ligne php 1 .

    J’ai bien compris que votre site était familial mais je vous parle en connaissance de cause,j’avais fait un site pour ma cousine sur ses filles,il y a quelques temps et un jour un hacker est passé par là,l’intérêt pour lui,simple,faire « chier » c’est tout.

    là à votre place,je réinstallerai WP 2.1 ,vous n’avez aucune sauvegarde de votre base de donnée même une vieille ??

    #699867
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    J’ai testé php5 parce que j’ai lu dans les forums que ca résolvait quelques trucs, mais pas dans mon cas visiblement.

    Et sinon je ne suis pas contre les mises à jour, c’est juste que je ne suis déjà pas très assidu dans le contenu de mon blog, alors encore moins dans les mises à jours :( (malheureusement)

    J’avais fait, fut un temps une sauvegarde, je ne sais pas si elle date de la 2.1 ou précédente… Faut que je la retrouve (plus j’avance plus vous me montrer à quel point j’ai honte !! lol ! bref je prend sur moi, le tout est de faire tout le possible pour restaurer)
    Admettons que je récupère cette sauvegarde, j’imagine qu’il faudra que je m’y prenne correctement pour ne pas perdre mon contenu ajouté entre mes sauvegardes ?

    Je vais tenter la restauration de ma 2.1 et je vous tiens au courant

    #699866
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    Re bonjour

    J’ai retrouvé une sauvegarde SQL de 02/2007.
    Je ne souhaite pas faire pire que mieux alors j’aimerais bien qu’on me guide vers la restauration… Merci d’avance.

    #699868
    alexsolex
    Participant
    Initié WordPress
    23 contributions

    Bon j’ai tenté de remettre le vieux blog avec ma vieille sauvegarde SQL et comme je le craignais ca n’a pas fonctionné. C’était même pire. Heureusement que j’ai pu remettre la sauvegarde de la 8.2.6 (ah oui cette fois j’ai fait un backup de ma base avant de faire plus de conneries…)
    C’est rageant, j’ai jeté un oeil dans mes tables SQL et j’ai tous mes articles….
    J’ai tenté d’ajouter un commentaire et ca fonctionne également, je recois un mail me demandant d’approuver ou refuser le commentaire…

    Y’a vraiment que l’interface admin qui m’est refusée…

15 sujets de 1 à 15 (sur un total de 36)
  • Vous devez être connecté pour répondre à ce sujet.