[Résolu] Plus d’accès à wp-admin (not available)

  • WordPress :5.2
  • Statut : résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2273692
    Heero
    Participant
    Initié WordPress
    3 contributions

    Bonjour à tous,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.8
    • Thème utilisé : Oblique
    • Extensions en place : All-in-One WP, Mega-Menu, Yoast SEO
    • Nom de l’hébergeur : 1&1
    • Adresse du site : http://www.3aikido-montbrison.fr

    Problème(s) rencontré(s) :

    Nouvel arrivant sur ce forum, je me permet de faire appel à vos connaissances pour résoudre un problème récent, qui me bloque complètement.

    Je ne peux plus du tout accéder à WordPress. Lorsque je souhaite accéder à wp-admin, le navigateur me renvoi une fin de non-recevoir:

    “not available”.

    J’utilise FileZilla.

    J’ai donc essayé différentes techniques. Tout d’abord la permission des fichiers:

    • J’ai passé tous les fichiers en 640.
    • J’ai passé tous les dossiers en 750.
    • J’ai laissé wp-config en 604.
    • Ensuite concernant les plugins, j’ai renommé le dossier “plugins” en “plugins_old” pour essayer de les désactiver, au cas où l’un d’entres eux pose problème. Aucun changement.
    • J’ai essayé de supprimer le fichier .htaccess après avoir pris soin de le sauvegarder sur mon disque: impossible de le supprimer, de le modifier, le renommer, le remplacer, ni même de modifier les droits d’accès au fichier. FileZilla me dit que je n’ai pas l’autorisation.

    Je commence à être un peu à cours d’idées. Les dernières modifications que j’ai effectué avant que WP plante, et dont je me souviens, sont les suivantes:

    • Modification du fichier “wp-config” pour intégrer le SSL.
    • Modification de certaines sécurité dans WP Security (Plugin All-In-One WordPress) mais je ne me souviens plus de toutes les modifications.
    • Déconnexion de mon compte directement sur le site.

    Si certains d’entre vous ont une idée sur la marche à suivre, je suis preneur.

    Bien à vous,

    Heero

    #2273695
    Li-An
    Modérateur
    Maître WordPress
    22361 contributions

    Bonjour, il faut que vous regardiez la doc de WP Security pour savoir exactement comment désactiver l’extension. Les extensions de sécurité sont délicates à gérer dans ce genre de problème.

    Il faut nous expliquer ce que vous avez fait à votre wp-config exactement. Je n’ai pas souvenir qu’il faille le modifier pour passer en SSL.

    #2273771
    Heero
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    merci pour votre retour.

    Concernant la modification de “wp-config.php” j’ai ajouté ce code pour que le site passe en https:

    define( 'FORCE_SSL_ADMIN', true );

    Je l’ai inséré en-dessous de la ligne suivante:

    define( 'WP_CACHE_KEY_SALT', 'Rg-{>;E}f:ut|h7E/;hx. wI<KA/OvoD~xo{*PKiI$CdtOr^gxOO[jrcy}D_:#}5' );

    La manipulation a dû marcher puisque le site est passé en https tout de suite après. Ça n’a pas duré longtemps puisque peu de temps après je n’avais plus accès au “wp-admin” et le site est repassé en http.

    J’ai essayé de faire la manipulation inverse en remettant le “wp-config.php” comme il était à l’origine mais l’accès à “wp-admin” m’est toujours refusé. Je ne pense donc pas que cela vienne de là.

    Je vais essayer de trouver le moyen de désactiver WP security. Hélas ayant déjà essayé de désactiver les plugins en renommant le dossier “plugins” pour le rendre inactif, j’ai peur que cela ne vienne pas de là non plus.

    [EDIT]: Je viens de me rendre compte que je n’avais pas renommé le bon dossier “plugins”. J’ai donc pû désactiver le plugin WP-Security et reprendre le contrôle de “wp-admin”.

    Reste à savoir d’où cela vient. Est-il possible de supprimer le plugin WP-Security en “dur”, directement par FileZilla et de le réinstaller pour que ce dernier soit dans sa configuration d’origine?

    Bien à vous,

    Heero

    • Cette réponse a été modifiée le il y a 1 mois par  Heero.
    #2273774
    Heero
    Participant
    Initié WordPress
    3 contributions

    Problème résolu:

    j’ai désactivé le (bon) dossier plugins. Cela m’a permis de récupérer le contrôle de “wp-admin”. J’ai renommé le dossier en “plugins” pour les réactiver. Puis je suis allé dans les extensions sur le tableau de bord, j’ai désinstallé le plugin WP-Security et je l’ai réinstallé. Plus de problèmes de fonctionnement. Il va falloir que je reconfigure ce plugin avec parcimonie pour éviter de me retrouver dans la même situation.

    Merci pour le retour,

    Bien à vous,

    Heero

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.