plugin textile2 : pb avec les caractères accentués

  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #451904
    Paddy
    Membre
    Initié WordPress
    20 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1.3
    – Thème utilisé : défaut
    – Plugins en place : textile2
    – Nom de l’hebergeur : celeonet
    – Adresse du site : pas encore en ligne

    Problème(s) rencontré(s) :

    bonjour à tous,

    je débute avec WordPress et avec la création de sites en général.

    souffrant de la difficulté à gérer la mise en forme avec l’éditeur par défaut, j’ai installé textile2 en espérant simplifier le problème.

    a priori il marche bien, mais les caractères accentués ne sont pas correctement codés et j’obtiens à la place des signes ésotériques comme è à la place de è.

    le problème ne se pose pas pour les titres des articles, seulement pour le corps de l’article et pour les commentaires.

    je précise que WP est configuré en utf-8 et textile2 en utf-8 en input et output.

    j’ai essayé de mettre en 8859-1 sans résultat.

    j’ai cherché dans ce forum et dans le forum officiel et je n’ai rien trouvé.

    Y-at-il d’autres utilisateurs de WP qui utilisent textile2 ici et ont-ils ce problème ? des idées pour une solution ?

    Merci d’avance

    #599578
    Paddy
    Membre
    Initié WordPress
    20 contributions

    bon, j’ai fini par trouver la solution dans un post d’un chinois sur site dédié à un fork de WordPress (Lyceum) qui s’est inspiré d’un forum sur Drupal… merci Google 🍺

    pour ceux qui seraient intéressé, voici la solution :

    Textile 2 plugin for wordpress works out of box with lyceum 0.34,
    assuming your are using english. Put the plugin in the plugin
    directory OR(?) the systemplugin directory will do it.

    But there’s a bug in textile:

    If you are using Chinese, like me, or languages with accented
    characters, it misbehaves. Chinese become unreognized characters.

    Here’s how to fix it:

    edit textile.php, search for keyword « char_encoding « 

    you will see

    // head_offset sets the amount to increase header level (i.e. h1. be$
    $textile->options = $this->settings;
    $textile->options = $this->settings;
    $textile->options =
    $this->settings;

    Change Encoding and InputEncoding to language code you are using, e.g
    utf-8, as it’s the default with lyceum installation? Anyway, I always
    use utf-8.

    Porblem fixed.

    Je reviendrai surement bientôt… :wp:

    Paddy

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.