[Résolu] Plantage site suite à MAJ Extension et malgré réinstallation ancienne sauvegarde (Créer un compte)

  • WordPress :4.7
  • Statut : résolu
15 sujets de 16 à 30 (sur un total de 36)
  • Auteur
    Messages
  • #1640471
    kati
    Participant
    Maître WordPress
    850 contributions

    Re,

    Je viens de m’inscrire sur 000webhost.

    En attendant de trouver une issue à mon souci, je vais essayer de transférer les dossiers de ma sauvegarde vers ce nouveau site…L’avantage c’est qu’au moins j’aurais la dernière version de WP 🙂

    #1640482
    Li-An
    Participant
    Maître WordPress
    28260 contributions

    Le désavantage, c’est que vous allez finir par avoir de la pub ou je ne sais plus quoi sur votre site. Vous pouvez avoir un hébergeur pour 3 euros par mois https://monarobase.net/hebergement

    #1640527
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonsoir,

    ça je m’en doutais un peu pour la pub. Je souhaite rester avec du gratuit. La direction n’a jamais compris l’intérêt d’un blog mais l’hôtel était visible et visité également par ce biais.

    Par contre quand vous parliez d’une réinstallation « propre », comment faudrait-il procéder??

    Bonne soirée.

    #1640540
    Li-An
    Participant
    Maître WordPress
    28260 contributions

    Ah zut, j’avais commencé à répondre mais je n’ai pas terminé.

    Méthode 1 : Vous exportez bien votre base de données, vous sauvegardez les fichiers de wp-content (ou wp-content/uploads avec uniquement les fichiers médias sans les thèmes et extensions – ce n’est pas nécessaire mais c’est une précaution). Vous supprimez les tables WP de la base de données via phpMyAdmin (qui commencent par défaut par wp_ si vous n’avez pas modifié le préfixe) (ATTENTION, à ce moment là vous perdrez toutes vos données si vous n’avez pas de sauvegarde de la base de données !). Et du coup, si vous allez sur le site, il va proposer l’installation. Vous refaites l’installation et vous aurez un wp tout propre.
    Pour revenir en arrière, il suffira d’effacer les nouvelles tables de la base et importer les anciennes.

    Méthode 2 : un peu tordue mais bon. Vous renommez le fichier wp-config.php (vous ne le supprimez jamais, vous feriez bien d’en conserver une copie). En allant sur le site, il va proposer une nouvelle installation. Vous faites l’installation en choisissant un autre préfixe que wp_ genre wptruc_. Vous aurez un WP tout neuf.
    Pour revenir en arrière, vous renommez (ou effacez carrément) le nouveau wp-config.php pour le remplacer par l’ancien. Par cette méthode, vous n’avez pas besoin d’effacer les tables de la première installation wp_ puisque le nouveau WP va utiliser celles wptruc_ (que vous pourrez supprimer quand vous n’en aurez plus l’usage).

    Méthode 3 : il y a peut-être quelque chose de plus malin mais je ne vois pas.

    Dans tous les cas, une sauvegarde au chaud de la base de données originale est l’assurance contre tout problème éventuel puisque vous pouvez toujours revenir en arrière. Soyez parano avec la base de données. Si vous avez un doute, posez la question. Avec Free vous n’avez pas le droit à l’erreur puisque vous êtes tout seul à gérer les sauvegardes.

    #1642660
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonjour,

    Bon je vous annonce la mort de mon blog !! J’ai fait votre deuxième manip en pensant que ça fonctionnerait mais même ça, ça ne marche pas.

    J’avoue qu’effacer la BDD sur phymyadmin me fais un peu peur..

    Je ne sais d’où vient le souci mais je ne ferais plus de MAJ des extensions directement.

    Si quelqu’un a une idée je laisse le post ouvert on ne sait jamais.

    Bonne fin de journée.

     

    #1643906
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonjour,

    Comme je suis têtue, j’ai remis les mains dans le FTP du blog de mon travail!

    Alors j’ai bien remis un fichier htacess correct et pour voir si ça venait de lui je l’ai renommé en .htaccess-test.

    J’ai toujours cette même erreur à la suite de cette manip

    <b>Parse error</b>: syntax error, unexpected T_OBJECT_OPERATOR in <b>/mnt/106/sdb/b/7/motelsavinien/wp-admin/index.php</b> on line <b>103</b>

    Là je vais avoir besoin d’un ou d’une spécialiste en PHP. J’ai localisé la ligne 103. Voici ce qui est écrit :

    $option = get_user_meta( get_current_user_id(), ‘show_welcome_panel’, true );
    // 0 = hide, 1 = toggled to show or single site creator, 2 = multisite site owner
    $hide = 0 == $option || ( 2 == $option && wp_get_current_user()->user_email != get_option( ‘admin_email’ ) );
    if ( $hide )
    $classes .= ‘ hidden’; ?>

    Ce que j’ai mis en gras c’est la ligne 103…

    Si quelqu’un sait comment réparer ce paquet de noeud. Merci d’avance.

    🙂

    #1643907
    Li-An
    Participant
    Maître WordPress
    28260 contributions

    Renvoyez tous les fichiers de WP par FTP en écrasant ceux qui existent déjà – vous ne perdrez aucune données.

    #1643915
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonjour Li-An,

    Je remplace vraiment tout??? Normalement je ne touche pas à wp-config, .htacess

    Merci de continuer de m’aider 😀

     

    #1643934
    Li-An
    Participant
    Maître WordPress
    28260 contributions

    Ces fichiers ne seront pas affectés, ils n’existent pas dans le pack, vous pouvez vérifier.

    #1736473
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonsoir,

    Post résolu étant donné que l’hôtel ferme définitivement ses portes en septembre…Plus besoin de blog.

    Merci quand même pour vos réponses.

    Bonne soirée.

     

    #1747416
    Flobogo
    Modérateur
    Maître WordPress
    19981 contributions

    Bon courage  😕

     

    #1755179
    ClaudiusII
    Participant
    Initié WordPress
    34 contributions

    Bonjour,

    WordPress et sa base ne sont pas en cause.

    J’ai eu ce problème d’erreur 500 – Erreur interne au serveur sur mon propre serveur. Cela vient bien effectivement du serveur donc dans votre cas Free. Ce sont des serveurs sous linux et deux problèmes entre autre ont provoqué cette erreur. Les droits sur toute l’arborescence du site.

    En faisant un chmod -R 0777 sur toute l’arborescence du site j’ai réglé le problème ou dans le .htaccess, il faut rajouter ceci :

    Options +FollowSymLinks

    Mais vous avez peut-être déjà essayé.

    Cordialement

    #1755237
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonjour,

    Je vous remercie pour vos messages.


    @ClaudiusII
    : j’ai inséré la ligne dans le .htaccess mais rien ne fonctionne.


    @Flobogo
    : c’est un mal pour un bien 😉

    Pas de regrets de toutes façons comme je l’ai dit plus haut, l’hôtel s’arrête définitivement à la mi-septembre donc…

    Je ne saurais pas pourquoi ça a planté d’un coup tant pis!

    Bonne journée à tous.

    #1760623
    ClaudiusII
    Participant
    Initié WordPress
    34 contributions

    Bonjour Kati,

    Malgré le post résolu et la fermeture de l’hôtel ce qui est triste, je vérifierai l’exactitude de ma ligne de code car je vous l’ai donné de mémoire étant en vacances et il manque peut-être quelque chose. Il serait intéressant de savoir pourquoi çà a planté.

    Bonne journée

    #1761712
    kati
    Participant
    Maître WordPress
    850 contributions

    Bonsoir,

    Ok à l’occasion pour comprendre.

    Bonnes vacances en attendant.

15 sujets de 16 à 30 (sur un total de 36)
  • Vous devez être connecté pour répondre à ce sujet.