[Résolu] piratage de mon site et impossibilité de rentrer dans mes sauvegarde (Créer un compte)

  • WordPress :6.1
  • Statut : résolu
  • Ce sujet contient 92 réponses, 5 participants et a été mis à jour pour la dernière fois par Flobogo, le il y a 1 année.
15 sujets de 16 à 30 (sur un total de 93)
  • Auteur
    Messages
  • #2453861
    jules971
    Participant
    Padawan WordPress
    54 contributions

    Merci Ferman

    je n’arrive pour l’instant pas a utiliser mes différentes sauvegarde

    je ne vais pas plus loin que la limite de taille,

    je ne me résous pas encore a refaire mon site, je vais épuiser d’abord tous le moyens

    #2453865
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Comme je vous le disais précédemment, il faudra tout faire manuellement et procéder par étapes. En préalable à toute autre chose, je vous suggère de faire une installation neuve de la dernière  version de wordpress  sur votre serveur local. Vous devez avoir un site vierge.

    #2453869
    jules971
    Participant
    Padawan WordPress
    54 contributions

    c’est fait, nouveaux wp et nouveau site local avec une nouvelle base de donnée phpmyadmin

     

    #2453870
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Maintenant, exportez votre base de données depuis votre hébergeur (exportez deux fois : une fois en format sql et une autre fois en format gZip). Faites aussi une copie par FTP  des dossiers et fichiers wp sur votre PC,  dans un dossier que vous aurez créé.

    #2453871
    jules971
    Participant
    Padawan WordPress
    54 contributions

    Merci beaucoup Ferman

    j’ai exporter de la base de donnée au format sql, et en cherchant bien j’ai trouvé la possibilité de l’exporter en format gZip

     

    pour le FTP j’ai un fichier que je n’arrive pas a telecharger .ftpquota

     

    • Cette réponse a été modifiée le il y a 1 année par jules971.
    • Cette réponse a été modifiée le il y a 1 année par jules971.
    #2453875
    ferman
    Participant
    Maître WordPress
    6996 contributions

    pour le FTP j’ai un fichier que je n’arrive pas à télécharger .ftpquota

    Pour simplifier, téléchargez uniquement le dossier wp-content. Oubliez les autres dossiers et fichiers

    Ensuite, sauvegardez votre site local:exportez votre base de données locale et faites une copie des dossiers et fichiers du site. Ceci pour ne pas avoir à le réinstaller en cas de problème pour ce qui suit.

    Dans phpmyadmin, Videz votre base de données locale (supprimez toutes les tables mais ne supprimez pas la base de données) et essayez d’importer la sauvegarde que vous avez faite chez l’hébergeur, d’abord en sql. Si ça ne marche pas, essayez en gZip. Pouvez-vous aller vérifier chez votre hébergeur la taille de votre base de données?

    La suite demain

    • Cette réponse a été modifiée le il y a 1 année par ferman.
    • Cette réponse a été modifiée le il y a 1 année par ferman.
    • Cette réponse a été modifiée le il y a 1 année par ferman.
    #2453905
    jules971
    Participant
    Padawan WordPress
    54 contributions

    Bonjour Ferman

    si je prend dans phpmyadmin l’ensemble des tables font 29,8 Mo

    si je prend chez mon hebergeur l’espace disque utilisé je suis a 1,6 Go

     

    concernant l’importation en .sql et en gzip j’ai un même message d’erreur

    #1050 - La table 'wp_commentmeta' existe déjà

    #2453907
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Bonjour,

    Ce message indique que vous n’avez probablement pas supprimé toutes les tables dans votre base de données locale. Voyez-vous ce qui est indiqué en pièce jointe (phpmyadmin)?

    Pouvez-vous aussi donner les valeurs indiquées par les flèches rouges dans le 2e copie d’écran? Pour les flèches horizontales, sélectionnez uniquement les tables les plus grosses (>1Mio) et donnez aussi le nom des tables correspondantes.

    Et pendant que vous y êtes, dans la table wp_users voyez-vous des utilisateurs anormaux?

    • Cette réponse a été modifiée le il y a 1 année par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2453931
    jules971
    Participant
    Padawan WordPress
    54 contributions

    quand je vide comme vous me l’aviez demandé precedement les tables de la  base de donnée , il y a des elements qui reste

    comme indiqué plus haut j’avais le message en rose

    quand je suprime il n’y a plus rien

    j’ai donc essayé d’ importer la base de donnée de mon site en ligne en .sql sur le phpmy admin de mon site local vide

    l’importation c’est fait sans echec

    apres importations

    les deux bases de données sont identique 21,7 Mo , 62 tables  33798 InnoDB

     

     

    concernant les users

    il y en a 3 , moi , admin et sam-mi qui ont respectivement admin@exemple.com et info@exemple.com

    je crois me souvenir qu’il est recommandé qu’il n’y en ai qu’un et qu’il faille supprimer les users inutile a l’installation du site en ligne

     

    #2453938
    ferman
    Participant
    Maître WordPress
    6996 contributions

    quand je vide comme vous me l’aviez demandé precedement les tables de la base de donnée

    Non, il y a eu un petit malentendu; je disais:

    Dans phpmyadmin, Videz votre base de données locale (supprimez toutes les tables mais ne supprimez pas la base de données)

    Effectivement si on ne fait que vider les tables on a le type de message que vous avez observé.

    Il faut maintenant remplacer le wp-content local par celui de votre sauvegarde . Attention: ne remplacez pas wp-config et .htaccess. Conservez ceux du site local (et ne mettez pas ceux du site distant).

    Dans phpmyadmin, ouvrez la table wp-options de votre base locale et dans les lignes contenant les « option_names » url et home (sans doute les deux premières lignes), remplacez les « option_value » correspondantes par l’url de votre site local. Pour faire ça simplement vous pouvez double-cliquer sur l’option_value, ce qui permet de la modifier.

    A ce stade, vous devriez pouvoir voir votre site en local mais tous les liens seront brisés. Si c’est bien ce que vous voyez on passera à la suite.

     

    #2453942
    jules971
    Participant
    Padawan WordPress
    54 contributions

    merci vraiment pour tous vos efforts

    mais je suis une vraie buse, j’ai honte

    j’ai bien trouver le moyen de changer l’url, dans option; mais je ne sais pas par quoi je la remplace

    #2453952
    ferman
    Participant
    Maître WordPress
    6996 contributions

    Bonjour,

    j’ai bien trouver le moyen de changer l’url, dans option; mais je ne sais pas par quoi je la remplace

    Je ne comprends pas. Vous avez bien installé votre site en local (avec quel serveur, wamp, local, autre ?) donc vous avez une adresse locale . C’est cette adresse locale qui doit remplacer celle de votre site en ligne dans wp_options locale (deux lignes à modifier).

    #2453958
    jules971
    Participant
    Padawan WordPress
    54 contributions

    Bonjour Ferman

    je n’arrivais pas a trouver quel url il fallait que je prenne, j’ai donc recreer une base de donnée, suivi toute les etapes

    et ça fonctionne, j’ai acceder enfin a mon site, merci mille fois Ferman et Lucien qui m’a conseillé de venir sur WPFR

    le site n’est pas completement conforme a ce que j’avais en souvenir, quelques soucis d’affichage (taille trop grande de quelques photos, perte de logo , bas de page disparu)

    toute les galeries sont là, l’architecture est préservé.

    encore Merci

    #2453959
    jules971
    Participant
    Padawan WordPress
    54 contributions

    maintenant , comment faire pour ouvrir ce site sur wordpress ?

    parceque là j’ai bien le site ouvert , mais pas wordpress

    j’ai loupé une etape ?

    y a t’il une erreure quelques part ?

    #2453961
    jules971
    Participant
    Padawan WordPress
    54 contributions

    j’ai essayé dans wp-option de modifier l’url en rajoutant /wp-admin/

    avec /wp-login.php  sans succes

    est ce que je me trompe de piste ?

15 sujets de 16 à 30 (sur un total de 93)
  • Vous devez être connecté pour répondre à ce sujet.