PHP 8. (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2372384
    olivierf95
    Participant
    Initié WordPress
    1 contributions

    Bonjour

    actuellement tous mes sites fonctionnent parfaitement avec WP 5.7 et PHP 7.4  (tout est à jour,  theme, plug in…)

    J’aimerai savoir si on peut passer en php 8.0 sans tout casser ?  (j’ai vu des plantages)

    Ou peut on passer en php 8.0 et revenir en en 7.4 si cela ne fonctionne pas ?

    Merci à tous

     

    #2372388
    PhiLyon
    Modérateur
    Maître WordPress
    27436 contributions

    Bonjour.

    Si tu es en WordPress 5.7 le minimum est la 7.4.1.

    WordPress est compatible avec PHP 8, en ce qui concerne les thèmes et extensions c’est à vérifier sur leur site.

    J’ai testé sur mon site local, j’ai eu quelques erreurs avec certaines extensions.

    Pour l’instant je reste en 7.4.1.

    Ou peut on passer en php 8.0 et revenir en en 7.4 si cela ne fonctionne pas ?

    Cela dépend de ton hébergeur mais en principe oui.

    🙂

    #2372416
    Loraga
    Participant
    Padawan WordPress
    65 contributions

    Bonjour,

    Ne vous embêtez pas forcément à être “en avance” avec les versions de PHP. Les développeurs d’extension/de thème ne suivent pas forcément ce principe. Vu que WordPress demande au minimum PHP 7.4, restez en PHP 7.4, car les développeurs vont se baser là-dessus. Quand WordPress annoncera PHP 8 au minimum, ce sera plus simple car la majorité des développeurs feront l’effort de maintenir la compatibilité de leurs applications.

    Pour connaitre le statut du support des versions de PHP, visitez cette page, vous pourrez constater que les mises à jour de sécurité ont toujours lieu pour PHP 7.3 et 7.4, ces versions sont donc toujours sécurisées, pas de souci pour rester en 7.4 🙂

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.