[Résolu] Perte téléversement media : impossible de créer le dossier wp-content/uploads (Créer un compte)

  • WordPress :6.1
  • Statut : résolu
  • Ce sujet contient 3 réponses, 1 participant et a été mis à jour pour la dernière fois par ucan, le il y a 1 année.
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2447536
    ucan
    Participant
    Initié WordPress
    31 contributions

    Bonjour,

    Ma config. actuelle :

    – Version de WordPress : 6.1.1 multi-site

    – Version de PHP/MySQL : 7.4.30 / 5.5.5

    – Thème utilisé : Enfold-Child

    – Extensions en place : Advanced Custom Fields (6.0.7), Dashboard To-Do List (1.2.0), Forum_wordpress_fr (4.2), Health Check & Troubleshooting (1.5.1), Leaflet Map (3.3.0), Optimus (1.6.3), Plugin Notes Plus (1.2.6), Reading Progress Bar (1.3), Schema (1.7.9.5), Simple Sitemap (3.5.9), Twenty20 Image Before-After (1.6.0), Ultimate Maps by Supsystic (1.2.11), UpdraftPlus – Backup/Restore (1.22.24), WordPress Importer (0.8), WP Grid Builder (1.5.9), Yoast SEO (20.2.1)

    – Extensions réseau en place : Comet Cache (170220), Fixed Widget (6.2.3), iThemes Security (8.1.4), WP-Sweep (1.1.5), WP Dashboard Notes (1.0.10)

    – Adresse du site : https://c-serp.fr/
    – Suis mon propre hébergeur (novice) : Apache/2.4.54 (Unix) NAS Synology DS718+

    —————————-

    Je ne parviens plus à uploader de media dans mon site. Ni dans le principal (pourtant parfaitement opérationnel depuis 4 ans) ni dans le sous-domaine ‘insights’ – récemment créé.

    Voici le message d’erreur qui remonte chaque fois que j’essaie de téléverser une image :

    Impossible de créer le dossier wp-content/uploads/2023/03. Son dossier parent est-il accessible en écriture par le serveur ?

    Via FileZila, j’ai vérifié que les répertoires de wp-content étaient accessibles en écriture et les ai à nouveau passés en 755. A priori tout va bien de ce côté-là.

    J’ai bien tenté de vérifier si les variables php du webstation Synology étaient correctement dimensionnées, mais n’étant pas expert, j’ai supposé que tout était ok de ce côté-là… rien de moins certain.

    Grâce à cet article (https://kinsta.com/fr/base-de-connaissances/wordpress-echec-ecriture-du-fichier-sur-le-disque/) j’ai été sensibilisé au dossier temporaire dont j’ignorais l’existence. A priori je n’ai jamais eu ce répertoire, aussi je ne pense pas que le problème vienne de là. Mais là encore rien n’est moins sûr.

    Bref, je n’y vois plus très clair dans cet environnement dans lequel je ne suis pas très familier. Les fichiers système restent désespérément ‘not writable’. Un coup de main ne serait pas de refus, histoire de reprendre ou d’explorer de nouvelles pistes…

    Merci d’avance pour votre aide.

    ——————–

    Ci-dessous une partie des infos du Santé du site. Je peux ajouter toutes les infos de php.ini sur demande.

    ### wp-core ###

    version: 6.1.1

    site_language: fr_FR

    user_language: fr_FR

    timezone: Europe/Paris

    permalink: /%postname%/

    https_status: true

    multisite: true

    user_registration: false

    blog_public: 1

    default_comment_status: closed

    environment_type: production

    site_count: 5

    network_count: 1

    user_count: 1

    dotorg_communication: true

     

    ### wp-dropins (1) ###

    advanced-cache.php: true

     

    ### wp-active-theme ###

    name: Enfold-Child (enfold-child)

    version: 0.1.0

    author: RV

    author_website: (undefined)

    parent_theme: Enfold (enfold)

     

    ### wp-parent-theme ###

    name: Enfold (enfold)

    version: 5.4

    author: Kriesi

    author_website: https://kriesi.at

    theme_path: /volume4/web/cserp/wp-content/themes/enfold

    auto_update: Désactivé

     

    ### wp-media ###

    image_editor: WP_Image_Editor_Imagick

    imagick_module_version: 1690

    imagemagick_version: ImageMagick 6.9.10-27 Q8 x86_64 2021-03-02 https://imagemagick.org

    imagick_version: 3.4.4

    file_uploads: File uploads is turned off

    post_max_size: 128M

    upload_max_filesize: 128M

    max_effective_size: 128 Mo

    max_file_uploads: 20

    imagick_limits:

    • imagick::RESOURCETYPE_AREA: 11 Go
    • imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    • imagick::RESOURCETYPE_FILE: 768
    • imagick::RESOURCETYPE_MAP: 11 Go
    • imagick::RESOURCETYPE_MEMORY: 6 Go
    • imagick::RESOURCETYPE_THREAD: 4

    imagemagick_file_formats: 3FR, 3G2, 3GP, A, AAI, AI, ART, ARW, AVI, AVS, B, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCREENSHOT, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV

    gd_version: bundled (2.1.0 compatible)

    gd_formats: GIF, JPEG, PNG, WebP, BMP

    ghostscript_version: not available

     

    ### wp-server ###

    server_architecture: Linux 4.4.59+ x86_64

    httpd_software: Apache/2.4.54 (Unix)

    php_version: 7.4.30 64bit

    php_sapi: fpm-fcgi

    max_input_variables: 1000

    time_limit: 300

    memory_limit: 256M

    max_input_time: 300

    upload_max_filesize: 128M

    php_post_max_size: 128M

    curl_version: 7.54.0 OpenSSL/1.0.2u

    suhosin: false

    imagick_availability: true

    pretty_permalinks: true

    htaccess_extra_rules: true

     

    ### wp-database ###

    extension: mysqli

    server_version: 10.3.29-MariaDB

    client_version: mysqlnd 7.4.30

    max_allowed_packet: 1048576

    max_connections: 151

     

    ### wp-constants ###

    WP_HOME: https://c-serp.fr/

    WP_SITEURL: https://c-serp.fr/

    WP_CONTENT_DIR: /volume4/web/cserp/wp-content

    WP_PLUGIN_DIR: /volume4/web/cserp/wp-content/plugins

    WP_MEMORY_LIMIT: 64M

    WP_MAX_MEMORY_LIMIT: 256M

    WP_DEBUG: true

    WP_DEBUG_DISPLAY: true

    WP_DEBUG_LOG: /tmp/wp-errors.log

    SCRIPT_DEBUG: false

    WP_CACHE: true

    CONCATENATE_SCRIPTS: undefined

    COMPRESS_SCRIPTS: undefined

    COMPRESS_CSS: undefined

    WP_ENVIRONMENT_TYPE: Indéfini

    DB_CHARSET: utf8

    DB_COLLATE: undefined

     

    ### wp-filesystem ###

    wordpress: not writable

    wp-content: not writable

    uploads: not writable

    plugins: not writable

    themes: not writable

    • Ce sujet a été modifié il y a 1 année et 1 mois par ucan. Raison : correction de coquilles... ;)
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2447762
    ucan
    Participant
    Initié WordPress
    31 contributions

    Nouveautés, si ça peut aider…

    1. J’ai un autre sous-domaine (demo) qui me sert de labo et lui bizarrement je peux télécharger des images comme habituellement. Pourquoi lui fonctionne et pas le site principal… ?
    2. Justement pour une maquette sur ce sous-domaine, j’ai eu besoin de tester des plugins. J’ai téléchargé sans problème Starfish Reviews, mais son fonctionnement capote : (cf.jpg joint)
      Warning: mkdir(): Permission denied in /volume4/web/cserp/wp-content/plugins/starfish-reviews/init/actions/starfish-pluginloaded.action.php on line 16 Call Stack: 0.0001 367784 1. {main}() /volume4/web/cserp/wp-admin/admin.php:0 0.0001 368264

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2447943
    ucan
    Participant
    Initié WordPress
    31 contributions

    Avançant dans mes investigations… pour info.

    je me suis rendu compte que sur mon sous domaine demo – celui sur lequel je peux toujours téléverser des images à la différence du site principal – le propriétaire des répertoires a changé depuis décembre 2022.

    Je ne suis plus le propriétaire de certains répertoires, bizarrement c’est http.

    Voir le jpg

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2450166
    ucan
    Participant
    Initié WordPress
    31 contributions

    Résolu.

    Pour info, après de nombreuses recherches sur les privilèges du répertoire d’installe du site sur Synology, j’ai fini par récupérer l’intégralité de mes droits en actionnant l’inclusion de mes permissions héritées. Le cache, les plugins, les images… tout se télécharge et se supprime parfaitement.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.