Perte encodage des accents après migration

  • WordPress :5.2
  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #2269050
    keita
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 4.8.5
    • Thème utilisé : Jefferson
    • Extensions en place :
    • Nom de l’hébergeur : Free -> Hostinger
    • Adresse du site :

    Problème(s) rencontré(s) :

    Après avoir rencontré des problèmes de lenteur avec les pages persos free, je me suis décidé à changer pour un hébergeur payant.

    J’ai donc exporté ma base de données (3.1.5) en fichier sql pour l’importer dans ma nouvelle base (4.8.5).

    Toutes mes tables ont un interclassement en “latin_general_ci”. A l’exportation on me demande l’encodage, je choisi “UTF-8”, je cherche et remplace dans wordpad ++ les références de mon ancien serveur, j’enregistre mon nouveau fichier sql en ayant coché “encodage en utf-8”.

    J’importe le tout dans ma nouvelle base en utf-8 (sans rien modifier en réalité).
    Je note que je peux mettre un interclassement général à ma base de données (celle sur free est vide) ici c’est utf8-general-ci.

    Je consulte mon site et remarque que tous mes caractères accentués apparaissent tels qu’ils le sont dans la BDD :

    les lignes du métro qui desservent les mêmes quartiers et les mêmes centres d’intérêts

    (le texte apparait tel quel dans la BDD, tout comme avec free).

    Sachant que je n’ai rien modifié dans le fichiers, qu’est-ce que j’ai loupé ? Est-ce un problème de compatibilité de version de mysql ???

    Lorsque je rentre un nouvel article, les accents s’affichent correctement.

     

    Merci d’avance pour votre aide, le problème n’est pas grave car le site fonctionne mais c’est quand même bien pénible de devoir déchiffrer les phrases…

Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.