[Résolu] PERTE DROIT ADMINISTRATEUR APRES MIGRATION (Créer un compte)

  • WordPress :5.7
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2379066
    envyworen
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4
    • Thème utilisé : twentytwenty-one
    • Extensions en place : Yoast SEO, ELEMENTOR
    • Nom de l’hébergeur : Perso
    • Adresse du site : preprod.maps-system.com

    Problème(s) rencontré(s) :

    Bonjour ici, je viens de migrer un site depuis un Wamp windows vers un hébergement perso.

    Depuis le migration je peut me connecter avec les utilisateurs, mais aucun n’est reconnu comme administrateur et il m’est impossible d’accéder à la page wp-admin. Je vois bien la barre wordpress, mais je n’ai aucune autre option que la déconnexion.

    Ce que j’ai déja fais:

    • Changement des url siteurl et home (et toutes les anciennes références au localhost)
    • Vidage cache navigateur + suppression cookies
    • Désactivation via la base de toutes les extensions (pas de plugin cache)
    • Modification en base des users avec le droit admin=> a:1:{s:13:”administrator”;b:1;}
    • Création d’un nouvel utilisateur en base et affectation droit admin

    Je bloque depuis plusieurs jours sur ce problèmes qui est assez gênant, est-ce que quelqu’un aurait une solutions.

    Merci

    #2379077
    envyworen
    Participant
    Initié WordPress
    3 contributions

    Je l’ai résolu pour ce que ça intéresse, c’était que mon serveur en ligne voyait une différence entre les maj et les minuscule.

    #2379111
    Flobogo
    Modérateur
    Maître WordPress
    17618 contributions

    Bonjour,

    c’était que mon serveur en ligne voyait une différence entre les maj et les minuscule.

    A quel niveau ? Pour la connexion ??

    #2379124
    envyworen
    Participant
    Initié WordPress
    3 contributions

    La connexion était possible, mais rien de plus

    L’erreur était dans base de donnée > wp_usermeta >meta_key > préfixetable_capatibilities

    Le préfix de ma table dans meta_key contenu des majuscule.

    #2379170
    Flobogo
    Modérateur
    Maître WordPress
    17618 contributions

    Bon, je n’ai pas bien compris, mais le principal, c’est que vous ayez retrouvé un fonctionnement normal.

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.