Perte de l’éditeur visuel et du javascript dans les post et pages (Créer un compte)

  • Statut : non résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #496182
    Aheli
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.1.3
    – Version de PHP/MySQL : 5
    – Thème utilisé : Striking
    – Extensions en place : Advaned custum fields, contact form 7, Contact Form to DB Extension, EZPZ One Click Backup, Multiple Category Selection Widget, Newsletter, Subpages Extended, WordPress Access Control, WP Content Slideshow
    – Nom de l’hebergeur : 1and1
    – Adresse du site : http://www.avocatsversailles.com/wordpress/

    Problème(s) rencontré(s) :

    Bonjour à tous,
    Je rencontre un pb souvent évoqué sur ce forum mais malheureusement la consultation des sujets précédents ne m’a pas apporté la solution : il s’agit de la perte de l’éditeur visuel dans la saisie (et maj) des posts et des pages.
    Je ne peux me contenter de l’éditeur HTML car la saisie de ce site important est géré par plusieurs personnes au sein de l’institution (ordre des avocats) et ils ne connaissent pas le HTML. De plus, toutes les autres fonctions javascript sont inopérantes en saisie car le bug sur le chargement de TinyMCE doit les perturber (par exemple les liens vers « ajouter une image » ou un média ne fonctionnent plus et même « image à la une » n’ouvre plus une fenêtre modale.
    Je précise que j’ai déjà beaucoup pratiqué wordpress et que j’ai déjà réalisé de nombreux sites (http://www.aheli.fr).
    J’ai essayé de désactiver et de réactiver les plug’ins un par un. Sans succès. Le pb est apparu durant la saisie des membres de l’annuaire des avocats. Je suppose que cela a à voir avec un caractère spécial dans l’un des champs de saisie, intégré dans la base, mais va savoir sur quel fiche annuaire (il y a 642 membres) !
    J’étais en 3.1.2 et j’ai installé la 3.1.3 mais le pb est resté.
    J’ai essayé également d’installer advanced tinyMCE en espérant qu’il intégrait ses propres javascripts mais cela n’a pas fonctionné non plus.

    Alors voilà : je fais appel aux habitués de ce forum qui auraient peut-être d’autres pistes de recherche à me fournir.
    Avec mes remerciements.
    Hervé

    #776351
    Aheli
    Participant
    Initié WordPress
    27 contributions

    J’ai poursuivi mes recherches mais sans plus de succès :
    La désactivation 1 par 1 de chaque plugin résout provisoirement le pb, mais ne l’identifie pas car ce n’est pas toujours le même plugin qui libère l’éditeur visuel ! Ceci m’a amené à penser qu’il s’agissait plutôt d’un pb d’allocation mémoire.

    J’ai alors créé un php.ini avec memory_limit à 32M (le max pris en compte par 1and1 en mutualisé) mais cela ne change rien.

    Une autre idée ?

    Merci pour votre aide !

    #776352
    jacky
    Participant
    Initié WordPress
    47 contributions

    Bonjour
    J’ai le même problème depuis la version 3. beaucoup plus gourmande en mémoire. Le problème vient que tu n’a pas assez de mémoire, certain hébergeur limite la taille à 32Mo et ne peux pas être modifié. La solution c’est de supprimer un plugin. Pour vérifier la taille utilisé par ton wordpress, installe le plugin suivant: wp-memory-usage, il ne prend pas de place, il te permetra de voir le plugin qui prends le plus de place. J’ai résolu mon problème en remplaçant le plugin contact-form par une page en php trouvé sur le web.
    Bonne soirée

    #776353
    LeMagicien
    Membre
    Initié WordPress
    16 contributions

    Moi aussi j’ai le même problème…

    #776354
    xknown
    Membre
    Chevalier WordPress
    119 contributions
    Aheli wrote:
    J’ai poursuivi mes recherches mais sans plus de succès :
    La désactivation 1 par 1 de chaque plugin résout provisoirement le pb, mais ne l’identifie pas car ce n’est pas toujours le même plugin qui libère l’éditeur visuel ! Ceci m’a amené à penser qu’il s’agissait plutôt d’un pb d’allocation mémoire.

    J’ai alors créé un php.ini avec memory_limit à 32M (le max pris en compte par 1and1 en mutualisé) mais cela ne change rien.

    Une autre idée ?

    Merci pour votre aide !

    Alors, vous avez identifié votre problème ?
    Sinon, vous pourriez vérifier qu’il n’y a pas d’erreurs javascript (en Firefox, console d’erreurs).

    #776355
    Aheli
    Participant
    Initié WordPress
    27 contributions

    Bonjour,
    Pb toujours d’actualité et toujours incompréhensible. J’ai ajouté le plugin wp-memory-usage suggéré par Jacky mais il ne détecte pas de pb de mémory (au passage il se trompe car j’ai créé un phpini avec 32mo de memory-limit – le max de mon hébergeur 1and1 – alors que wp-memory-usage me dit que je dispose de 256mo).
    Lorsque j’enlève les plugin un par un, il arrive que le pb se résolve seul et que la barre Tiny réapparaisse (ainsi que le javascript) mais ce n’est jamais le même plugin qui est en cause, et j’ai besoin des plugin que j’ai installés sur ce gros site client. Le client en question ne peut mettre à jour le site, je suis légèrement dans la m…
    Si d’autres idées, je suis preneur !

    #776356
    Vince64
    Membre
    Initié WordPress
    25 contributions

    bonjour

    Un an an après toujours le même problème, est ce que le passage à la 3.3 va régler le pb
    Même problème 2011

    Si une solution a été trouvé je prends 🙂🙂

7 sujets de 1 à 7 (sur un total de 7)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.