Permaliens, un tuto ???

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 18)
  • Auteur
    Articles
  • #456853

    franckydevil
    Participant
    Initié WordPress
    6 contributions

    Hello les WPnautes,
    Je voulais tester les permaliens sur WP (deja teste, jamais fonctionnes) et je me retrouve avec ma version 2.3.2 sans aucune idée.
    Malgré une zone sur le forum, le codex et des sites invitant a editer des fichiers inexistant, je me permets de poster à nouveau sur ce sujet.
    Comment faire avec un WP 2.3.2 chez un hébergeur (tout sauf Free) avec les Rewrite_URL activés sur son serveur Apache pour obtenir des permaliens ressemblants à http://www.monsite.com/catégorie/article.
    J’ai suivi des tutos et teste sur mon site, resultat je l’ai crashé, j’ai remis d’aplomb (merci phpmyadmin) et je voudrais savoir par quel magie (bizarre en info) comment les permaliens fonctionnent sur d’autres sites ???
    J’ai testé depuis mon hébergeur, Doesn’t work
    J’ai testé sur un serveur perso (Ubuntu 7.04, Apache 2.0 + mod.rewrite, PHP 5) un beau fichier .htacces avec les droits d’ecriture dans l’arborescence du site : Doesn’t woirk.
    Ensuite j’ai cherché du coté des plugins, j’ai donc testé PermalinksMigration : Doesn’t work.

    Si quelqu’un peut m’aider (en oubliant la solution du index.php/categorie/article), ca marche deja.

    Merci d’avance

    #620027

    franckydevil
    Participant
    Initié WordPress
    6 contributions

    Une lueur d’espoir dans ce tuto lié à Apache, en fait la solution se trouvait dans le Virtual Host apparement.
    Le lien pour paramétrer son serveur : http://prendreuncafe.com/blog/post/2006/06/20/473-installer-le-framework-php-symfony-sur-ubuntu-dapper-drake

    Pour être plus précis voici en exemple le fichier de conf :

    J’édite mon fichier /etc/hosts et je rajoute à 127.0.0.1 localhost nomDeMaMachine

    On active tout d’abord le mod Rewriting

    $sudo a2enmod rewrite
    Si vous faites un ls /etc/apache2/mods-enabled/ vous devriez voir un lien comme celui la rewrite.load -> ../mods-available/rewrite.load, votre mode Rewrite est installé.

    Ensuite éditer le fichier : gedit /etc/apache2/sites-enabled/000-default et y inscrire ce qui suit :

    
        AllowOverride All
        Allow from All
    
    
    
        ServerName [b]nomDeMaMachine[/b]
        DocumentRoot « /var/www/ »
        DirectoryIndex index.php
        Alias /sf /usr/share/php/data/symfony/web/sf
        
        
            AllowOverride All
            Allow from All
        

    Redémarrer son serveur Apache /etc/init.d/apache2 restart

    Faire les réglages des permaliens et ça marche ✅

    Je regarde de plus prés les options allouées par mon hébergeur sur la modification des fichiers de conf et vous tiens au courrant.
    @ plus tard

    #620028

    franckydevil
    Participant
    Initié WordPress
    6 contributions

    Je viens de finaliser la mise en place des permaliens http://www.monsite.com/%categories%/%articles% et ca marche. Non sans mal.
    Tout d’abord, j’ai pris le problème à l’envers car sur un systeme Ubuntu 7.04 c’etait les directives de mon Vhost qui n’etaient pas bonnes (quoique…) et chez mon hebergeur j’ai teste un truc qui marche pas trop mal. Le remplacement de l’argument RewriteBase / par RewriteBase /index.php
    J’ai aussi supprimé l’argument ./index.php de RewriteRule par ./ tout simplement.

    Une question, est ce que le .htaccess généré par WP est vraiment merdique ou c’est le serveur de mon hébergeur qui tourne à l’envers ?
    Toujours est-t’il que tout fonctionne et j’en suis ravi. Pour plus de sureté, j’ai aussi restreint les droits d’ecriture dans le fichier .htaccess, histoire de ne pas avoir de mauvaise surprise aux prochains changements.

    .htaccess modifié et fonctionnel (droits s/ FTP en


    r-x ou 005)

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /index.php
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./ [L]
    
    # END WordPress

    .htaccess d’origine (généré par WP), qui ne fonctionne pas.

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./index.php [L]
    
    # END WordPress

    Si ça peut aider car les tutos complets sur la question sont rares

    #620029

    AmO
    Participant
    Maître WordPress
    4961 contributions

    Si ca marche !

    #620030

    beginneuse
    Participant
    Initié WordPress
    4 contributions

    Et pourquoi justement « tout sauf free » ??

    Voilà, je crois que j’ai compris mon probleme en partie, j’ai changé dans wordpress la structure de mes permaliens qui étaient définis sur defaut et depuis ERREUR INTERNE 500, je n’arrive plus à annuler mon action, revenir en arrière comme avant où ca marchait bien…

    Je ne sais pas vraiment comment re-modifier le script des permaliens dans mon FTP, concrètement il se trouve où dans WP ? Et à quoi ca doit ressembler pour ca fonctionne chez Free ?

    Merci pour vos réponses!

    #620031

    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4913 contributions

    Pour retrouver un fonctionnement normal il faut d’abord supprimer le fichier .htaccess qui a du se créer à la racine du serveur FTP qui héberge WP.

    Chez Free, les permaliens sont possibles en suivant cette démarche : http://www.wordpress-fr.net/faq/content/4/6/fr/je-suis-chez-free-je-ne-parviens-pas-a-modifier-la-structure-de-mes-permaliens-toutes-modifications-entrainant-la-perte-de-l_acces-au-blog-et-l_affichage-d_une-erreur-500-comment-faire-.html?highlight=permalien

    #620032

    franckydevil
    Participant
    Initié WordPress
    6 contributions

    L’Erreur 500 sur Free.fr après personnalisation des permaliens.
    En gros,
    Suppression du .htaccess sur la racine du répertoire d’installation de WordPress (afficher les fichiers cachés sur votre logiciel de FTP).
    On revient sur la page http://monsite.free.fr (avec un joli thème nuked genre site de geeks) et on recherche le lien pour se connecter à la page d’administration (ou directement sur http://monsite.free.fr/wp-login.php).
    Puis, toujours avec le thème naked, remettre le paramétrage par défaut des permaliens OPTION/PERMALIENS.
    Rafraichir la page, tout devrait rentrer dans l’ordre.
    Comme le signale BenKenobi, aller sur le tuto proposé pour paramétrer les permaliens à la sauce Free.
    Merci aux admins de Free pour avoir désactivé le Rewrite…

    #620033

    tatam
    Membre
    Chevalier WordPress
    163 contributions

    J’ai eu pas mal de problèmes avec les permaliens, j’expliquerai bientôt ma manipulation.

    #620034

    Jazzman
    Membre
    Initié WordPress
    3 contributions

    Actuellement j’ai une Valeur par défaut

    exemple : http://www.mediaxys-prod.com/?p=123

    En terme de lien c’est pas propre. A priori il exite un plugin qui est « Permalinks Migration » et qui permettrait de modifier très facilement et rapidement les permaliens. On dit que pour un pour un meilleur référencement il est recommandé d’afficher dans les urls du blog, le nom de la catégorie suivie du nom de l’article.

    Sous cette forme : /%category%/%postname%/

    Ce plugin permettrait de faire cette manipulation très facilement et ajouterait automatiquement une redirection 301 sur tous les articles. C’est-à-dire que tous les liens serait mis à jour lors du passage de Google, ou autre moteur de recherche.

    Seulement, je voudrais savoir si cette manipulation est délicate.

    Le site est herbergé chez OVH, dois-je voir avec eux s’ils prenne en compte le rewriting avant toute migration.

    Merci.

    #620035

    brazz
    Participant
    Initié WordPress
    4 contributions

    Il y a quelque chose que je ne comprends pas: si je fais -en local- des modifs de structure des permaliens, ça marche très bien, tout est modifié, c’est OK et mes liens de homepage (Archives, catégories, etc) marchent. Quand je fais la même chose sur le serveur, les permaliens sont bien modifiés mais les liens de homepage ne marchent plus…
    Il y a vraiment encore beaucoup de choses à améliorer sous wordpress! En particulier dans la gestion des liens et leur intégration dans les pages par exemple.

    #620036

    brazz
    Participant
    Initié WordPress
    4 contributions

    Bon, je me réponds 😉 des fois que ça puisse servir à d’autres: je suis sous lighttpd et non sous apache (beaucoup trop lourd). Donc, là on n’a qu’un seul et unique fichier de config: lighttpd.conf, voilà! Dans mon cas, il me manquait juste une ligne dans le paragraphe Virtual Host qui va bien, la dernière… cela donne:

    $HTTP[« host »] =~ « (^|.)monblogamoiquivabien.fr » {
    server.document-root = « /repertoiredechroot/home/lighttpd/monblogamoiquivabien.fr/htdocs »
    accesslog.filename = « /repertoiredechroot/home/lighttpd/monblogamoiquivabien.fr/logs/access.log »
    server.errorlog = « /repertoiredechroot/home/lighttpd/monblogamoiquivabien.fr/logs/error.log »
    server.error-handler-404 = « /index.php »
    }

    C’est incroyable, je croyais que cette directive ne visais que les messages d’erreurs… grosse erreur !

    Quand tout sera au point (fin de semaine si le rhume me lache un peu 🙂 ) je posterai l’adresse du site qui fonctionne donc en lighttpd+worpress; son objet est justement les trucs et astuces de ce genre…

    #620037

    brazz
    Participant
    Initié WordPress
    4 contributions

    Ceci dit, si je suis content d’avoir réglé le problème avec juste une ligne dans la conf (pas de plugin wordpress spécial, rien) je n’ai pas encore trouvé la panacée en ce qui concerne l’établissement facile de liens entre pages et articles et vice versa. C’est vrai que là on s’écarte du blog pour aller vers le CMS!

    #620038

    mlledidi
    Membre
    Initié WordPress
    4 contributions

    Je n’ai rien compris du premier post déjà alors je risque pas d’être d’une grande aide malheureusement ..
    Quelqu’un pourrait m’expliquer avec un langage de débutant ?

    #620039

    barneynantes
    Participant
    Initié WordPress
    14 contributions

    Pour les débutants les permaliens sont dans la partie Admin de WordPress

    Dans réglages > permaliens

    Pour la Structure personnalisée, mon conseil est de mettre : /%postname%/

    #620040

    Miaz3
    Membre
    Initié WordPress
    6 contributions

    Merci Benkenobi pour le lien 😉

    Sinon je voulais savoir si il était possible de remettre le .Htacess une foix la modification faite?

    ++

15 sujets de 1 à 15 (sur un total de 18)
  • Vous devez être connecté pour répondre à ce sujet.