[Résolu] pb Javascript (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2290523
    Ahote
    Participant
    Initié WordPress
    20 contributions

    Bonjour et joyeux noël a tous :-),

    Ma configuration WP actuelle :

    serveur : Auto Hébergé sous debian 10 / Nginx / Mariadb 10.3.18 / php7.3 / Wp 5.3.2 (installation fraîche)

    client : debian 10 / firefox 68.3.0 ESR

    Problème(s) rencontré(s) :

    alors voila je tente depuis un moment de résoudre ce problème sans succès

     

    lorsque j’essaye de créé une page ou un article je tombe systématiquement sur un message d’erreur m’indiquant :

    L’éditeur nécessite JavaScript. Veuillez activer JavaScript dans les réglages de votre navigateur, ou essayez l’extension Classic Editor.

    j’ai aussi un message d’erreur dans le tableau de bord qui me demande JS pour faire fonctionné un widget …

     

    pourtant java est bien présent je ne comprend pas d’où vient le problème 🙁

    surtout que cela marchait très bien avant que je réinstalle WP

     

    merci d’avance et passé de bonnes fêtes

    Ahote

     

    ps: comment se fait il que wordpress se tourne vers le java alors que celui-ci semble voué a disparaître au profit du html5 d’ici 2020 ? je trouve ca étonnant ^^

    • Ce sujet a été modifié le il y a 8 mois et 3 semaines par Ahote.
    #2290537
    ferman
    Participant
    Maître WordPress
    2797 contributions

    Bonjour,

    comment se fait il que wordpress se tourne vers le java alors que celui-ci semble voué a disparaître au profit du html5 d’ici 2020 ?

    C’est surprenant; où avez vous vu ça?

    Est-ce que Java Script est bien activé.? Regardez ce lien.

     

    #2290594
    Ahote
    Participant
    Initié WordPress
    20 contributions
    #2290595
    PhiLyon
    Modérateur
    Maître WordPress
    26305 contributions

    Bonjour.

    Flash player et Java n’ont rien à voir.

    j’ai aussi un message d’erreur dans le tableau de bord qui me demande JS pour faire fonctionné un widget …

    Quel widget/extension ?

    🙂

    #2290598
    Ahote
    Participant
    Initié WordPress
    20 contributions

    Flash player et Java n’ont rien à voir.

    si je ne me trompe pas c’est flash player qui permet a firefox (ou autre navigateurs) de lire les contenus en JS du coup sans flash player le JS sur les site devient problématique

    ou je me trompe totalement ? ^^

     

    Quel widget/extension ?

    pas un widget en particulier en fait c’est inscrit juste en dessous de “EVENEMENTSET NOUVEAUTÉ WORDPRESS” dans la page d’accueil du tableau de bord

     

    je suis sur a 99% que le problème est coté serveur mais je ne sais pas ou exactement

    je soupçonne une erreur dans mon Vhost Nginx mais sans certitude

     

    j’ai pourtant bien le paragraphe qui je supose active le JS :

     location ~* \.(jpg|jpeg|png|gif|ico|css|js|svg|eot|otf|woff|woff2|ttf|ogg)$ {
     expires 10d;
     }
    vhost

     

    #2290599
    ferman
    Participant
    Maître WordPress
    2797 contributions

    Bonjour,

    si je ne me trompe pas c’est flash player qui permet a firefox (ou autre navigateurs) de lire les contenus en JS

    Je ne croispas. On n’est pas du tout obligé (heureusement) d’avoir flash player pour voir un site. (à ma connaissance tous les sites contiennent un minimum de js et/ou j-query)

    Et juste pour voir, avez vous essayé “classic editor”?

    #2290600
    Ahote
    Participant
    Initié WordPress
    20 contributions

    bonjour,

     

    Je ne croispas. On n’est pas du tout obligé (heureusement) d’avoir flash player pour voir un site. (à ma connaissance tous les sites contiennent un minimum de js et/ou j-query)

    avant c’était le cas ^^

    c’est bon a savoir 🙂 il faudra que je fasse des recherche pour ma culture personnel ^^ le java n’est pas mon fort …

     

    oui j’ai essayé classic éditor qui a priori marche

    mais entre temps je me suis aperçu que le “manque de java” me créait d’autre problème :

    • pas de possibilité de choisir un thème ( pas de bouton)
    • certaines pages du panneau admin ne s’affiche carrément pas …
    • sûrement d’autre chose que je n’ai pas encore vue ….

    du coup c’est assez problématique mdr ^^

    #2290604
    mathieu42
    Participant
    Chevalier WordPress
    101 contributions

    attention aussi à ne pas confondre java et javascript

    https://fr.wikipedia.org/wiki/Java_(langage)

    https://fr.wikipedia.org/wiki/JavaScript

    #2290626
    Ahote
    Participant
    Initié WordPress
    20 contributions

    oui pardon j’ai écris trop vite ^^

     

    #2290685
    Ahote
    Participant
    Initié WordPress
    20 contributions

    Bonjour,

    j’ai essayé une réinstallation de WordPress et une réinstallation de Nginx

    ca n’a rien changé 🙁

    je tourne en rond ca commence a me gonflé ….

    si qqun a une idée brillante je prend 😀

    #2291010
    Ahote
    Participant
    Initié WordPress
    20 contributions

    Bonjour/Bonsoir

     

    je suis finalement arrivé a régler le problème comme je le soupçonnait il y avait bien un problème au niveau de mon Vhost j’ai donc recréé un nouveau Vhost pour Nginx et ca fonctionne a nouveau !!! 🙂

    je ne pourrait pas dire exactement ou était l’erreur par contre .

     

    source de mon Vhost :

     

     

    upstream php-wp {
        server                    unix:/var/run/wordpress.sock;
    }
     
    server {
        listen                    80;
        listen                    [::]:80;
        server_name               mondomaine.com;
    	return                    301 https://$host$request_uri;
    }
     
    server {
        listen                    443 ssl;
        listen                    [::]:443 ssl;
    	server_name               mondomaine.com;
     
        root                      /var/www/wordpress;
    	
    	index			          index.php;
    	
    	ssl_certificate           /etc/letsencrypt/live/mondomaine.com/fullchain.pem;
        ssl_certificate_key       /etc/letsencrypt/live/mondomaine.com/privkey.pem;
    	ssl_trusted_certificate   /etc/letsencrypt/live/mondomaine.com/chain.pem;
     
    	ssl_dhparam               /etc/ssl/certs/dhparam.pem;
     
        ssl_protocols             TLSv1 TLSv1.1 TLSv1.2;
    	ssl_prefer_server_ciphers on;
        ssl_ciphers               'kEECDH+ECDSA+AES128 kEECDH+ECDSA+AES256 kEECDH+AES128 kEECDH+AES256 kEDH+AES128 kEDH+AES256 DES-CBC3-SHA +SHA !aNULL !eNULL !LOW !kECDH !DSS !MD5 !EXP !PSK !SRP !CAMELLIA !SEED';
    	ssl_ecdh_curve            secp384r1;
    	
    	ssl_session_cache         shared:SSL:1m;
        ssl_session_timeout       1440m;
    	ssl_stapling              on;
    	ssl_stapling_verify       on;
    	resolver                  8.8.8.8 8.8.4.4;
     
        add_header                Strict-Transport-Security max-age=31536000;
    	
    	location / {
    		try_files             $uri $uri/ /index.php?$args;
    	}
     
    	location = /favicon.ico {
    		log_not_found         off;
    		access_log            off;
    	}
     
    	location = /robots.txt {
    		allow                 all;
    		log_not_found         off;
    		access_log            off;
    	}
     
    	location ~ .php$ {
    		include               fastcgi.conf;
    		fastcgi_pass          php-wp;
    	}
     
    	location ~* .(js|css|png|jpg|jpeg|gif|ico)$ {
    		expires               max;
    		log_not_found         off;
    	}
    }

     

     

    • Cette réponse a été modifiée le il y a 8 mois et 2 semaines par Ahote.
11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.