Pb codage dans « En-tête du thèpme »

  • WordPress :4.9.4
  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #2151579
    Rosalie-novice
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.6.30  (je ne sais pas si c’est juste, le « forum-wp-fr » ne peut être ajouté il n’existe plus.)
    • Extensions en place : Yoast SEO, UpdraftPlus
    • Nom de l’hébergeur : 02switch
    • Adresse du site : https://rah-astrologiehumaniste.com
    • Version WordPress : 4.9.5
    • Thème : Enfold

    Problème(s) rencontré(s) : Depuis que j’ai passé le site en https, puis reconfiguré Google Analytics et Search console (11 mai), dans les résultats de Google Analytics je n’ai plus les résultats des données (liens internes, externes et mailto). Pensant ne pas avoir mis dans wp le code « global site Tag search console au bon endroit, j’ai écouté un autre tuto qui proposait d’aller dans « Apparence, Editeur, Thème parent de Enfold, En-tête du thème et d’insérer le code avant « Head ».

    J’ai fait des erreurs de manip et enlevé un <?php que j’ai réussi à remettre mais visiblement pas au bon endroit. Maintenant il y a une barre noire au-dessus du menu et lorsqu’on fait défiler la page c’est du texte de la page qui apparaît. Du coup je ne sais pas s’il y a des espaces en trop ou en moins entre les codes, ou s’il manque un autre code ?

    Si je refais la mise à jour en 4.9.5 cela va-t-il corriger le problème ou au contraire l’amplifier ? Ou alors, est-il possible de voir ci-dessous la page des codes et de vérifier ce qui ne va pas.

    <?php
    
    if ( !defined('ABSPATH') ){ die(); }
    
    
    global $avia_config;
    
    
    $style                                                 = $avia_config['box_class'];
    
    $responsive                                        = avia_get_option('responsive_active') != "disabled" ? "responsive" : "fixed_layout";
    
    $blank                                                            = isset($avia_config['template']) ? $avia_config['template'] : "";
    
    $av_lightbox                          = avia_get_option('lightbox_active') != "disabled" ? 'av-default-lightbox' : 'av-custom-lightbox';
    
    $preloader                                         = avia_get_option('preloader') == "preloader" ? 'av-preloader-active av-preloader-enabled' : 'av-preloader-disabled';
    
    $sidebar_styling                     = avia_get_option('sidebar_styling');
    
    $filterable_classes     = avia_header_class_filter( avia_header_class_string() );
    
    $av_classes_manually           = "av-no-preview"; /*required for live previews*/
    
    $av_classes_manually   .= avia_is_burger_menu() ? " html_burger_menu_active" : " html_text_menu_active";
    
    
    ?><!DOCTYPE html>
    
    <html <?php language_attributes(); ?> class="<?php echo "html_{$style} ".$responsive." ".$preloader." ".$av_lightbox." ".$filterable_classes." ".$av_classes_manually ?> ">
    
    <head>
    
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    
    <?php
    
    /*
    
    * outputs a rel=follow or nofollow tag to circumvent google duplicate content for archiv * located in framework/php/function-set-avia-frontend.php
    
    */
    
    if (function_exists('avia_set_follow')) { echo avia_set_follow(); }
    
    ?>
    
    
    
    <!-- mobile setting -->
    
    <?php
    
    
    if( strpos($responsive, 'responsive') !== false ) echo '<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">';
    
    ?>
    
    
    
    
    */
    
    <?php
    
    
    
    wp_head();
    
    
    ?>
    
    
    
    
    </head>
    
    
    
    
    
    <body id="top" <?php body_class($style." ".$avia_config['font_stack']." ".$blank." ".$sidebar_styling); avia_markup_helper(array('context' => 'body')); ?>>
    
    
    <?php
    
    
    if("av-preloader-active av-preloader-enabled" === $preloader)
    
    {
    
    echo avia_preload_screen();
    
    }
    
    
    ?>
    
    
    <div id='wrap_all'>
    
    
    <?php
    
    if(!$blank) //blank templates dont display header nor footer
    
    {
    
    //fetch the template file that holds the main menu, located in includes/helper-menu-main.php
    
    get_template_part( 'includes/helper', 'main-menu' );
    
    
    } ?>
    
    
    <div id='main' class='all_colors' data-scroll-offset='<?php echo avia_header_setting('header_scroll_offset'); ?>'>
    
    
    <?php
    
    
    if(isset($avia_config['temp_logo_container'])) echo $avia_config['temp_logo_container'];
    
    do_action('ava_after_main_container');
    
    
    ?>

     

    D’avance merci, si tu peux me sortir de ce mauvais pas.

    • Ce sujet a été modifié le il y a 4 months par  PhiLyon.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.