Passage de WP 2.1.3 à 2.2.1= Fatal error ! (Créer un compte)

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #453257
    uZi
    Membre
    Chevalier WordPress
    104 contributions

    Salut!

    Je suis chez 1&1, et j’utilisais la versions 2.1.3 (en)et en passant à la 2.2.1 (en), j’ai eu ce msg:

    Fatal error: Call to undefined function: get_private_posts_cap_sql() in /homepages/41/d201084324/htdocs/wp-admin/index.php on line 64

    Ca faisait un petit moment que j’avais pas touché à mon blog et fait de maj, là j’avais qu’en même vérifié, mais je suis pas sûre de ce que j’ai fait, voilà comme j’ai fait:
    1. Désactivé les plugins.
    2. DL le nouveau WP, suppression de wp-content, wp-includes, wp-config-sample
    3. J’envoie tout sur le serveur
    4. wp-admin/upgrade.php
    5. J’ai le message

    No Upgrade Required

    Your WordPress database is already up-to-date!

    6. Réactivation plugins.

    Maintenant à l’affichage du site (www.dikizconnection.com) c’est bon. Mais:
    1. J’ai un bug dans le tableau de bord
    ssbugwppi3.th.jpg
    2. En cliquant dans les autres onglets (écrire, gérer….) il est dit en bas de page que ma version est toujours 2.1.3

    Bref, je comprends pas pourquoi cette maj semble à moitié faite, et je ne vois pas ce que je dois faire pour régler le pb. Merci d’avance pour vos suggestions 😉

    #606049
    ModoFX
    Membre
    Chevalier WordPress
    363 contributions

    Bonjour,

    Recommence la MAJ en suivant la même méthode… peut-être qu’un fichier a été corrompu durant le transfert des fichiers.

    Cordialement,

    #606050
    alakhnor
    Participant
    Maître WordPress
    996 contributions

    Essaie de recharger le fichier wp-includes/post.php déjà.

    #606051
    uZi
    Membre
    Chevalier WordPress
    104 contributions

    Salut
    j’ai fait pas mal d’essais, notamment avec la 2.2. qui ne marche pas mieux.
    Je suis revenu à la 2.1.3 avec laquelle je n’ai aucun pb.

    Par contre j’ai pas testé la suggestion de alakhnor, je le ferai lors de la prochaine release.

    Je vous tiendrai au courant!! 😉

    #606052
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Désactive tes plugins avant de mettre à jour.

    #606053
    uZi
    Membre
    Chevalier WordPress
    104 contributions

    Je l’avais promis, je le fais, et bien finalement j’ai réussi à passer la version 2.2.2 alors que la 2.2.1 j’avais tenté un paquet de fois…allez savoir pourquoi!
    🙂

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.