[Résolu] Passage de mon site en https -> problème les images ne s’affichent plus

  • WordPress :4.9.8
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 27)
  • Auteur
    Messages
  • #2222314
    loloQCB
    Participant
    Initié WordPress
    30 contributions
    • – Version de WordPress : 4.9.8
    • – Version de PHP/MySQL : 7.0.32 / 5.6.39
    • – Thème utilisé : Que C’est Bon – Elara Child
    • – Extensions en place : Akismet Anti-Spam (4.0.8), Async JavaScript (2.18.06.13), Autoptimize (2.4.1), Classic Editor (0.5), Cookie Notice (1.2.44), Dynamic To Top (3.5.2), Elementor (2.2.7), EWWW Image Optimizer (4.4.2), Forum_wordpress_fr (4.1), Instagram Feed (1.10.1), Jetpack by WordPress.com (6.7), Kirki Toolkit (3.0.34.1), Permalink Finder (2.5), Speed Booster Pack (3.7.2), Subscribe2 (10.22.1), W3 Total Cache (0.9.7), WordPress Database Backup (2.3.3), WP Fastest Cache (0.8.8.6), WP Force SSL (1.3), Yoast SEO (9.1)
    • – Adresse du site : https://www.quecestbon.be
    • – Nom de l’hébergeur : Apache

    Bonjour

    Débutant au niveau de l’utilisation de WordPress pour le site de ma femme j’ai un problème.

    Tout mon site fonctionnait bien en http://www.quecestbon.be

    J’ai suivi pas à pas le guide suivant pour le passer en https sans rencontrer de problème dans les manoeuvres

    https://wpchannel.com/wordpress/tutoriels-wordpress/passer-site-wordpress-https-guide-complet/

    Maintenant le site s’affiche mais les images sont manquantes sous firefox et mozilla mais certaines s’affichent sur Edge

    Est-ce que quelqu’un aurait un coup de main à me proposer ? Une solution ? Quelque chose que j’ai louper ……

     

    #2222322
    bkantique
    Participant
    Chevalier WordPress
    285 contributions

    Hello

    je pense qu’il y a eut un loupé dans ton passage en https car tes images sont toujours en http lorsque l’on regarde la balise href

    je ne sais pas si tu as beaucoup d’images mais sinon faudrait modifier le permalink des images à problème manuellement je pense

    #2222451
    loloQCB
    Participant
    Initié WordPress
    30 contributions

    Salut @bkantique

    Merci pour ta réponse.

    Bon il y a quand même 1400 images.

    J’ai utilisé le plugin Search and Replace et j’ai en effet trouver un peu plus de 1400 références http que j’ai fais changer en https mais rien ne se passe mes images sont toujours « absentes » 🙁

     

    #2222453
    bkantique
    Participant
    Chevalier WordPress
    285 contributions

    Ah en effet 1400 images mieux valait utiliser un plugin.

    Maintenant il faudrait peut-être vider ton cache (ou relancer le site) mais je ne garantis pas que cela marchera

    #2222454
    loloQCB
    Participant
    Initié WordPress
    30 contributions

    relancer le site ??? comment ??

    Vider le cache je l’ai fais via WP Fastest Cache mais rien ne change

    C’est tout de même bizarre qu’est-ce que je peux / dois faire ???

    #2222459
    bkantique
    Participant
    Chevalier WordPress
    285 contributions

    hum difficile de dire mais juste pour essayer tu pourrais regarder ce tuto en particulier la partie que faire après le passage en HTTPS pour voir s’il ne te manque pas une étape

    https://wpmarmite.com/wordpress-https/#apres-activation

     

    #2222561
    Noaneo
    Participant
    Maître WordPress
    29201 contributions

    Bonjour,
    si vous désactivez Jetpack, pareil ?

    #2222580
    loloQCB
    Participant
    Initié WordPress
    30 contributions

    Bonjour @Noaneo

    j’ai désactivé Jetpack et en effet des images sont revenues. MERCI 🙂

    Pourquoi ? Il y a un conflit entre Jetpack et le https ??

    Le problème c’est qu’une partie de Jetpack est utilisé pour le suivi des abonnés

    #2222593
    Noaneo
    Participant
    Maître WordPress
    29201 contributions

    @loloQCB Jetpack n’a pas une option lazyload ?  Parfois cela bloque les images.  Peut être désactiver lazy load ou autre fonctions liées aux images comme Photon.

    Jetpack est utilisé pour le suivi des abonnés ??
    un autre plugin, ne peut pas le faire ?

    #2222608
    loloQCB
    Participant
    Initié WordPress
    30 contributions

    Si mais il n’a pas l’air en cause car activé ou pas les images ne chargent pas.

    Oui en effet pour le suivi des abonnés c’est une connaissance qui me l’avait montré et je le trouvais facile

    Je vais devoir apparemment chercher après un autre

    En tout cas encore une fois un tout grand merci @Noaneo

    #2222628
    Noaneo
    Participant
    Maître WordPress
    29201 contributions

    Vous videz bien le cache de vote navigateur comme vous le désactivez ?
    Ou vider le cache de votre site.

    #2222629
    loloQCB
    Participant
    Initié WordPress
    30 contributions

    je vide le cache via WP Fastest Cache
    Je dois faire autrement ?

    #2222647
    Noaneo
    Participant
    Maître WordPress
    29201 contributions

    Il y a aussi le cache du navigateur a vider.

    Mais je trouve que Jetpack ralenti un site, je ne suis pas « fan » de ce plugin, si vous pouvez faire sans, je trouve, personnellement, que c’est mieux.

    #2222653
    loloQCB
    Participant
    Initié WordPress
    30 contributions

    Et dans une autre mesure je voudrais corriger ce problème que GtMetrix me communique mais je ne comprend pas le message ni évidemment ce que je dois faire pour enlever le problème

    #2222695
    Noaneo
    Participant
    Maître WordPress
    29201 contributions

    GTMetrix ?
    https://gtmetrix.com/reports/www.quecestbon.be/pB3t6KVF
    je ne vois pas de problème

15 sujets de 1 à 15 (sur un total de 27)
  • Vous devez être connecté pour répondre à ce sujet.