[Résolu] Pas d’indexation du site sur Google (Créer un compte)

  • WordPress :6.3
  • Statut : résolu
  • Ce sujet contient 6 réponses, 4 participants et a été mis à jour pour la dernière fois par Sevbreizh, le il y a 7 mois.
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2462201
    Sevbreizh
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Mes infos :

    • WordPress : v6.3.2
    • Serveur PHP/MySQL : 8.2.10/5.7.42
    • Thème : Twenty Twenty-Two
    • Extensions : BackWPup, Cookie Notice & Compliance for GDPR / CCPA, Elementor, Imagify, Royal Elementor Addons, WP Maintenance, Yoast SEO.
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.sophro34.fr

    Problème(s) rencontré(s) :

    Pas d’indexation de mon site par Google depuis sa création (ni sur d’autres moteurs de recherche). Je suis passée par Google Search Google pour accélérer son indexation et j’ai reçu un message m’indiquant que le site n’était pas indexé à cause de la présence d’une balise « noindex ». Or, avec l’ami développeur qui m’a aidait à configurer mon hébergement sur OVH (moi je n’y connais pas grand chose en informatique), nous avons vérifié et il n’y a pas de balise noindex dans le code. Il a ajouté un fichier robots.txt puis j’ai relancé une indexation le 20/09/23 qui n’aboutit toujours pas. J’ai effectué une nouvelle demande aujourd’hui 18/10/23 (cf. pièce jointe). Mon problème est-il désormais lié aux délais d’exploration de Google?

    Bien sûr dans WP, la case pour éviter l’indexation n’est pas cochée.

    Je ne sais plus quelle cause explorée : problème WP ? extensions (Yoast?) ? ou délai indexation Google ?

    Mon site ne contient pour le moment qu’une page.

    Merci d’avance pour votre aide.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2462269
    momofr@free.fr
    Modérateur
    Maître WordPress
    7106 contributions

    Salut, d’après cet outil d’analyse il n’y a pas de noindex sur ta page d’accueil.

    Sur Google Search Console tu as validé ton domaine ?

    Il faut valider les 4 URL de base :

    • https//www.mondomaine.com
    • https//mondomaine.com
    • http//www.mondomaine.com
    • http//mondomaine.com

    Puis lancer l’analyse du sitemap : https//mondomaine.com/sitemap.xml

    #2463556
    zoerafael
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Je me permets de suivre ce fil de discussion, car je rencontre le même problème sur un site que j’administre.

    Les infos du site :

    • WordPress : v6.4.1
    • Serveur PHP/MariaDB : 7.4.30/10.3.27
    • Thème : personnalisé
    • Extensions : Advanced Custom Fields PRO, Classic Editor, Contact Form 7, Redirection, Regenerate Thumbnails, TranslatePress – Multilingual, W3 Total Cache, WP Sync DB, WP Sync DB Media Files, Yoast Duplicate Post, Yoast SEO
    • Nom de l’hébergeur : ouvaton
    • Adresse du site : https://cine-corps.com

    Problème rencontré :

    Depuis la migration du site d’un hébergeur à un autre, le site n’est plus référencé (par Google principalement), à cause d’une balise <meta name=’robots’ content=’noindex, nofollow’ /> visible dans le header du site en code source d’un navigateur. Le site est bien inscrit dans la Google Search Console en :

    https://www.mondomaine.com
    https://mondomaine.com
    http://www.mondomaine.com
    http://mondomaine.com

    j’ai ajouté un fichier robots.txt avec :

    User-agent: Googlebot
    Disallow:
    User-agent: AdsBot-Google
    Disallow:
    User-agent: Googlebot-Image
    Disallow:

    mais ce qui est visible avec cine-corps.com/robots.txt est :

    User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-admin/admin-ajax.php
    
    

    Essayé avec All in One SEO Pack de supprimer un fichier robots.txt qui serait déjà là mais non visible dans Filezilla, malgré l’activation de l’option Forcer l’affichage des fichiers cachés. Essayé avec Yoast Seo de recréer un ce fameux fichier robots.txt, mais la balise meta noindex est toujours là et la Google Search Console ne peut pas indexer même une seule page. Le problème est le même sur 475 pages.

    Pourriez-vous m’indiquer des pistes de résolutions ?

    Merci d’avance pour vos conseils.

    #2463593
    Flobogo
    Modérateur
    Maître WordPress
    20163 contributions

    Bonjour,

    Désactivez votre thème personnalisé pour quelques jours (idéalement, mettez un thème de la série Twenty Twenty).

    Et pensez à vider le cache de W3 Total Cache à chaque fois que vous faites une manip’

    #2463607
    zoerafael
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Problème résolu.

    Pour info il s’agissait du dossier mu-plugins qui contenait une page disallow-indexing.php.

    J’ai pu m’en rendre compte en reconstruisant le site en local.

    Bonne journée

    #2463651
    Flobogo
    Modérateur
    Maître WordPress
    20163 contributions

    Merci pour l’explication. J’avais pensé à une fonction glissée dans le thème personnalisé. Un mu-plugin, c’est un peu le même principe : on y met des fonctions personnelles, qui deviennent obligatoires … et parfois, on oublie qu’on les a mises là. 😉

    #2463880
    Sevbreizh
    Participant
    Initié WordPress
    2 contributions

    Salut,

    Désolé pour mon manque de réactivité : toutes vos réponses étaient parties se cacher dans mes spams…

    Merci pour votre retour.

    Les mystères de la Google Search Console : après un 1er message m’indiquant que l’indexation de mon site n’était pas effective pour cette histoire de noindex, j’ai reçu quelques semaines plus tard un autre message m’indiquant que le site était indexé… alors que je n’avais rien corrigé…

     

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.