[Résolu] Pas de description dans Google recherche

  • WordPress :5.2
  • Statut : résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2297835
    JBenoit
    Participant
    Maître WordPress
    523 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : 5.3.2
    – Version de PHP/MySQL : 7.2.12 / 5.5.57
    – Thème utilisé : Destination Tanganyika
    – Thème URI : https://extendthemes.com/go/mesmerize-home/
    – Extensions en place : Admin Menu Editor (1.9.3), AdSense Integration WP QUADS (1.8.8), All Meta Tags (4.38), Backup (1.2.4), Black Studio TinyMCE Widget (2.6.9), Child Theme Configurator (2.5.2), Classic Editor (1.5), CM Tooltip Glossary (3.7.1), Content Views (2.3.1), Cookie Notice (1.2.50), Easy FancyBox (1.8.18), Forum_wordpress_fr (4.2), Google Language Translator (6.0.4), Google XML Sitemaps (4.1.0), Mesmerize Companion (1.6.111), MetaSlider (3.15.3), NextGEN Gallery (3.2.23), OG (2.7.6), Slider by 10Web (1.2.29), TablePress (1.10), TinyMCE Advanced (5.3.0), Wordfence Security (7.4.5), WP-Optimize – Clean, Compress, Cache (3.0.16), WP External Links (2.43), WP Statistics (12.6.12), Yoast SEO (13.0)
    – Adresse du site : https://www.destin-tanganyika.com
    – Nom de l’hébergeur : Apache

     

    Problème(s) rencontré(s) : J’ai découvert récemment que mes articles n’avaient pas de description dans les recherches GG. Sous le titre, est indiqué “Aucune information pour cette page”… En cliquant sur “découvir pourquoi”, il est question de robot.txt qui bloquerait l’indexation, seulement le fichier ne contient aucun “noindex” ou “nofollow”, je ne comprend pas, et donc ne sais pas comment remédier à ce problème.
    Un exemple de recherche où une page de mon site apparait avec cette formulation: https://www.google.com/search?q=lamprichthys+tanganicanus&rlz=1C1CHBD_frFR884FR884&oq=lamprichthys+tanganicanus&aqs=chrome..69i57j0l6.7458j1j4&sourceid=chrome&ie=UTF-8

    Pour moi elle apparait en 12ème place de la page.

    Merci et bonne journée.

    #2297900
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    Bonjour,
    L’extension Yoast SEO  est bien configuré ?
    Quand vous regardez le code source de la page
    https://www.destin-tanganyika.com/lamprichthys-tanganicanus/
    Vous voyez la balise description dans
    <!– This site is optimized with the Yoast SEO plugin v13.0 – https://yoast.com/wordpress/plugins/seo/ –>

    #2297915
    wrey75
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    C’est bizarre, en regardant de plus près j’ai remarqué que c’est la seule page du site qui semble être dans ce cas (faire une recherche Google en ajoutant “site:destin-tanganyika.com” sans les guillemets pour filtrer sur le site web).

    J’ai aussi remarqué que vous aviez bloqué le moteur Google-MediaPartners dans robots.txt (est-ce volontaire?). Vous pouvez tester votre fichier robots.txt ici: https://www.google.com/webmasters/tools/robots-testing-tool

    La version 13.0 de Yoast est très récente, il se peut qu’il y ait des bugs. En particulier, il y a bien des descriptions <META> générés pour les descriptions “Open Graph” (Facebook) et Twitter mais par pour le Web. Je ne sais pas si cela peut avoir une véritable influence.

    En espérant que cela puisse vous aider à trouver l’origine du problème. Bonne soirée.

     

    #2297922
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    Je me demande si les autres pages n’ont pas une description par défaut, le début du texte de la page ou de l’article.
    site:destin-tanganyika.com

    Si on prend ce lien
    https://www.destin-tanganyika.com/neolamprologus-similis/
    Description de Google : Entre cap Tembwe en R.D. du Congo et Kabogo en Tanzanie mais absent de Zambie (où l’on trouve N. multifasciatus).
    On voit qu’il manque la balise Description dans le code source de la page, il y a bien pour Facebook
    <!– This site is optimized with the Yoast SEO plugin v13.0 – https://yoast.com/wordpress/plugins/seo/ –>
    <meta name=”robots” content=”max-snippet:-1, max-image-preview:large, max-video-preview:-1″/>
    <link rel=”canonical” href=”https://www.destin-tanganyika.com/neolamprologus-similis/&#8221; />
    <meta property=”og:locale” content=”fr_FR” />

    Sur WP Formation, le robots.txt optimisé
    https://wpformation.com/robots-txt-wordpress/#creer-robots-txt-wordpress

    User-agent: *
    # URLs que je ne veux pas indexer : Login Trackbacks Commentaires
    Disallow: /wp-login.php
    Disallow: */trackback
    Disallow: /*/comments
    Disallow: /cgi-bin
    Disallow: /*.php$
    Disallow: /*.inc$
    Disallow: /*.gz
    Disallow: /*.cgi
    # URLs autorisées CSS JS Analytics pour les Bots
    Allow: /*css?*
    Allow: /*js?*
    Allow: /*?utm*
    Allow: /css/?
    # Autoriser Google Image
    User-agent: Googlebot-Image
    Allow: /*
    # Autoriser Google AdSense
    User-agent: Mediapartners-Google*
    Allow: /*

    Sitemap: https://monsite.com/sitemap_index.xml

    #2297955
    JBenoit
    Participant
    Maître WordPress
    523 contributions

    Merci pour vos réponses, j’ai vu l’erreur (a priori) dans le robots.txt, j’ai corrigé, je vais voir comment cela évolue ces jours-ci.

    Bonne journée.

    #2297956
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    Bonjour,
    Présentation des robots d’exploration Google (user-agents)
    -Supposons que vous souhaitiez voir s’afficher des annonces sur l’ensemble de vos pages. Toutefois, vous ne voulez pas que ces pages s’affichent dans la recherche Google. En utilisant ces lignes de code, vous bloquez Googlebot, mais autorisez Mediapartners-Google :
    User-agent: Googlebot
    Disallow: /
    # Autoriser Google AdSense
    User-agent: Mediapartners-Google
    Disallow:

    -AdSense : Mediapartners-Google : Mediapartners-Google

    Cela montre que vous aviez bloqué les annonces AdSense sur vos pages et non la description.

    Aviez-vous vérifier votre fichier robots.txt là https://www.google.com/webmasters/tools/robots-testing-tool

    comme l’avait suggéré @wrey75 ?

    #2297961
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    @jbenoit
    Avez-vous bien le snippet dans Réglages SEO – Yoast SEO, onglet Type de publication, cadre “Meta description” ?
    Voir exemple dans pièce jointe.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2297964
    JBenoit
    Participant
    Maître WordPress
    523 contributions

    Bonjour, non je ne l’ai pas, et il n’est pas proposé dans le déroulant.

     

    o_o

    #2297965
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    @jbenoit :
    Il faut suivre un tutoriel pour bien configurer les plugins SEO
    https://wpmarmite.com/wordpress-seo/#types-contenus

    La liste des snippets est sur le site de l’auteur Yoast
    https://yoast.com/help/list-available-snippet-variables-yoast-seo/

    Excerpt   %%excerpt%%        Replaced with the post/page excerpt (or auto-generated if it does not exist)

    #2298075
    JBenoit
    Participant
    Maître WordPress
    523 contributions

    C’est parfait, merci pour l’aide, les infos !

    Le truc, c’est que lorsqu’on pense qu’un plugin fait le taf seul, on ne pense pas qu’il faut lui donner des infos supplémentaires. Donc on fait comme moi, on ne fouille pas plus avant, et après on s’étonne… 🙂

    Bonne soirée.

    #2298076
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    Tant mieux, bien suivre le tuto de WP Marmite pour configurer le reste du plugin.

    Très souvent, il faut configurer un plugin, il ne faut pas juste l’installer puis l’activer.

    Comme Cookie Notice for GDPR & CCPA, il ne suffit pas de l’activer pour être en règle avec le RGPD.
    Il faut le configurer, avoir les trois boutons “J’accepte”, “Je refuse” et “En savoir” (lien vers la page Politique de confidentialité.
    Puis il faut activer l’option Révoquer le consentement.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.